[HOWTO] /e/cloud.global Change your recovery email

  1. How can I change the email address used to request password recovery and notifications?

  2. How can I change the language of the user interface?
    If I select a different language (e.g. English (US)) in the “Language” section, the interface language (German) doesn’t change.

I log off from /e/cloud and receive the following message:

Access prohibited
CSRF check failed

Zugriff verboten
CSRF check failed


What could be the cause?

Hi archie,
I couldn’t save the recovery email, too :frowning:
About the display language, did you try to change it within your browser ?

Pls have a look here https://community.e.foundation/t/change-my-e-account-mail/10751/5

The forum search is a nice tool :rofl: :rofl: :rofl:

Oops! That page doesn’t exist or is private.

@harvey186 /e/ support, what a great help! But I know you can do better if you just want to.

Hello @smu44, it was the first time I couldn’t change the display language with the web browser CLIQZ. During the test with the web browser SRWARE Iron it worked as it should immediately.

More important is …

Please refrain from personally attacks

Who is attacking whom personally???

@archie let me be clear - this site will not have personal attacks or sarcastic comments being made by any user. If I remember previously a list made about what @harvey186 had said in various posts was posted earlier in another thread. Language on the forum will have to be respectful of other users at all times. @harvey186 posted a link to a support email chat on the same subject. Which was not accessible. That can be mentioned in a better way. Pl check what you write before posting it.

@Manoj, I know what I’m writing and I am aware of my words. It goes without saying that I treat every user with respect. You see that very one-sided and biased!

@harvey186 is the only user who keeps posting “personal attacks or sarcastic comments”. That I will not be accepted without comment. @Manoj you must already lock me out of the forum to ban me from the mouth.

Why don’t you answer my question …

… or link to a possibly already answer?

@Manoj it’s ok. I can life with it.


1 Like

@harvey186 copying the part where Alexis gave a solution to the problem

I have just tried and have been able to change my recovery address on my side. As there is indeed no ‘save’ button, it is true it’s difficult to know what to do.

Can you try this and see if it works?

  • Go to https://ecloud.global/settings/user and change your recovery email,
  • Don’t reload the page
  • On the left handside menu, click on another category like Security or Activity

  • Go back to Personal Info and see if the email change remained.

It worked for me and i received a confirmation email about the change.

1 Like

@harvey186 , I can live with your side blows too. Our community leader apparently just doesn’t understand our german mentality. It’s also not easy, because “other countries other customs” and a language that isn’t our native language.

Your side blows will only not remain uncommented, unless I’m excluded from the forum participation. And then I won’t come back under a different name - that’s a matter of honour.

@harvey186, unfortunately the content of your screenshot does not help me.

Sorry, to hear. And also the HowTo from Manoj works ?

I have just made a test.
Open a ‘privat’ Browser tab (in Chromium)
Open ecloud
changing email and layout language
viola all done :slight_smile:

Yes, it works - now with both web browsers!

The change of the user language now also works with both browsers. I’ve not restarted the browser since the error was detected, but only opened new tabs. .

@Manoj [How to] is helpful. Thanks for that. “Just” click into the field »recovery email«", change the email address, don’t reload the page, click “Security or Activity” on the left side and go back to Personal Info: I didn’t think it could work so easy.

By the way:
I’ve received a "confirmation email " every time. A message for this doesn’t appear in /e/cloud.