[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

So is it Prenormal or is it not?

That is not bricking; the device is still talking to you!

@aibd - Thanks…I’m new to this so the terms are confusing me…

I don’t see the word Prenormal anywhere…I’m looking on the phone and it says:
BOOTLOADER AP SWAEV: 4 (really hard to read this one)

Lower down is says “Downloading… Do not turn off target!!”

On the PC Odin says:
<ID:0/015> Added!!

and nothing else.

So the bootloader is not locked. Two lines of “Custom” indicate it is not Samsug Official.

I guess it is now what Verizon is up to. I am in UK and have no experience.

You might try searching for the bootloader term you are struggling to read.


Maybe Verizon require a special situation to allow the Custom ROM to become authorised. Just a guess, but that expression I have not seen before, sorry.

Sometimes we see a disabler for a situation like this.

humm…after a few more restarts now it won’t display anything other than the “bring this to verizon store” message.

So…not bricked but just as useless?

Thanks for this tutorial!
I tried this on a Samsung Galaxy S5 neo (SM-G903F) and all steps seemed to run through without errors. But after the final reboot, I won’t see an “e” logo. Instead, there’s the original “Samsung Galaxy S5 neo - Powered by Android”. The phone will not boot, but stay there forever.

I used:

  • Odin3-v3.13.3
  • twrp-3.6.1_9-0-s5neolte.img.tar
  • e-1.1-q-20220630200240-dev-s5neolte.zip (had tried e-0.23-q-20220402175186-dev-s5neolte.zip before with identical result)

Thanks in advance!

Great article.

I apologize if somebody has already posted this info above (I couldn’t read the whole thread - too may posts :slight_smile: ):

If you’re working with a Samsung S10/S10e/S10+, at step 5, you’ll also need to add the vbmeta.tar file to the CP field (see this article: /How to/ install /e/ R on a samsung galaxy s10e already running android 12 - Using /e/OS / Setup - /e/ community)

1 Like

I failed to install /e/ on my S10e yesterday evening with this error.

I haven’t test your trick yet but I’m quite sure this will fix the problem. Many thanks for that!

@Anonyme May I suggest you amend your original post to add what @centaurus just mentionned for S10/S10e/S10+ devices? BTW many thanks for your very precious post!

I got the same error when trying to load without the vbmeta. Once I added the vmbeta file, the error went away.

Thank you very much for the help, this tutorial made it possible to install e/os/ after the easy installer failed on my Galaxy S9+ . However if someone runs into the same issue as me, I was not able to intsall the stable version with multiple different versions of TWPR. However what worked for me was to install the dev version on with an old version of TWRP (instead of the current twrp-3.7.0_9-0-star2lte.img.tar version fro my device , I used this version twrp-3.3.1-1-star2lte.img)

Excellent tutorial ! Thx mate :slight_smile: The easy installer was not working on my Samsung S9 SM-G960F. With this tutorial it went smooth as… (I don’t know what comes next, English is not my native tounge)

it says “in the “Options” tab (between “Log” and “Pit”) untick the “Auto-reboot” box.”, but I don’t even know where to look. in Android? in Download Mode? or in Odin? I cannot find an “options tab” in any of those places.


Other option is :
let the auto-reboot selected, click start,
Then hold ONLY the volume up bouton…
until the custom-recovery-manager logo (TWRP or recovery-e) appear on the phone.

thank you! but sadly, both don’t work, I never reach TWRP. with the method you described in your last post, also Android starts. with the method described in the original post (deselecting “auto-reboot” and sliding the finger from volume down to volume up while holding the two other buttons), my phone gets stuck in a screen just showing the logo “Samsung Galaxy S5 Neo”

I know how to reach this mode but this is no good right?


Unselect “auto-reboot” as it is recommanded, and click to start,
When “pass”, Unplug, extract the battery, reinsert the battery,
Then reboot by holdding volume up AND home AND power

with this method, again I’m stuck with the “Samsung Galaxy S5 neo” screen:(

do you try to install TWRP or the recovery-e ?
using Linux or Windows ?

Did you give up, or did you find a way?

I have done one 3-4 days ago… and I’m very impressed!
Great battery life!!

This is my TWRP and getting it into recovery mode is a bit of a hit and miss, unfortunately.
Needed 3 attempts right now, but hey it is worth it!

Also pleas note, you will get this warning on every boot, but you just click it away, it does not cause any problems.

[edit] in english

Does anybody know whether this works for Samsung S10?

TWRP or recovery-e ?
Linux or Windows ?

You may need to fash vbmeta along TWRP or recovery-e