[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Yes don’t forget to disable auto-reboot in Odin !

Maybe fate does not want me to enjoy an actual eOS Phone. It installed fairly easy on the S4 that cannot be used as a phone, and now that I have what should be a qualified S4 it will not install TWRP regardless of heimdall via Linux or Odin in the “simple” WIndows procedure. I have tried older versions of TWRP listed under jfltexx, and it always results in a FAIL immediately via Odin, where the blue bar on the S4 screen barely starts and then fails. When trying Heimdall in Ubuntu, the Blue bar completes but it never ever boots into TWRP. This is just madness. I tried using Windows Shell, and this is what works:
.\adb devices results in detection of the phone, but only when booted to normal use. Then:
.\adb reboot bootloader - results in download mode ok, THEN:
.\fastboot flash recovery twrp- results in an eternal hang “waiting for device”
I cannot make any sense of this anymore. It seems unable to detect the device when it is actually in download mode!

Note: There is actually a TWRP APP on the App Store. I installed that with an APK installer and executed it, which then takes you to select your device and downloads the .tar file but then does nothing with it!! Madness I tell you!

LAST EDIT ( I promise) Finally there is nowhere in ANY settings (I mean it… I looked through EVERYTHING) there is no “Auto Reboot” to disable. Not in regular settings and not in Developer. Just thought I’d throw that in.

Fastboot commands don’t work with Samsung

piero, your patience is amazing. I appreciate these post traumatic nuggets of knowledge. I wish there would be a clear concise instruction on these devices. These instructions are IN the specific Samsung How-to’s. So many landmines for the uninitiated. I will follow this most recent How To. Thanks.

Trying to follow this yellow brick road. Get to the Heimdall flash of TWRP and as usual FAIL, with this -
Initialising connection…
Detecting device…
Claiming interface…
Setting up interface…

Initialising protocol…
Protocol initialisation successful.

Beginning session…

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device’s PIT file…
PIT file download successful.

Uploading RECOVERY
ERROR: Failed to confirm end of file transfer sequence!
ERROR: RECOVERY upload failed!

Ending session…
Releasing device interface…

This may as well be a brick for all the use its going to be to me. Looks like I am stuck with an iPhone & big tech. I cannot afford hundreds of $ for an ePhone. Maddening. Just over the top maddening! I have been working at this for well over 24 solid hours, and its just one fail after another. I am burnt out

I hear your pain. Is it any good to stop and reflect with this? Know your hardware - Samsung

Haha… YES! ANY diversion right now would be good. I read the 1st paragraph of that article and chuckled. OBVIOUSLY I am one of a LONGGGG line of people to be driven into eMadness by Samsung Jedi Mind Tricks. I very much need a break from this before I throw the phone at a wall in a tantrum. Thanks. What makes this so incredibly painful is that when i 1st learned of eOS on youtube, I visited, and was successful my 1st try with a different S4!!! THAT phone however was a Sprint CDMA and it was just plain impossible to ge unlocked by the Spring/Boost/T-mobile people, and 3rd party Unlockers @ UnlockRiver specifically state that they cannot unlock a Sprint phone! So I have an eOS ion.S4 that is ok for wifi, but cannot be used as a phone! Got an AT& T unlocked S4… cannot do the eOS thing! Madness. I will read the Legend of Samsung now. Thanks for the info and diversion

So it’s not a SGH-I337M ?
witch is officially supported

it is probably a special ATTmodel SGH-I337




Yes its the AT&T SGH-I337 - People on ebay (including myself do not have any clue what or why there are 31 flavors of every model phone… well thats just great… I am done with this. It has beaten me. iPhone it is. Thanks for putting up with me. At least we’ve tracked down what is causing this permanent error. I hope someday this shitcan Big Tech Authoritarianism idea catches on in a bigger way. I wanted to do this very much, but it is definitely for Android experts. I have gotten an education here for sure. I learned how much I do not know.

1 Like

OK, so I am a sucker for punishment. I will try this. I thought yesterday was the end. I REALLY want this to work. I LOVE the entire idea of the e.foundation. You have been a light in a very dark place. Stay tuned.

If you still have the stock recovery, when you boot into it, you should see the device code there, to help confirm that you are proposing to use the correct ROM.

I’m tellin’ ya brothers and sisters, fate has something else in store for me. My collection of phones just don’t conform. I checked the Bootloader and its not one of the two needed for this untested install. See below:

WARNING: Your device must be on bootloader version I337UCUAMDB / I337UCUAMDL , otherwise the instructions found in this page will not work.
My Device Bootloader = I337UCSGOK3 - so won’t work.

One of these days something will go right. Until then I have a fabulous collection of useless Samsung phones! :wink:

I appreciate the fantastic helpful spirit of the eOS community.

Can you tell if jflteatt is correct?

If you are on
You can easily downdate to
with Odin

Because retrodating was not blocked on this device generation


1 Like

piero, DL the appropriate boot loader from Samsung. Followed their directions, and it failed in Odin just like TWRP.

I think Samsung wins - I lose the S4 wars. I certainly do not know where to go from here. The phone is clearly unlocked as my RedPocket acct recognizes it and developer options is set for ADB debugging. Its at the Odin/Heimdall stage that it fails every time as shown in the uploaded screen grab.

Have you tried the nanderase option ?

Hi, Ells, if you ever stop for a bit of reflection I wonder how you see your position compared to this user:

I have chosen a rather random point to break into a long unresolved thread :slightly_smiling_face:

Any point in this saga is random so its all good to me. Point about Nanderase above, yes I checked that option and retried and it did some stuff I do not know about and then just seemed to be done with no Fail or Success. So I tried running Odin again with Nanderase unchecked and it failed immediately. Not sure about what anything actually means or does. One note though reading through this other thread about the S9 - It brings up clearing all traces of ownership accts. I have searched high and low on the phone for how to even sign out of my alias Google acct and then there is an ATT contacts acct that I also do not know how to remove. Would these accts be the source of the failure? How do I eliminate them?

The rule of thumb is “remove all accounts” so if ATT appears to have some sort of prior claim on the device, that would be bad.

I definitely think it is worth further research how to remove them, because it is not clear ATT is claiming an account, as owner, is it?

Anything that exists in accounts, would be a blocker from what I understand.

It would trigger Factory Reset Protection. I cannot remember if you tried, but what happens when you do a Factory Reset from within Settings >> System ?

You might look at the Download mode screen, any clues there, you could perhaps send an image if in doubt.

Here is the fail screen in Odin failing with Nanderase checked.