[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Thanks for the additional info @Anonyme. I deviated from your procedure in a small way: I already had transferred the /e/ ROM zip file before installing TWRP (somehow thought that could be safer if for some reason my phone would not be recognised as a device in windows afterwards). Just to be sure: In this case it would have been deleted if I ticked “internal storage”, right?

By the way, is it important to place the /e/ rom zip on the internal storage or is external SD card fine too?

Yes it would have deleted the file you put into the internal storage. So in this case you did well by not ticking it :slight_smile:

My 2 cents : I had several issues with the latest build of TWRP and the fact is that it want to write in an non-existant directory when you want to install the zip file :
/cache/recovery/xxx
The workaround to complete the installation with this build of TWRP is to go to Advanced / Terminal and type :
mkdir /cache/recovery
Then go back to the installation of your zip file

2 Likes

Thank you for this great documentation! :+1:
After it didn’t work with easyinstaller i’m super happy to tell you that i finally got /e/OS running on my Samsung S8! :tada::sparkles::balloon:

  • I followed this “HOWTO”
  • to solve ERROR7 which encountered, i hat to take an older Version of TWRP (Version 3.3.3.1 instead of 3.4.0.0)
  • then i could install the latest version of /e/OS (e-0.12-p-2020102981459-dev-dreamlte.zip)

Thanks a lot :bouquet::heart:

1 Like

Hello to all and hello to the tutorial maker Anonyme!

I read (partially with help of a online translator) and try the installation of /e/ on an older Samsung Galaxy A3 (SM-A310) with the “a3xeltexx”-Image in the version e-0.12-o-2020093076269-dev-a3xeltexx from the site https://images.ecloud.global/dev/a3xeltexx/

All of the installation process ran smooth without problems (as far as I can see).
But after the last point, the system restart, hang the phone on the animation of the /e/ logo (booting?).

I do not dare to disconnect the USB cable from my computer. I wait since barely an hour and nothing changes, except the logo jumps.
I have used the TWRP 3.4.0-0-a3xelte from https://eu.dl.twrp.me/a3xelte/. Could not find the version 3.3.3.1 like mentioned above.

What can I do? Disconnect the phone? Restart? Could I try the installation again?
Please, could you help?

Thank you and have a nice day!

Hi @Insidetechnics, and welcome to /e/Land.

Try to reboot in TWRP mode,
go to the wipe menu and choose format /data, tip yes, tap enter, when done, tap back to the main menu and choose reboot to recovery.
Then, when rebooted, from the TWRP main menu, choose reboot to system.

If you have used TWRP 3.4.0-0,
go to the wipe menu, avanced wipe, and choose change/repair /data partition to ext3, when done, tap back ro the main menu.
re go to the wipe menu, avanced wipe, and choose change/repair /data partition to ext4, when done,tap back to the main menu and choose reboot to recovery.
Then, when rebooted, from the TWRP main menu, choose reboot to system.

twrp 3.4.0-0 is designed for android 10,
Better use twrp 3.3.0-0 for this device
https://eu.dl.twrp.me/a3xelte/

Hello piero,
thank you for your help!
Because I used TWRP 3.4.0-0 I must take only your second advice (the lower passage) with the option “Advanced wipe” in TWRP?
How can I reboot from the /e/ logo in the TWRP mode? Sorry for this “dumb” question but I will only nothing destroy…

To turn off : hold volume down and power boutons

To reboot in TWRP : hold volume up, home and power boutons

Hi piero,
only the the upper passage of your post:

can I do. The other with the advanced wipe ends with an error “corrupted(?) file sytem” or so.
But now after a reboot I’m in /e/!
Thank you thousand times!! :heart:

Thanks for this awesome tutorial. Everything is very clear described and at end my samsung Galaxy S9 runs with /e.

My Problems and solution:

custom binary blocked by FRP Lock:
I haven’t disable OEM thing, after that the whole system restarts

False Error with Odin
Solution:
I have to install the Samsung USB driver from you description

Wrong TWRP:
first i used twrp-3.4.0-0-starlte.img then i tried with twrp-3.3.1-1-starlte.img

How can i downgrade TWRP?
Solution:

and the final boss:
Error 7
Solution:
With the help of Minimal ADB and Fastboot i have to update “the vendors”
Here are the files to download:


after that i conected my phone with USB with the PC and start the tool “minimal ADB and Fastboot”
I renamed the file to verndors.zip and copy it to the tool folder
after that i typed in the tool:
adb sideload vendors.zip
In the device TWRP is started an i go to Advanced>ADB Sideload`

Then the blue bar appears. After that a short shock moment because the e stands there for a while but this great manual calmed me down. It takes a while

After all, thank you for this great puzzle activity in corona times :wink:
and thanks again for this manual

1 Like

Worked great, thanks so much!

Just flashed /e/ on my Samsung Galaxy S7 (SM-G930F) following this HowTo :slight_smile:

Tipps for other SM-G930F owners:

  • Step 4) I got new Odin (v3.14.1) here: https://odinsoft.site/download/install/
  • Step 5) I used “twrp-3.5.0_9-0-herolte”
  • Step 8A) I had this “Error” with the /data-partition: Changing to “exFAT” did not work (TWRP crashed so i had to re-flash Original Rom and start all over :frowning: …) Changing to “ext3” worked, then changing back to “ext4” as described

*cheers

PS:
The “/e/ EasyInstaller” was not working (error after trying to reboot to TWRP)…

For installing Nougat, Oreo, or Pie, DON’T use TWRP 3.4.x-x or 3.5.x-x, BUT use TWRP 3.3.x-x

/[HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully

Hi, I have a Samsung s7 edge (i assume it is the hero2lte one) and have made it up to step A.4. I got an error when I tried to wipe the phone. So I followed the steps to try and reformat to exFAT. This took at least an hour and so I went to bed, the phone was still connected to the computer so it would not die. This morning the screen was black and when I try and turn it on it just stays on the Team win screen with no options. I have tried to hold down the home+vol down + power buttons but get no result. The only thing that it will do is when I hold the power button it turns on and goes to the Teamwin screen again.

Any help would be much appreciated :slight_smile:

I think my problem sounds similar to yours. Can you walk me through re-flashing the Original rom?

I would add a tip to step 7

The problem I had was odin didn’t recognize my phone when it was in download mode. It would recognize it to charge or when running normally but not in download mode. I fixed this problem by opening device manager finding my phone under USB devices right clicking to update driver software then clicking on “Browse my computer for diver software” then choosing the option to “let me pick from a list of device drivers on my computer” then selecting Samsung Mobile USB CDC Composite Device" I clicked to install (the driver) unplugged and puled back in and was good to go.

@Jo_123

To factory-reset your phone:

  1. Get the right Stock-Rom for your device
    i got mine here: https://galaxyfirmware.com/
    search for your model (SM-G935?) and choose your region (i picked NEE for Nordern-Europe), click download

  2. Flash the Stock-Rom to your device with Odin
    heres a guide: https://androidspd.com/flash-samsung-stock-rom-with-odin/

  3. Boot your phone “normally”, you shloud now have a “clean-factrory-reseted” Android

  4. Start all over here (with enabling OEM-unlock…)

And then at Step 8, try changing to “ext3” first, then back to “ext4”

Hope u’ll get i done!

Please report here :wink:

Hi :wave:!

I’m stuck at step 6.6 Installing TWRP with Odin. After clicking Start, Odin was stuck at Setup Connection.

Finally the log output is:

<ID:0/005> Added!!
<ID:0/005> Odin engine v(ID:3.1303)..
<ID:0/005> File analysis..
<ID:0/005> Total Binary size: 28 M
<ID:0/005> SetupConnection..
<ID:0/005> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

Installing /e/ on Samsung SM-A510F, using Windows 10.

What can I do? Thanks for the help.

Edit:
Don’t mind me I already found out that 1. my cable didn’t support data and 2. I didn’t have the drivers.
From then on, things went super smoothly! Thank you. Is there some ritual now that I’m a /e/user?

1 Like

Thanks to whoever did this! Awesome, I’m supper happy with my new-old-safe-phone right now!

This has been tested and working fine on my SM-T805) and other devices that people confired. I’m not responsible for any bricks btw. Twrp Method:

  1. Download the twrp.tar on your pc and supersu.zip on your device. Also, download odin on your pc
  2. Open odin on your pc.
  3. Put device into download mode by turning off the tab s first. Then hold power,home, volume down button all at the same time till download mode comes up.
  4. Hit volume up to continue
  5. Connect tablet to pc.
  6. Hit the ap or PDA button in odin.
  7. Select the recovery tar.
  8. Untick auto reboot in odin
  9. Hit start
  10. Now force reboot by holding power,home, volume up and down buttons at the same time till it reboots.
  11. Power device off again.
  12. Reboot into recovery by holding power,home, volume up buttons all at the same time till twrp pops up.
  13. Hit install button in twrp.
  14. Select the e zip you downloaded.
  15. Swipe to install and reboot.
    Done!
1 Like

Thank you, this saved the day! It worked for my second hand Samsung S9 dual SIM

Just for information:

  • installing TWRP at the first attempt failed, with the same “only official released binaries…” error. This caused the ‘OEM Unlock’ option to disappear, and I had to make the option reappear by manually setting the date to more than 7 days ago, deactivate some auto updates and restart the phone.
  • for reasons unclear to me, the second attempt to install TWRP worked, then the remainder of the howto mentioned above worked as well, with the following small differences
    • there was no Error 7 when installing the /e/ .zip file
    • after the install, there was no prompt whether to install TWRP to run under /e/

Versions involved:

  • Phone: Samsung S9 (Model SM-G960-F) running Software revision version 15 (Feb or March 2021)
  • Odin3_v3.14.4
  • twrp-3.5.1_9-0-starlte.img.tar
  • e-0.13-q-2021012097133-dev-starlte.zip