[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

I’m hoping someone can guide me around a problem I have come up against, while preparing my Samsung Galaxy III International i5300 phone for flashing with /e/ OS. I have never flashed a phone before, and this phone is only being used as a music player at the moment as I upgraded last year to a Motorola G7.

I am using Anonyme’s very clear instructions “[HOWTO] Install /e/ on a Samsung smartphone with Windows easily” as my knowledge of command- line is sketchy. I realise the phone he has flashed is not the same as my phone, but this phone is on the list of supported devices.

I didn’t get very far… When I came to “3) OEM Unlock” it was missing, so I followed the instructions to activate Developer Options [it was already activated], then looked again but OEM Unlock still wasn’t in Developer Options.

I then attempted to update Android; I unchecked Automatic Date and Time/ changed the date on the phone to 10 days in the past, looked for ‘Auto Update System’ [not there], found ‘Software Update/ Auto Updates’ and unchecked it, tapped on ‘Update’, got the message “latest updates already installed”.

Next I rebooted the phone and turned on ‘automatic date and time’ again; restarted the phone and check to see if OEM Unlock had magically appeared; still not there.

I then did a Factory Reset to see if that changed anything. The Android version is still 4.3 as before.
Where do I go from here? I’m thinking I should save up for one of the refurbished phones with /e/ already installed, anyone think of something else I can try?

If you mean this Samsung Galaxy S III (International) - “i9300” then please read on here …

1 Like

So far I have avoided Samsung phones, because the instructions seemed to require building “Heimdall” on Windows (build “not available”?) I could set up a Linux PC just for Heimdall, but overall this is all very confusing.

Is there a problem with installing Odin instead, and why is it not mentioned in the official instructions? Thanks!

There is no difference in the final resulat. Both methods will install TWRP on your Samsung phone.

It’s true it’s not mentioned directly in the installation page of Samsung devices, maybe it should since this HOWTO seems safe a tested by many users.

No, I don’t know any problems of this kind: Wind°ws and “Odin 3” fit together as well as Linux and “Heimdall”.

The majority of “professionals” especially software developers use a Linux derivate and have already given up using Wind°ws a long time ago. Wind°ws is as reluctant to be put into the mouth as G°°gle. So tools are primarily mentioned on Linux basis. They simply “forget” that 3/4 of the “normal” desktop PC / notebook users work with Wind°ws as operating system. An effective Wind°ws tool is Samfirm, a fast free downloader of Samsung Android firmware.

I belong to the Wind°owsers of the first hour. My W°Systems are largely “closed”, so that it can only rarely “phone home”

Good point. Will have a reference to installing Odin also added to the official /e/ documentation.

That’s brilliant. I remember when checking out /e/ for the first time the Samsung instructions looked like a big hurdle, so I only looked at Motorola. Samsung being the most ubiquitous models, it should be as easy as possible for Windows users.

Hello, I installed a Samsung S9 via this method. Worked like a charm and today I tried my luck on the Galaxy S7. No luck this time. I bricked it twice but via Odin I could bring it back to the original Samsung installation. The problem actually was not Windows or Odin related but the phone seemed to be encrypted. In case of wiping as written in the article do this:

Boot into TWRP after the upload to the phone

Choose the button “Keep Read Only” It seems to me that the Galaxy S7 had encryption on by default.

Choose the “Wipe” button

Choose “Format Data”

Type: “yes” and now everything is wiped off the phone

Reboot into Recovery and choose “Do not install”

Choose “Keep Read Only”

Now you can go on with the installation of /e/

Everything went well

Thanks for the nice manual! I trying to use this ROM for my Galaxy S5 Mini (kminilte).

Everything works fine for me until the flashing process.

I am encountering error 7. While I could avoid the device check with the above posted infos, I now have a new error 7 which is the following:

Patching system image uncondituonally...
mkdir "/cache/revovery/
19e673c[...]/" failed:
No such file or directory
E1001: Failed to update system image.
Updater process ended with ERROR: 7
ERROR installi zip file 'e9.zip'
Updating partition details...
... done

Maybe somebody has an idea?

Hi, welcome in the forum :slight_smile:

Which version of TWRP do you have ? The error 7 happens on old version of TWRP, like 3.1.1 for instance. Last version is 3.3.1 (if my memory is good enough).
Oh a 3.4.0 version was released 3 days ago and is available for your device.

Thanks, and thanks so much for the fast reply!

I am using twrp-3.4.0-0-kminilte, so I guess that is not the problem.

OK, I wanted to install /e/ on another phone (Samsung A5 2017, a5y17lte) which resulted in the same error. Finally I just tried so previous TWRP version 3.3.1-0 which worken like a charm on both devices! So I would recomment to abstain from using 3.4.0 for these two devices!

All right, thank you for the tip !

Thank you so much. I had a similar problem installing /e/ on my Samsung J5 and using the TWRP 3.3.1-0 instead of the 3.4.0 solved my problem.

Very helpful comments @izgrimmer @Anonyme:
Had the same Error 7-Problem with a Samsung Galaxy S8 and TWRO 3.4.0. With the TWRP 3.3.1-0 it was no problem at all.

Thanks @Anonyme! I did the flash with your tut and worked well. Way easier than the e tut. I had only troubles that I couldn’t put the zip file in to the internal storage, I put it instead on a micro SD and bootet it from there, merci encore une fois!:+1::+1::+1:

@frankdrebin, happy to help the best policeman in the world :wink:

1 Like

Hi everyone
After multiple attemps on my Galaxy S8, I still had the Error 7.

Solution found: add a reboot of Recovery TWRP without install (no install option) after wiping your cache, data, etc…
If you had to reformart and back to ext4, then I’d add another simple reboot of Recovery without install.

I’ve tried to remove the asserts line (de-zip re-zip the ROM) but it didn’t change anything.
I’ve tried Lineage 16 (same error 7) then Lineage 17.1 (different error this time).
The next day, after a complete reboot (with no install), the installation of the latest e/Rom worked fine.

Ref: Youtube video: How to Root Galaxy S8/S8+ on Android 9.0 Pie!
Detailing the Reboot steps.

I used
Odin v. 3.14.4
Rom: e-0.9-p-2020062560240-dev-dreamlte

1 Like

Thanks a lot @Anonyme. It’s a very clear guide, even for an (absolute) beginner like me. I have bought a device with pre-installed /e/ because I thought I wouldn’t be able to do learn how to flash myself in the near-to future. But as I really like the idea behind /e/ I am keen on learning more. So with the help of your “How to” I flashed my old S4 mini. And it worked - which made me really happy!

I used TWRP 3.3.1. as recommended by some in this thread (instead of 3.4.0) and had no Error 7.

One small question: In the “How to” under Point 8a (Delete existing smartphone content) it says: “Select the following items to delete and nothing else”. The following 5 bullets include “Internal storage” which is however not ticked on the screenshot (and I think I also read somewhere that “internal storage” shouldn’t be deleted). Is that a small bug in the description? (I opted for not ticking it)

Thank you, that was the goal :slight_smile:

In the first place Internal Storage wasn’t mentionned (because at the time I also read that I shouldn’t tick it), but I tick it each time I need to wipe and there is no problem, so I added it but I haven’t modified the picture.

Internal Storage is just what you can find in the Files app (“Download”, “Documents”, “Pictures”, etc.).