Hulp bij installeren adb en fastboot via Linux Mint 21.3

Hallo,

Ik heb zojuist de FP5 aangeschaft en wil graag eOS installeren op deze telefoon.
Echter loop ik al vast bij het installeren van ADB Devices en Fastboot.

Ik maak gebruik van Linux Mint 21.3 en heb Linux geinstalleerd.
Het downloaden en uitpakken van de platform-tools is geen probleem, echter doe ik blijkbaar iets verkeerd bij het toevoegen van de regel in het .bashrc bestand.

Ik kan namelijk neit in elke map het commando ./adb devices en ./fastboot devices gebruiken en als ik de eerste opdracht invoer dan krijg ik enkel in de map platform-tools te zien: ¨List of devices¨ (nothing to see)

map platform tools
where to find the bashrc file

Om te begrijpen wat je doet, kijk eens naar:
echo $PATH
echo $HOME
Het gaat niet veel anders dan vroeger onder DOS met de : als scheidingsteken tussen de paden die afgezocht worden.

Bedoel je eigenlijk:
export PATH=“$HOME/platform-tools:$PATH”

./adb =
./ in huidige directory

alleen adb zoekt $PATH af

Ik doe dit uit mijn hoofd, dus tikfouten voorbehouden.
Een complete beschrijving staat in de How to voor Mageia

1 Like

Ik begrijp niet wat je bedoeld en het helpt mij ook niet verder.

./adb devices resulteerd in: bestand of map bestaat niet
./Fatboot Devices resulteerd in niets. Ik krijg ene volgende regel en meer niet.

Vorige keer heb ik mijn Asus Zenfone 8 opgestuurd naar iemand in Frankrijk om mij te helpen met het installeren van eOS. Precies toen braken er hevige protesten uit in frankrijk en heb ik godzijdank na 4 maanden mijn telefoon na een hoop ellende terug ontvangen.
Ik wil deze ellende graag voorkomen en wil graag weten hoe ik zelf eOS installeer op mijn nieuwe Fairphone 5.

Maar ik eerlijk gezegd begrijp ik er geen f*ck van…

Misschien kan dit artikel je helpen om ADB/fastboot aan de praat te krijgen :

https://itsfoss.com/install-adb-fastboot-linux/

1 Like

Dank je ik had dit al gedaan zoals dit staat beschreven, maar kennelijk deed ik iets niet goed en kreeg ik ineens een popup op mijn telefoon om USB debugging op mijn telefoon goed te keuren voor mijn computer.

Inmiddels lijkt het of ik e/os nu op mijn telefoon heb geinstalleerd al ging de installatie niet goed.
Ik kreeg bij de laatste package een foutmelding welke ook al op dit forum bekend is.
Nu heb ik eerst op apply ADB geklikt en vervolgens reboot in fastboot.
Vervolgens start Murena op en krijg ik de standaard instellingen zoals taal kiezen, wifi, code, vingerafdrukscanner en uiteindelijk inloggen op mijn Murena account.
Het lijkt erop dat het nu is geluk, ondanks de error.

Echter is het mij niet gelukt om de bootloader weer te locken.
Misschien heeft dit met het bovenstaande te maken, maar als ik de instructie volg dan resulteerd dit in een sim-lock en krijg ik telkens opnieuw de vraag om mijn pincode in te vullen maar ik kom er niet meer in. Aangezien de bootloader op mijn oude Asus Zenfone ook nooit gesloten was, denk ik dat dit ook niet het grootste probleem is. Echter zou ik toch wel willen weten waarom dit niet gaat.
tevens had ik ontdekt dat als je de bootloader terug plaatst, de telefoon weer naar fabrieksinstellingen gaat en je alles apps e.d. weer opnieuw moet installeren.

1 Like