Hung installation on Samsung S9+

Samsung S9+, new out of the box.

Using the easy installer, my installation has stopped. My phone is showing the ‘running recovery commands’ screen for a few hours now. The last shown command is ‘Formatting system using make_ext4fs…’. See attached pic. Easy Installer is at the ‘Resize Data Partition’ screen.

How sould I proceded without damaging my phone?

Thanks in advance!

Hi @gspencer welcome to the /e/ forum.

I suggest looking for the Easy Installer log on your PC and perhaps sharing it here. Details here Howto troubleshoot issues with the easy-installer.

It can happen that a brand new Samsung has a locked bootloader for 7 to 14 days, released remotely by Samsung after a period of “normal” use using SIM card and wifi. This is revealed by looking at your Download mode screen and looking for the word prenormal, top left hand side; more info on this here. Know your hardware - Samsung. There should have been notice of this in the packaging of a new phone.

(The format for insertion of images is
![name|size](url) – it looks as if you were trying to adjust it! :slight_smile: )

1 Like

Hello, thanks for your response.

I have quite a few log files, these are the last two;

2nd last log: hastebin
Last log: hastebin

I would like to look at my download mode screen. However, I don’t know if it’s safe to unplug/reboot, can you give me some information on that point?


ADD: There wasn’t any indication of a prenormal state in the included documentation, however there seems to be quite a bit of talk about this in various forums, I’ll continue to investigate. Still need to know the safe way to restart my phone.

Just in your earlier log, Easy Installer seems to have downloaded ok (not fully checked yet), uploaded Recovery successfully [1] and gone back to do it again [2].

We see sound progress [3] … then this is where it falls apart [4].

So …

Did you make your first boot into TWRP aka TeamWin?

I will assume you read my Know your hardware article and I wil not repeat anything I already wrote there.

I don’t know if it’s safe to unplug/reboot

Yes. Easy Installer is usually competent to restart at almost any point.

You should unplug and boot into Recovery. The main system will be unstable. Bootloops will probably happen if you allow it to boot into system; just get used to moving around between Download mode Recovery mode and OFF.

Please ensure the device is fully charged (>80%) from OFF mode and confirm.


  (debug)Uploading RECOVERY

  (debug)0%2% ... 98%100%
2022-06-05 15:03:15,655 DEBUG [Thread-56] e.e.i.m.Command [null:-1] 
  (debug)RECOVERY upload successful


Uploading RECOVERY
RECOVERY upload successful
Ending session...

Releasing device interface...


waiting for recovery

device found in recovery

Mounted '/system'


  (debug)/home/george/snap/easy-installer/common/sources/star2lte/ 1 file pushed, 0 skipped. 779.3 MB/s (263275 bytes in 0.000s)
2022-06-05 15:06:50,370 DEBUG [Thread-62] e.e.i.m.Command [null:-1] 
  (debug)/home/george/snap/easy-installer/common/sources/star2lte/ 1 file pushed, 0 skipped. 784.1 MB/s (263275 bytes in 0.000s)
2022-06-05 15:06:50,566 DEBUG [Thread-62] e.e.i.m.Command [null:-1] 
(debug)rm: can't remove '/sdcard/': No such file or directory

For Later

I am going to wait for your answer before proceeding … but, having looked it up, I am just dumping this url here

1 Like

Yes, I did make the first boot into TWRP and was following instructions until I ran into the problem that I mentioned in my first post.

My first restart after unplugging brought up the download screen, I chose to continue, which brought up TWRP’s ‘Unmodified System Partition’ window, I chose ‘swipe to allow modifications’. Now when pressing key combo’s to enter either download or recovery mode, these all bring up TWRP’s top/welcome menu with install, wipe, backup options, etc.

At this point I think you have a choice retrace your steps again with Easy Installer, or to install manually


All the downloads on offer today are Android 10 -q
Was your phone previously on Android 10 ?
– in which no vendor zip or patch (referred above) is required.

If you had Android 11, this would conflict with the Caution below!

If this is not an issue … pick up where Easy Installer left off at the sub-heading Resize userdata – of the manual instruction linked above.

You can also decide whether to install the stable build or the dev build.

Reading from your log you will see that you already have platform tools ready for use in


also present


That image will be a stable build, you have another choice available, dev build; see

For a long time Easy Installer has been installing Oreo.

You will notice that the manual instructions include

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

I may have covered too may “ifs” in my text – if unclear please ask again!

I apologise for my lack of concentration … I got too deeply into try to reconcile your log that I forgot to read you text and image. :blush:

1 Like

This phone is brand new, I did not consciously upgrade from the original, Android 8/Oreo. So, it will still be Oreo unless Samsung performed an upgrade right after I powered it up. Is this a possibility? I’m asking because I’m concerned about future instability.

I installed Heimdall successfully, and used it to reboot the device.

Then resized userdata in TWRP.

I ran into trouble in the next stage; Installing /e/ from recovery, where the command ‘adb boot recovery failed’ with ‘error: no device/emulators found’

I competed the other steps, then as expected, ‘Sideload the /e/ .zip package’ also failed with no device/emulators found.

Cool thing is that simply dis/reconnecting the usb cable fixed this issue.

After that, the installation completed! And everything looks to be working well.

Thanks for all your help, it’s been invaluable!

Thank you for your kind words, sounds like you were better able to navigate the hurdles, than I to explain them !

Highly unlikely imho.

I was struggling with your log, but Easy Installer must have done sufficient work in order for you to pick up where you did … then once /e/ boots we can be fairly certain you have a stable device.

Always good to get really confident with backups, so that if you ever doubted that you were on sure foundations you could flash an Android 10 stock ROM and do it all again!

1 Like