I rewrote the installer script for MacOS and FP4

As mentioned I rewrote the installer that comes with the FP4 package for MacOS, the steps for use are as follows:

1.) Change the part of ‘flash_FP4_factory.sh’ that checks for the computer OS to this;

Operating system checks and variable definition

os_checks() {
case “$(uname -s 2> /dev/null)” in
echo “INFO: You are using a Linux distribution.”
echo “INFO: You are using MinGW on Windows”
echo “INFO: You are using MacOS.”
echo “ERROR: Unsupported operating system (${OSTYPE}).”
echo “ERROR: Only GNU/Linux, and MinGW on Windows are currently supported.”

2.) Copy fastboot into a folder called ‘bin-darwin’ in your IMG folder, next to the ones for linux and MinGW

3.) Make the installer script executable using ‘chmod +x flash_FP4_factory.sh’

4.) Execute the script after putting your FP4 into fastboot mode using the power up + volume down method.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


I came up with a similar change for the FP3 flash script. Indeed, Mac users should still be able to use this script and go past the OS check that covers only Windows and Linux.

It would be worth pushing the changes to Gitlab (not sure if it’s the right place):

The “flash-scripts” to my knowledge is the outdated version of the scripts that are now part of the easy installer.
But I agree that creating a merge request would be best. If only we knew where to place it :wink:

1 Like

@mrkar0sh1 @MaMaTT88 & @Ingo_FP_Angel thanks for your efforts to improve the scripts. I passed on the info to the developers and they welcomed the help. You can create an issue in [GitLab](Issues · e / Backlog · GitLab and share the issue ID. I can have it labelled and pass on the details to the team.
In case you have issues creating a ticket on Gitlab check this guide.

1 Like

Thank you very much, it worked!

Gitlab won’t actually let me register for an account, not sure what’s going on there but it doesn’t like my company email.



Thanks! Was able to apply the same edits to the FP5 installer script and it worked great!