I'm unable to transfer data via USB

Hello community,
I cannot tell you when this happened but I’m now unable to transfer data between my Gigaset to my computer via USB.

When I plug my phone and check the settings everything (apart from greyed out options) looks OK to me.


I used to be able to connect with this cable. Please advise.


What OS is running your computer?
Did you try another USB port?
Do you have any other computer available for testing?


I’m running Ubuntu Linux on both of my computers.
Yes I did try to use different ports on both computers.

I have only 2 computers to use.

Some tips with Ubuntu: https://askubuntu.com/questions/142050/does-ubuntu-log-when-usb-devices-are-connected and https://wiki.ubuntu.com/Kernel/Debugging/USB.
If you can’t get anything from logs & traces, then you’re probably facing a cable or device USB port problem.

I assume you tried to reboot the device?
If you are aware of fastboot (bootloader) or recovery ADB, you may use them to verify your USB hardware.

I got a new USB cable because I suspected there was something wrong with the old one.

Still getting this from the phone:


What baffles me is that the computer detected my phone just fine couple of months back. What changed ?

Has it ever been working?

My FP3 never showed up as an ordinary USB device, neither on Linux nor on Windows. This behavior is well known.

On Windows you get a special entry under This PC you can access for file copying or similar, but it’s different from ordinary USB, you also can’t hang out this thing. Check this on a Windows PC to see if your device is OK.

On Linux you can’t mount anything. As far as I know you need special software like android-file-transfer or similar to access files on the device. Or you use generally FTP (the device is the server, the Linux PC is the client) or similar.

Wow. It did work for me. Only few months back it worked like a charm for a long time. I gotta say I made a mistake with the purchase of a new cable. It was advertised as a data cable but it gives only a charge. So I need to find another cable that actually has the capability. I don’t necessarily need the data transfer though. I can simply use eCloud to move / copy files but I need the cable connection for my videos. I run a YouTube channel and I use my phone to shoot videos. The software I use to connect my phone uses either wifi or USB connection. Wifi in my place is rather unreliable so hence I’m going for USB connection. And now it’s not working … ggrhh …

I find it quite surprising that it actually never worked for you and you’re saying it is expected behaviour. I guess my Gigaset was special for some time.

I’m using a Samsung S9, /e/ ver 1.11, and it is hit and miss if my Windows PC sees it on USB. It used to work on Windows 7 but since I tried on Windows 10 and 11 it doesn’t work on any PC anymore.