Impossible to encrypt a Galaxy S8 /e/ latest version

Hi, I’ve flashed /e/ on a friend’s S8 (SM-G950F) with the easy installer and configured it to introduce him to a privacy respecting OS and tools but when he tried to encrypt it as I advised him, it failed. He wasn’t even asked to enter a pin for the encryption. then the so called encryption only took 1 minute. Then he let it sit for an hour or so and when he took it back, the S8 entered in the twrp menu. He tried to turn it off the the button but it didn’t work. As he didn’t know what to do he asked me for help. I selected reboot but after that, I noticed that some installed apps wouldn’t work anymore (Telegram FOSS, Aegis, Scrambled Exif and Bitwarden for example). Also when on stand by, a notification stating the permanent vpn has been disconnected (used for Blokada) won’t stop showing every 2 minutes. The OS also runs less smoothly than before.
I’ve been told that the twrp version could be the problem (3.3.1-2). I had to format data and wipe then I installed the 3.4.0-0 version following instructions and then again the last /e/ version available for the S8. I tried again to encrypt it but it encountered the same problem.

I guess it’s safe to assume the problem hasn’t to do with twrp version but with /e/ itself. I’m really disappointed and above all ashamed to have to tell my friend that he won’t be able to encrypt his phone (a most basic thing for security and privacy). I told him to buy a second hand S8 precisely because it is being sold by /e/ and supported by the easy installer thinking that it would mean basic things like the encryption would work without problem.

Is there something more I should try before losing my credibility along with /e/'s one? Help would be greatly appreciated

1 Like

I’ve seen that after letting it in stand by for a bit more than one hour, it rebooted on its own in twrp. The same way it happened to my friend.
I hope someone of the team will be able to help me to solve this problem

Hi @Popescu,

Sorry for the inconvenience. Could you let me know which /e/ version are you running?

About the encryption issue, there is a workaround. From TWRP, could you please apply the following actions:

  1. Resize Data partition: Wipe > Advanced Wipe > Tick Data > Repair or Change File System > Resize File System > Swipe to Resize
  2. Reboot on System and let me know if you are now able to encrypt the device.

Thank you in advance,


1 Like

Thank you very much for you answer and support. I’ve done what you suggested me to do. The encryption appeared to go on the same way it did the previous times but this time, it doesn’t appear to have “broken” the S8.
The process hasn’t asked me to choose a pin for the encryption though. I don’t really understand what’s the point in having an encrypted device if it doesn’t require a pin to decrypt it. Could you tell me more about that, please?
PS: This is the latest version of /e/ for the S8

LineageOS 17.1, the basis for future /e/ OS ‘Q’ versions, has enabled encryption by default in the build for Galaxy S9 / S9+ - without PIN. Encryption can cause some problems. For example, I don’t need encryption because I don’t store any data on the smartphone that would be worth encrypting.

Encryption is a very basic and extremely advised thing to do regarding security and privacy.
I still don’t understand what’s the point in an encrypted device that doesn’t require any pin to be decrypted then it might as well be unencrypted if someone could grab my phone and decrypt it without pin…

Then you just have to set a PIN/password, and if the option of asking for it at boot appears, say yes.

The decryption key doesn’t depend on your PIN/password. This would mean that every time you change your PIN/Password, the phone has to be decrypted and encrypted again which isn’t the case.

The decryption key is secured thanks to the PIN/password you will choose.

1 Like

Thank you very much for your explanation! My problem is solved then