Impossible to log in snapchat

I received my /e/ Samsung S7 edge yesterday
I installed snapchat but login keeps on failing I even reset my password … Login is still not working

1 Like

Have you tried snap chat on any other version of Lineage OS with MicroG. Just wanted to confirm if this is a /e/ specific issue.

I did not try, I only have /e/

I have the same issue on my Nexus 5 running /e/. This is the first custom ROM I’ve put on the device so I’m unsure if this is specific to /e/.

The error message I’m getting is something like “Oh no! Your login temporarily failed, so please try again later.”

I have the same message !

A few months ago, for a friend, I managed to make snapchat work with /e/. It’s not a problem with /e/, but with microG. Snapchat don’t want custom ROM uses. The solution is to use Magisk with some microG updates (you can find the solution on the web. There is no need for me to explain my method (empirical), because it is already outdated from what I have seen).

So, i think it’s still possible !

For info : it’s was with a LeEco S2 and Android nougat.

Thank you @TheMajorTom! So I made some research and I found this :sob:

Indeed, it was notably with safety net… So, in my opinion, for the moment it is impossible… but, wait&see !

Anyway, snapchat is very far from the philosophy of /e/ from the point of view of data collection. However, I can understand that for a large part of the public, this is an obstacle. Especially because there is no alternative to this application.

Yes, same problem here, snapchat not working for me on my xiaomi redmi note 5 pro. Safetynet is not working on my device, I checked using Magisk… I hope safetycheck will work one day with microG

Ok, has anyone made snapchat work on /e/ yet?

It’s not impossible to have a working Snapchat on /e/, I made it (after it wasn’t possible de log in anymore) but that’s a pain.

You can’t connect because during the login process, Snapcgat checks for the Google SafetyNet certification that ROMs without the GApps don’t have.
The “good news” is that Snapchat only checks for it on the login screen, meaning that once you are loged in, you can use Snapchat.

Here are the steps (need root access) :

  • In order to make the notifications with MicroG work later : download Snapchat and open it. Wait for it to be registrered for Google Cloud Messaging in MicroG. Close it.
  • Browse /system/app/app/com.snapchat (with root access), change the access right (read/write) access of the few files to transform them into directory and browse them.
  • Search for a file with the unique notification identifier inside, and save this file somewhere.(I didn’t know what it looked like either the first time I found it)

  • On another similar phone with root access (or the same phone with LineageOS with GApps for instance, but in this case do this all part before the previous one), download and login to Snapchat.
  • Use OandbackupX (for instance) to do a full backup of Snapchat.

  • On your /e/ phone, simply restore this backup. You will be loged in to snapchat.
  • To make notification work, paste the file you saved earlier where it was.

Of course, try not to logout :yum: