Indoor Location Wildly Inaccurate

I am using /e/ 0.22 on a Fairphone 4 and a Samsung Galaxy Tab S6 Lite, and both have the same problem: whilst outdoor location works fine, indoor location is very inaccurate.

I have previously tried both the Mozilla Location Service and Apple Wi-Fi microg location modules. Both report my location as being in a village 5km from my home, always in the same spot. Recently I’ve also tried the GSM Location Service backend. This sometimes shows my location perfectly, but many times shows me in a field 750m away. As you can imagine, ordering takeout is a challenge.

From the same location, I have an iPhone and another Fairphone running stock Android, and both report my location perfectly.

Is anyone else experiencing the same issues and perhaps have a workaround?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

The one obvious thing defying what I would assume as logic is that


don’t report the same location indoors for you. But since I use neither in practice, what I would assume as logic might not play a role in practice here. I wouldn’t know.

Anyway, based on that …

Is Settings - Location - Wi-Fi and Bluetooth scanning - Wi-Fi scanning enabled?

If I look at Settings - System - Advanced - MicroG - Location modules - Mozilla Location Services - Configure, it has a “Use Wi-Fi” setting, and it’s enabled for me.
Does the Apple Wi-Fi module have this setting, too, and is it enabled for you?

Else …

Have you been there (perhaps even regularly)? I experienced that Android in general has the ominous tendency to sometimes start displaying a location fix it got in the past, totally unrelated to where I am currently or was recently, until a new location fix is found.

I have the same issue:

When I’m outside, the location works fine. As soon as I am indoors, I am suddenly 7000 km away.
Wifi scanning and Bluetooth scanning is turned on.
0.22 R (cheeseburger). But I have had this problem for a while, at least since 0.21.

@AnotherElk thank you so much for your reply!

Yes, both Bluetooth and Wi-Fi scanning are enabled.

The ‘Use Wi-Fi’ setting for Mozilla Location Services is enabled. The Apple Wi-Fi backend has no such setting.

I’ve driven past, perhaps once… however this problem started happening before I had ever visited the village, and I’ve driven past perhaps once in the past three months.

At this point I’ve disabled both Mozilla Location Services and Apple Wi-Fi as backends, and am relying on the GSM Location Service backend. It seems to be slightly more accurate. However, I still get the problem, especially at home, that shows me about 750m away in a field more often than not.

I can also confirm that this doesn’t happen only at home. I’m now at the office, which has had the same wifi system for 10 years and a couple of cell towers on the roof. Whilst I am sometimes shown in the correct location, my location suddenly jumps to a field around 500m away for a few minutes, before returning to the original correct location.

At this point I’m really stumped as to what to do :confused: