Install /e/ on a Samsung Galaxy S5 Active - “klteactivexx” (beta)

On ADB Sideload I get E3004:This package is for device: klteactivexx,klte;this device is klteactive. Updater ended with ERROR: 7

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I am using this:

Compare to this guide, error 7 is mentioned

1 Like

I see what the issue is now - this link (from Install /e/ on a Samsung Galaxy S5 Active - “klteactivexx”) Download a custom recovery - you can download TWRP. Just gives a 404 - so I did a search for twrp-x.x.x-x-klteactivexx.img but found only this TWRP_klteattactive-050818.img - which gives this error obviously :
On ADB Sideload I get E3004:This package is for device: klteactivexx,klte;this device is klteactive. Updater ended with ERROR: 7

So my question is where do I get the twrp-x.twrp-x.x.x-x-klteactivexx.img ?

Thank you!

I found this and gave it a try: wget
That gave me a signature failure 21. under install but offered option to continue anyway - gave it a try, and voila!

Looks like its working - doing /e/ setup now. (can’t wait to try it out)

Thank you /e/ <3

In the frequency of <3

Finally I thought setting it all up, and looking good, time to move the sim card from my other samsung device to the new /e/ - first issue typing sim pin at boot, it just spinned endlessly, went back to the other device and took away the sim-lock I was able to enter into /e/ but still there is issues it does not find mobile carrier…so now I have a fantastic touch device without calling abilities. Any clues anyone?

Have you already tried entering the APN settings for your carrier manually?

Thank you for the fast reply Taurus, I have only selected the the carrier manually, not the full lot of APN settings as I do not know what to enter…

You could insert the SIM in the old phone, then go to Settings and search for “Access Point Name” or “APN.” Look there to see which APN is active (selected). Tap on that and take note of what’s entered in the various fields, then write the same exact entries in the /e/ phone. Pay attention to spaces, dashes, capital/small letters, dots, commas, etc.

Or you could call your carrier and have support talk you through it, but that’s more annoying.

Actually, you may not even need to insert the SIM in the old phone to see the APN settings, but I’m not sure.

When entering in the new phone, you’ll probably need to “Add” (or “+”) to create a new APN. You also may need to restart the phone.

Fantastic Taurus - thank you. I’ll let you know how it goes…

Be on the lookout for your keyboard auto-inserting spaces after the commas in the “APN Type” field. There should be no spaces. I know this is a common problem.

1 Like

Oh, and be sure to Save the new APN when you’re done.

@Taurus to my surprise there was a drop-down with predefined entries, so no way to make typos. I set it to the exact same parameters in the “old phone” but still no connection to the mobile carrier…:slightly_frowning_face:

What is strange is that the “old phone” is accepting/acknowledging sim lock from an old and a new simcard. (old without coverage and new with) The /e/ only accepts the old - On the new, the wheel just spins forever.
To confirm that the /e/ can access the simcard I removed the sim pin - put it in the /e/ then I can enter and set a new pin, but still it’s not accepting the pin after a reboot, but pin confirmed present when I put it back to the old phone…next step is to put the phone back to stock to see the sim behavior there…any options where I can find that?

Thank you,

Hi @Hibba, sorry about the APN problems. I’m new to /e/, so I don’t know how to return to stock, but I know it should be easy. Maybe @Manoj or another forum member can point you in the right direction.

One thought…I just noticed that the version you flashed indicates that it’s for “att.” Are you actually in the U.S. and using AT&T network? Maybe you’re trying mismatched versions. We need an expert to step in here and advise.

Models Supported :

  • SM-G870F
    Other models are not supported
1 Like

Thank you @piero that is the model yes so that it clear. To your findings @Taurus that probably the root cause for it not getting mobile carrier connectivity…I am in Norway with carrier named Telenor

With the lack of TRWP mentioned up in the posts I found and used this:

With that I installed this:
./adb sideload - got it from the howto in my first post.

Thank you!

1 Like

And now you have network connectivity?

@Taurus - No network connectivity - noting has changed since my post 2 days ago, the reason for my last post was to sum up what I had previously used and done…