Install /e/ on Gigaset GS290 failed "unlock operation is not allowed"

Txs for your reply. Easy-installer doesn’t work on the old computer my neighbour gaves me. I will find another one !

When I tested the easy installer, I tested on an old pc with Win10 updated to the latest version… No way, the launch returned me an issue saying not compatible or something like that. With Windows we never know…

2nd test, I used a live version of Ubuntu, installed all updates of the system, installed the easy installer (no driver needed for the gs290), but the process stuck after the few minutes. Not sure of it, but maybe was not a good idea to test a live version, too slow or data lost?

Last test, I installed Ubuntu on the pc, updated it and installed the easy installer from the Ubuntu store. This time no data transfer issues… and finalised correctly!

And from yesterday I’m really happy with this system /e/ !!! It will replace my android phone from now on… :slight_smile:

Hope this can help you in a way or another

(By the way, I did not used the cable provided in the box… So cannot confirm this point)

= 32bit Single Core CPU ?

= not 32bit Single Core CPU !

Good choice … it is basic-user friendly, a mainstream but Debian based Linux-distribution,
It is simply perfect for installing and using the easy-installer on it !

Let me check…
Yes according to what found on the net, 1 Core (it is an Intel Atom N450)
And yes OS 32 bits… :slightly_smiling_face:
It’s really slow…

But updated to 21H1 !

So later I tried wit a recent laptop with another Linux and installed the Ubuntu to have the app from the store, EASIEST way… :slight_smile:

How far you’ve gone, the easiest way would not to bother with Linux and shity drivers, but to avoid using Easy Installer.
C’mon ! Once unlocked it’s five commands to go :wink:

1 Like

But not so easy for me :smiley:
I tried to install like that for 2 days on another smartphone (not the gs290, another brand)…no way!

So => I installed crDroid on it with no prob… and purchased the gs290 for the test with /e/… :wink:

Okay, then I wish you good luck with flashing (no joke) and fun with /e/ :blush:

Thanks! :slight_smile:
Until now I’m really happy with /e/


I have tried with a new cable and another pc, but :

  • With the easy-installer, I have an error after pushing up the volume
  • With the commands, the same issue…

    I’m desperate…

Unlock operation is not allowed…

Did you verified the settings on the phone for the unlock? Check again “Developer Options”

Le “Déverrouillage OEM” semble ne pas être actif?

il est en “grisé”, je n’ai plus accès à la fonctionnalité pour passer le curseur à droite. Et dessous “bootloader déjà déverrouillé” ?

Le post Gigaset - GS290 - gs290 - Documentation Suggestions - #10 by Yann974
aborde l’unlock du bootloader, je ne me souviens plus vraiment de cette partie

“bootloader déjà déverrouillé” devrait ne plus être grisé une fois qu’il est ouvert.

Je ne vois pas de solution dans ce post.
Le bootloader n’était pas grisé au début… J’ai essayé de revenir aux paramétrages d’usine, mais rien n’y fait.

Peut être que le message “Unlock operation is not allowed” apparaît car ton appareil est déjà déverrouillé ? :wink:
As-tu essayé les étapes suivantes ? C’est sans risque : si l’appareil est toujours verrouillé, elles seront refusées.

Il reste bloqué sur écran noir avec un message type “select boot mode : recovery, fastboot ou normal”, mais je ne peux rien sélectionner avec les boutons du téléphone. Donc je redémarre avec le bouton du tel, car la console est bloquée.
J’ai testé la suite => voir screenshot

It is normal that the device won’t accept fastboot command, as it is not in fastboot (BootLoader) mode.
So, you should issue a adb reboot bootloader before issuing any fastboot command.

If the device won’t go to fastboot (BootLoader) mode, I strongly advise to reset to stock ROM.
Please be aware that drivers a quite old, so they may not work on a Windows 10 computer (I ran them successfully on a 32b Windows 7 computer, please see here for details).

One other thing to try is to downgrade your platform-tools to version r30.0.5

This is the Windows link:

and this for Linux: