Install /e/ on Gigaset GS290 failed "unlock operation is not allowed"

Hi there,

I try to install /e/ on Gigaset GS290 but I have an error during the unlock operation FAILED remote: Unlock operation is not allowed

USB is on debug mode and OEM is unlocked (it is grey now and I can’t relock it).

When I tip adb devices in the terminal, the phone is recognised.

Could someone help me please ?

Thank you.



I installed my GS290 without any problems using the recommended fastboot version: 30.0.5-6877874

Did you follow these steps ?

OEM Unlock your device

To flash a custom ROM like LineageOS or /e/OS you need to unlock your device Bootloader. To unlock your Bootloader you as the owner of the device need to approve the unlocking. By enabling the OEM Unlock you are giving your permission for the Bootloader to be unlocked.

  1. Enable developer options and usb debugging following the instructions given here
  2. Allow OEM unlock from developer optionsSettings > System > Developer option > OEM Unlock

From Install /e/ on a Gigaset GS290 - “GS290”

Same issue with this version


Thank you for your answer.

Yes, OEM mode is still unlocked (and I can’t re-lock it, it’s grey “non clickable”)

are you sure about your cable ?
have you tried another USB port ?

Can you confirm that when you

adb reboot bootloader

the device actually changes to fastboot mode? Tiny text on a black screen.

Does your device react at all when you then,

fastboot flashing unlock

I know the text is very small, I would expect a tiny reaction on the device, then you press Volume UP on the device … then you expect the OK on the terminal.

(I like to increase the screen timeout to maximum, so that the thing stays on while I work :slight_smile: )


Maybe it’s not allowed … because flashing is already unlocked ?

What gives fastboot oem device-info and fastboot oem dmesg ?

For the reference : Locking/Unlocking the Bootloader  |  Android Open Source Project

… and one more thing, did you be sure to remove all accounts, especially a Google account and PINs before you started.

1 Like

It’s the cable that came with the new phone and I have tried with another usb port, yes.

The phone was bought for /e/ purpose : nothing installed yet.

Yes, the device changes to fastboot mode and I have more lines when I press the volume up.
Just after that, I have the error in the terminal and message on the screen phone that says “volume up to select : recovery / fastboot / normal mode”, but nothing happens when I press the volume up. I have to reboot the phone.

It says “waiting for any device”.

The OEM function on the phone is on “bootloader already enabled” status, but the option has a light grey color, so that I cannot change it anymore.

The GS290 manual says that they provide a data cable! I know it sounds odd, but I would say it is still worth trying another cable. :slight_smile:

1 Like

I don’t have another cable like that… :confused:

I don’t have another cable like that

Sometimes it looks like GS290 defies logic!

Can you send out for another? More haste less speed.

Bon chance.

1 Like

haha merci ! Yes I will try to find another one txs a lot :smiley:

Ask your neighbors or friends …

Did you resolved in the meantime?

I installed this morning on a GS290 thanks to easy-installer, first test was stuck after the unlock.
So, rebooted the phone and tested again to install via the easy installer with success.

The phone was new out of the box, each updates of system done with NO manual reboot.

Anyway, at some point I saw the choice for usb “transfer files” AND another choice on the top, “usb remote control”, or “usb control by phone”.
As by default, it was set on the 2nd choice, (the control by the phone), I tried selecting the first one, and it returned me an error.
So, rebooted again, again check on USB permissions and then started again the succesfull install via the provided tool.

1 Like

Yes ! and test on another computer: could be the main problem…

I will give you news next week :smiley:

Thank you very much for your help !