Install /e/ on Samsung Note 10+?

Not sure i understand what you meant there…

And is there anything i need to know before i go ahead with it? I’ve never sideloaded things before through stock recovery…

have you trying plug / unplug ?
some old device must boot to download mode before to be plugged
some recent have to be plugged to boot in download mode

Ah, i forgot you answered that.
Thank you.
Wish me luck.
(If i dare proceed… :smiley: )

A misquote – I was not referring to anti-rollback at all, merely saying a “rolling issue” in that maybe SPL prevents flashing this month, but /e/OS catches up next month.

We indeed need to work out why Heimdall is making no reported progress with this device !

sorry, my misunderstanding of your words (i am french)

1 Like

also opening download mode using the buttons is not the same than opening from recovery menu or adb reboot download …

Before you get to Heimdall or Odin; before you get to decide if you have to downgrade SPL, you have to complete the preinstall instructions. Note also that the install instructions are a bit muddled about which bits belong to Linux/Heimdall and which to Windows/ zadiag.exe/Odin. @prkfsz I am adding a Lineage link here just to help with the Linux / Windows decision Install LineageOS on d2s | LineageOS Wiki – it looks clearer to me than /e/OS install page … also another edit at the foot of this post.

There is still one thing which includes a misunderstanding in this conversation so far. /e/OS 19-s SPL. We had a link to

This includes the misleading wording:

This /e/OS v1.9 includes the Android security patches available until January. More information in the link below.
Android security patch January available until February

However the Android link is: Bulletin de sécurité Android – Février 2022  |  Android Open Source Project
The header of the link reads
Published February 7, 2022 | Updated February 17, 2022
The installed build includes Android SPL 5 Feb 2023.

Back to

Pre-Install Instructions

Warning: The following instructions will unlock the bootloader and wipe all userdata on the device.

  1. Connect the device to a Wi-Fi network.
  2. Enable Developer Options by pressing the “Build Number” option in the “Settings” app within the “About” menu
  • From within the Developer options menu, enable OEM unlock.
  1. Power off the device, and boot it into download mode:
  • hold Volume Down + Volume Up and connect USB cable to PC
  • Now, click the button that the onscren instructions coorelate to “Continue” and/or “Unlock Bootloader”.
  1. Your device will reboot, you may now unplug the USB cable from your device.
  2. The device will demand you format userdata, please follow the onscreen instructions to do so.
  3. Run through Android Setup skipping everything you can, then connect the device to a Wi-Fi network.
  4. Re-enable Development settings by clicking the “Build Number” option 10 times, in the “Settings” app within the “About” menu, and verify that “OEM Unlock” is still enabled in the “Developer options” menu.

I am not really suggesting that you publish a full blow by blow here … but I suggest you revisit these instructions and take at least one screenshot to prove to yourself that every step is complete – or ask if anything is odd at this stage.

In case you are not aware see also: Samsung - Galaxy Note10+ - d2s - Documentation Suggestions


thank you both, @aibd and @piero for your support on the way. I really appreciate that!

So, here comes a little update on the matter.

I couldn’t flash TWRP with Odin in to the device and Heimdal wouldn’t work, tried all the drivers available and nothing. Tried to rollback on the previous version of stock A12 for the Note+, downloaded from No-go. When tried from stock recovery it gave error message. When tried from adb it started the process but remained on verifying stage and no error message or anything so i had to abort after almost half hour. Luckily nothing bad happened.

Then, after a lot of strugle, i realized that the probable issue is that the phone just refuses to give the controll over the USB-port over to the other device (computer) no matter what i tried. There is a pulldown menu when you connect the phone to the computer where you choose if you just want to charge the phone or do other things, and above that there is a choice of giving controll over the USB-port to the phone or to the computer. And that thing just wouldn’t switch. Found just a few similar cases on the internet, tried some solutions that didn’t work.

I will now give the damn thing to my mom and buy another…

I think you cable could be faulty

i tried two cables, two computers and 5 or 6 USB-ports. And at least one of the cables was original samsung, even tho it didn’t come with the same device…

Original Samsung cable is known here to not working for data transfert flashing

really? But i’ve never had trouble with their cables before. Even tho this is the first device i am trying to flash with usb-c…

But i will try and get one more cable. Thank you for the advice.

20€ cable, same result.
I give up. Mom vill get it.

Btw, the cable for data transfer should be good for flashing, shouldn’t it? I mean, not so much other things to look for in a cable. How much charge it can take and how much data it can transfer.

same issue ?

I don’t think so. I never managed to install Twrp or extract pit-file… When i try to install twrp, i get the message ‘file analysis’ and nothing happens. And when i try to use Heimdall i get either error 12 or some other error message but i never got that far as to actually get the message that pit has been extracted…

Hi @prkfsz I would be interested to know what evidence you have that the bootloader is unlocked.

The bootloader is made much more secure on this generation of Samsung.

1 Like


Sorry for poor sharpness of the picture. The first row says that the bootloader od the device is unlocked.
It’s the first message that pops up after starting the device…

1 Like

… And while i was taking pictures, perhaps i can try and show some others:

  1. The bootloader looks like this. For me a bit strange, because i’ve never seen so many different languages in it…

  2. Downloading screen:
    Never seen a code there…

  3. When trying to switch over the controll over the USB port:

Found a solution. I tried few latest TWRPs and finally got lucky with the version 3.6.2_9-1. Didn’t try more versions, quite happy to finally have made it work… :smiley:

1 Like