Install Pie/FP2: reboot recovery: device not found

Hi everybody! Tried to flash pie on a FP2 with FairphoneOOS.

recovery-flashing seemed to work (“OKAY”), but now it’s not possible to reboot, saying: error: device ‘(null)’ not found

screen shows: Fairphone-logo

how to find out the fault?

Thank you VERY MUCH for answering!

Keeping the power button pressed for about 15 seconds will force a reboot.

Hi AnotherElk! Thank you! But I wonder, why the device is not found? And if the steps are made anyway like this?

What exactly did you try to reboot the phone? adb reboot? The adb command doesn’t work in Fastboot Mode, only the fastboot command does.

I had a look at the steps, and I see a possible problem …

The “Installing a custom recovery” section ends with “Now reboot into recovery to verify the installation”.
But it does only tell you how to do that with the Tip: On some devices if the device does not boot into TWRP you could try it manually by following these steps - With the device powered off, hold Volume Up + Power. Release when boot logo appears.”

This could be made clearer.
After you flashed the TWRP image, you have to reboot or start the phone while keeping Volume Up pressed to get into the recovery (which should be TWRP now). When you are in Fastboot Mode, you can reboot the phone by doing fastboot reboot at this point, or you can force a reboot with the power button. Either way you’ll have to keep Volume Up pressed to get into the recovery.

tried the both, several times, but always get into the fairphoneOpenOS.
wow, now! problem: my slim-case is damaged, so its very difficult to press the Volume-Up -botton!
But I’m in “Android Recovery”…

switched to “reboot to bootloader” in the android recovery, now I got the Fairphone-Logo and cannot force any further reaction. might have been bullshit…
no, I can remove the battery and boot into the FairphoneOpen again.

Bootloader = Fastboot Mode. Fastboot Mode displays the Fairphone logo and nothing much more, you have to do something with fastboot then.
Ok, with recent firmware the LED should flash blue, too, and the phone should vibrate a few times when Fastboot Mode starts. This was added to recent firmware to be able to distinguish Fastboot Mode from a failing boot attempt.

If you don’t manage to boot into TWRP right after flashing it, it can’t make itself resident. If instead the phone boots Fairphone Open OS, this will restore the Android stock recovery which comes with recent Fairphone Open OS.

You will have to try again to flash TWRP and boot into it right afterwards.

Or you could boot TWRP with fastboot without installing it, see here …

thank you! I will try it!

so, finally I succeeded in installing twrp und booting into (!) it :star_struck: (the volume-button is a bit damaged already)
now I have more questions:
which are the “System partitions to be wiped” and how will the Phone-System get the right .zip-address, as it is lying on the host machine? I tried to type “adb sideload”
in the host-terminal, but it shows “error: closed”
(of course I replaced “filename” with the filename)
The files address is the same as the twrp.img file ones, so this might not be the problem, doing it from the host.
greetings! dudu

ok, I got it! I did this:
open the file-manager of the host -> copy the .zip to the internal storage of the partition “FP2” shown in the file-system -> select “Install” in the twrp-main-menu -> “Select Storage” -> “Internal Storage” -> “ok” -> the rest I don’t remember exactly, but should be easy to follow…
Now /e/ works and seems to run much smoother than the FairphoneOpen! I wonder, why FairphoneOpen is not running good on a FP2, as it should be made for it… Could still be, I got a hw-damage. Greetings to all! Thank you!

1 Like

Puuuh. same problem: the phone has an issue to deal the orders at once, so I even cannot answer the telephone when calling…
So I bought a broken fairphone on ebay, what appears not to be fair.