Install problem on FP4

Hi everyone!
The family is enriched with a brand new FP4 to be installed with eos.
Earlier installls from our iMAC on FP2 and FP3 has worked fine. When starting the install the terminal give ERROR: Unsupported operating system (darwin21).
ERROR: Only GNU/Linux, and MinGW on Windows are currently supported.

OK. Instead trying to install from an old macbook now running Linux(Lubuntu). This neither seem to work (cannot find device in fastboot/bootloader mode.) and am stuck with "INFO: Looking for connected device(s)

any suggestions?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

solved myself by running the commandline from root (sudo su) on the Linux machine. Now it has started to install :slight_smile:

1 Like

for curiosity - which tool was outputting … ?

ERROR: Unsupported operating system (darwin21).

adb ?

Im not sure about which tool made the output. How can i tell?

when you were going through the docs and use line by line, the last command you issued

but reading Install /e/OS on a Fairphone FP4 - “FP4” (not all steps make sense to me… where is the link to the shell script?) so I understand if you execute this in one go it’s harder to see which output can be attributed to each command in the script

This is my log:

Martins-iMac:martinsturm martinsturm$ cd eos

Martins-iMac:eos martinsturm$ pwd


Martins-iMac:eos martinsturm$ cd eosRFP4

Martins-iMac:eosRFP4 martinsturm$ chmod +x && ./

*** Fairphone 4 flashing script ***

INFO: The procedure will start soon. Please wait…

Note that this will detect and flash only on FP4 device.

ERROR: Unsupported operating system (darwin21).

ERROR: Only GNU/Linux, and MinGW on Windows are currently supported.

ERROR: Aborting now (press Enter to terminate).

1 Like

I assume that the script itself issues these ERRORs

The docs mention to check that certain files and folders are correctly unpacked. And that lists only Linux and Windows specific files/folders. Also, the instructions contain “Run the installer script on Terminal(Linux) or on Git Bash UI(Windows)”.

There is no mentioning of Mac OS and the download package doesn’t contain the low-level tools for Mac.
And that’s what the script tells you: “Only GNU/Linux, and MinGW on Windows are currently supported” (“darwin21” is the internal codename of Mac OS 12).


thanks, that satisfied my curiosity - it’ at os_check() in · f130ff4a · e / os / flash_tools · GitLab where the line emits from. Mainly as you say, no fastboot is packaged for macOS