Installation issue on FP3+, stuck on boot

Hello everyone !

I followed the instruction to install /e/ on my new FP3+. (
Everything went ok, adb, fastboot, developer mode, the installation itself, etc.
When i finished the installation with fastboot flashing lock, i locked the bootloader as suggested and it would automatically reboot the device on /e/.
The thing is, my device ain’t rebooting at all, it is stuck to this screen :

After 5 minutes, i tried to reboot it manually, same thing happens, stuck on this screen.
I’m a bit lost here, anyone knows how to get this right ?
Every infos is appreciated, thanks

eOS doesn’t support FP3+ in the moment. The rom for 3+ should be available end of month


Thanks for your answer !

I was convinced the FP3+ worked the same way as the FP3…
So from now, i successfully installed an unsupported OS on my phone who doesn’t boot. My PC don’t recognize it so i can’t put another version on it.
Would a reset be a smart move ?

You could try to boot the other partition.
fastboot getvar current-slot, its either a or b.

If it was a:
fastboot --set-active=b

if it was b:
fastboot --set-active=a


The install itself has worked for users with the Fairphone 3+, so installing /e/ should be possible … the new camera modules wouldn’t work until /e/ gets upgraded to Android 10, there are topics about this already.

If you want to try again and unlock the bootloader again in a state where only fastboot works, you could try fastboot oem 8901_unlock .

Else … try what @andrelam suggested.


Okay, so what i did is :

So now i’m back at the start and will wait for the eOS update.

Thanks everyone for your help :slight_smile:

1 Like

I had the exact same problem with a FP3 (without+) and what did it for me was just small change:

fastboot -w fastboot flash system system.img fastboot flash boot_a boot.img fastboot flash vendor vendor.img fastboot flash dtbo dtbo.img fastboot flash product product.img fastboot flash vbmeta vbmeta.img fastboot flashing lock

I had the occuring error that was mentioned in the description where they suggested to change to boot_b but that did not work. When I specified it to boot_a it worked somehow