Installation issue- Xiaomi Chiron

Hi,
i am also having the problem with installing /e/. It canceled while installing on mi mix2 with incompatbility error. It says i need Firmware 9.5. Coming from Lineage 15.1 android 8.
The highest Firmware Version i found, includet in actually newest Xiaomi Chiron (2020/05/08) Official Rom, is 9.1, if its true. So there will be no choice to install. Do i have to process this in the same way like it was desceibed above?

I am also horrified to repeate it to every new update installation. But there is no alternativ to go back to the goo…e spyware. Does somebody else has installed /e/ on chiron and knows the problem?

Hi,
For the chiron it is more likely a TZ (TrustZone) level problem, so a firmware level.
You’ll have to flash latest Miui first, as described in /e/ documentation : https://doc.e.foundation/devices/chiron/upgrade.
Some links here may help.

I faced this problem for months with my chiron, it’s now over after applying latest firmware.

As this is not the same device nor the same problem, could a moderator (@Manoj ?) split the subject from Camembert’s post, please ?

Is there no chance installing without mi mix2 ROM? I hate this xiaomi stoff. So i found this, to change the TrustZone without playing the komplete game wit Xiaomi.


Looks possible to fix the TrustZone problem in this way easily. If its true, why doesnt /e/ took this way? Does somebody have expiriences with changing TrustZone just flashing fw? Here i found Firmware of different Xiaomi devices:

Thanks @Manoj for the split :slight_smile:

@Camembert : it’s worth a try, I wish I’d done it myself … if I had a second chiron for testing :wink:
Miui is the easier & safer way to fully reset and update your phone, but I think Firmware Updater will work.
You may want to have this tool ready, just in case (it has EDL reboot, UNTESTED).

Edit : I could give it a try on my santoni (also Xiaomi) in a few days, currently testing my latest build on it.

Some news
Firmware flash with adb sideload successful. First a gave a try to miflashtool but i got a error flash_all.bat not found. No solution with reinstalling it, new drivers etc.
After sideloading firmware mi mix2 11.060 i could install /e/. No more TrustZone problem :grinning::+1:
My first try was to sideload , (success) but after a reset /e/ breakes booting with hopping point and restart to twrp. Then i decide to install /e/ with twrp. Deletet Dalvik, Cash, System, Vendor, Data, reboot and copied /e/ to internal memory, installed it and everything looks fine until i boot /e/ again. Same result; A hopping e and after a while it returned to twrp. Before i sideloaded fw i had a nother try with two mi mix2 rom. Downloaded mi stock 11.060 and sideload stopps with ‘file missing while installation’. The next i loaded was 11.020. With sideload and installing from internal memory it has ‘error 7 - this is for oxygen and this is chiron’. But for shure i downloadet chiron. After two days downloading with realy bad receipe its boring me.
Any idea?

/Edited some corrections/

The third try to install /e/ with zip from internal memory also works but now /e/ started to the start screen. :beach_umbrella: Time to have a cup of tea. Next will be open usb debug and install root.

There was no need installing stock rom to doe TimeZone update and in case of my chiron also not to install /e/ (hope it works fine :roll_eyes:)

Happy to read that you finally managed to get /e/ working :slight_smile:

About the reboot to TWRP at first /e/ boot : did you just wipe the partitions before sideloading ?
You have to FORMAT them.

As you installed Miui 11.x once, the firmwares are up-to-date and it is not necessary to do it again.
Some technical background : https://gitlab.e.foundation/e/backlog/-/issues/476#note_27505

I havent installed Mi 11 rom ever. I only flashed the Firmware to solve the TrustZone Problem. And yes, i formated the Data also.
Some Apps dont like writeback from Titanium correctly but most Data i could use. Just for fun i tried Signal to backup and restore but it failed, but it has to.
Titanium couldnt activate its pro because there is no Playstore. With licenses its a bit tricky.

There are a lot oft questiones around compatibility now. But thats a theme for another treat and for duckduckgo.

Titanium Backup is quite old, and won’t restore some apps (mostly multi-parts).
If you still want to buy Pro, the developer comes with a alternative solution : click on the PayPal button in this page.

I have some licenses but inside Playstore. Titanium also and now i have to write to every Dev. to ungoogle it.