Installation Issues on OnePlus 5t

I finally got my OnePlus 5t in so I could try and install /e/ :grinning: but I am having some trouble :slightly_frowning_face:

I was following the instructions on the wiki and I would get to step 8, to side load the .zip package. after I selected “install from ADB” on the OP5t I used the command ‘adb sideload’; my Mac says it is serving the file and the phone shows updating. after only a few minutes my Mac says 'Total xfer: 1.00x ’ but my phone says Installation failed. I even tried to push the .zip file to the sd card of the OP5t and load it from there instead of USB but still no luck.

The ROM I downloaded was and the version of TWRP that got downloaded from the link in the wiki is twrp-3.3.1-0-dumpling.img. I then tried to use a prior ROM image to see if that made any difference, no dice, same messages on both devices. I left the ROM file zipped, is that possibly the culprit.

What might I be doing wrong? Appreciate any thoughts on what to do next.

That sounds similar to what i had, in my case I had not installed twrp properly … digging out the forum thread from back then … my resolution was the last post.
So yeah are you absolutely positiive twrp is on it? If its not in visible writing anywhere then thats the default onplus recovery system.

@Carlos how do I ensure TWRP is installed properly? I followed the instructions in the wiki and flashed TWRP as it stated. Supposing I did install TWRP correctly how do I boot into TWRP instead of the OnePlus recovery?

Does the recovery interface look like this? Then that means its not in twrp

the twrp menu should look somewhat like this

@Romey I succeeded in installing /e/ on a 5T just 3 days ago and it worked first time. Mine is the OnePlus A5010 and the only problem I had was not being able to do a backup of its original OxygenOS system, but I used a slightly more detailed set of instructions from the xda-developers site which involves using the advanced reboot feature of the 5T to get into fastboot mode and once the bootloader was unlocked I then followed the xda guy’s instruction to let it reboot again then repeated the USB-debugging procedure and enable the advanced reboot again before connecting the USB cable and flashing the exact same TWRP image file as you used.
On rebooting into recovery I had a functioning TWRP so was able to proceed with steps 4 to 8 of the wiki with no problem. The sideloading of the /e/ zip file - the same as you tried the second time - took a little while to complete but also finished with the ‘Total xfer: 1.00x’ message which I think is normal. On rebooting into the system it took a long time for /e/ to start, but this is also nomal. Since then, no problems and an automatic update was also completed successfully.
The only thing that appears a bit strange to me is that to be able to sideload with ADB you have to be in the TWRP recovery which you don’t mention. Perhaps @Carlos was right in suggesting you haven’t properly flashed it. Hope this helps.

@Carlos that is exactly what I am seeing. I will try the directions again, although I am pretty sure I flashed TWRP correctly. Will I have to do something special to reboot into TWRP or should TWRP automatically appear if it is installed correctly?

@Grendel I did turn on advanced reboot in the phone’s settings but didn’t seem to have the same experience as you.

I’ll update once I get another chance to try the installation.

To check if you’ve got TWRP as your recovery hold the volume-down and the power button down together and release when you get a screen asking for you to press the power button again to continue. After a slight delay you’ll see the typical TWRP screen that @Carlos showed a link to above. Without TWRP /e/ can’t be installed properly and its automatic OTA backups won’t work, so make sure that you flash it again if it doesn’t appear.

@Romey I did the “mistake” of rebooting my phone after flashing twrp. After executing the flash command I had to reboot the phone into the recovery mode directly from the fastboot menu (instead of restarting the phone phone and booting into recovery through adb). Thats what i think did the job for me.

If I remember correctly, I used the below video to fill in the blanks from the /e/ instructions. Just bear in mind that the only interesting bit is the section where he actually goes through the process of flashing twrp.

1 Like

Good news everyone! I was able to get the /e/ ROM installed. Thanks to @Carlos for helping me get over the hump. The original assumptions were correct, somehow I just wasn’t booting into TWRP :man_facepalming:

I started over from the beginning of the Installing a Custom Recovery steps in the wiki, I did adb reboot bootloader to get into fast boot and then flashed TWRP onto the device again. From fastboot I used the volume up key until the top line on the display said ‘Recovery Mode’ and when the phone rebooted TWRP came up. From there I was able to follow the remaining instruction and install the ROM successfully. Needless to say plenty of mistakes on my part, but I am learning some of this as I go so it could certainly have been worse.

Now the fun begins, I have not used Android as a daily driver for several years so I have plenty to play with and learn. Thanks everyone for the help.