Installation on Oneplus Nord (AC2003) hangs on flash recovery

I bought a Oneplus Nord (AC2003 Codename: avicii) because I saw that it was compatible with e/os and I followed the procedure

Trying first with Easy Install but the program freezes when the bootloader is restarted as shown in the image:

I then tried with manual installation present on the same
page ( )
Below are the installation commands:

C:\adb>adb reboot bootloader

C:\adb>fastboot oem unlock
OKAY [ 0.047s]
Finished. Total time: 0.047s

C:\adb>adb reboot bootloader

C:\adb>fastboot flash recovery recovery-e-1.9-s-20230310268290-stable-avicii.img

Sending ‘recovery’ (102400 KB) OKAY [ 4.278s]
Writing ‘recovery’ OKAY [ 0.421s]
Finished. Total time: 8.197s

C:\adb>adb reboot bootloader

When restarting the screen freezes in fastboot mode:

Not being able to install the recovery e/os either with easy insaller or with a manual procedure, I tried to install twrp following the instructions for oneplus nord from the link

On this page there are 2 versions for Oneplus Nord AC2003 and I tried Temporary boot of the downloaded image using the following command:

fastboot boot twrp.img

To be safe, I tried the two versions of TWRP for Oneplus Nord with fastboot boot but even if everything seems ok at boot TWRC does not start, freezing at the Fastboot boot screen

C:\adb>fastboot devices
eb8abc66 fastboot

C:\adb>fastboot --version
fastboot version 34.0.1-9680074
Installed as C:\adb\fastboot.exe

C:\adb>adb reboot bootloader

C:\adb>fastboot boot twrp.img
Sending ‘boot.img’ (46572 KB) OKAY [ 2.652s]
Booting OK [ 0.109s]
Finished. Total time: 2.933s

C:\adb>adb devices
List of devices attached
eb8abc66 device

C:\adb>adb reboot bootloader

C:\adb>adb reboot bootloader

C:\adb>fastboot boot twrp2.img
Sending ‘boot.img’ (46572 KB) OKAY [ 2.508s]
Booting OK [ 0.104s]
Finished. Total time: 2.747s

C:\adb>adb reboot bootloader

Has anyone had the same problems and can give me some advice?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

hey guys
can anyone help me?

You were firstly sure to meet

Before following these instructions please ensure that the device is on the latest Android 12 firmware.

In a very quick look at your report, I do not see a match for that recovery here

The latest complete pair looks like [MD5 | SHA256] / recovery-e-1.14-s-20230816320616-stable-avicii.img [SHA256]

Thanks for your answer

yes, I updated to the latest firmware version before proceeding with my attempts

the attempts I made were different and with many recovery versions. The one I reported is one of many, in this case 1.9, but they all have the same result: my Oneplus Nord reboots the bootloader without loading the recovery

Perhaps you should

fastboot flash recovery recovery_TWRP.img

You will have seen the warning

WARNING: If you accidently flash TWRP to your device using fastboot instead of temporarily booting the image, you will need to download the latest factory image for your device and reflash the boot image.

If it seems a bit contrary … be aware the above command is doing this deliberately !

no, I hadn’t seen that!
then I should download the latest factory image and reflash the boot image.

After this should I try flashing TWRP again but not temporarily?

In that case I should not have pointed it out to you !

I noticed that you previously did

This is called “temporary booting” – it is not what we actually want in this case.

We do want is

fastboot flash recovery recovery-TWRP-filename.img

You might just open a device manager window while you work, in case fastboot makes the device become a " :warning: Problem device "

ok I’ll try and I hope this time I can complete it In the meantime, thank you for your availability

I did not ask earlier, but you did remove all encryption, passwords, locks and accounts including Google account and Factory reset before you started ?

Yes, in reality I started with factory settings and then updated the firmware and Android without configuring accounts or anything else, so the device was clean

Sorry if you read my post before this EDIT. I was wrong in what I was suggesting.

However it appears from your posts above that you may not have flashed the required additional partitions before flashing recovery:

fastboot flash dtbo <dtbo>.img
fastboot flash vbmeta <vbmeta>.img

In the eOS install guide it says:

"First unzip the /e/OS Recovery file linked in the section marked Downloads for avicii . The following files would show up in the location where you unzipped the contents of the eRecovery zip file


Well, there is no recovery paired with the latest 1.5 for S stable. In the weekly development updates they mention a problem with making this work for the T builds and suggest a solution for extracting the required .img files with payload dumper go. Looks like same problem for this S build.

Yet another EDIT: I downloaded and extracted the payload.bin. Then extracted all of the images via payload dumper go just to check if there was a recovery.img inside. Yes there is . So if you did the same you should be able to get a working recovery flashed for installing the latest stable S.

As I already have the images I could post them on my cloud if you like.

I have now seen these indications which were not there in the previous version of the instructions. I’ll try this procedure hoping it will fix my problem.
Thank you

I thought they were missing also, but they seemed to get updated overnight. Thought it might be my memory playing tricks. Did you get a recovery flashed?

not yet, I will work on the device this weekend

I’m completely confused by the AC2003 situation.
It says “supported by Easy Installer”. But there are several posts in which that is not the case.
Does not a single AC2003 device work with easy installer, or is it a game of luck?
For what I can tell, there are 2 AC2003 devices.
1 (oldest? has 3 lines of text on the bottem of the back cover, first line says “MODEL: AC2003”

Then there are devices with no text op back cover. Are these the 5g models?
Is it possible that this is the problem for the installation of /e/? The 5g models?

I really need to know since I bought one second hand, as they are very well specced.

Sorry I disappeared
This week, after a million attempts I managed to install e/os on my One plus nord!
After bricked my device (several times) and restoring it using EDL mode, I was finally able to install a recovery.
Both e recovery and TWRP didn’t work in either version so I tried Lineage recovery. The e/os recovery is derived from the Lineage one but evidently they have small differences which were important on my device
Once the recovery was installed I had to make several attempts to install e/os because it always stopped at 47% of the verification check with an error:

Error 21
Current SPL: 2023-11-05 Target SPL: 2023-09-05 this is considered a downgrade
Denying OTA because it’s a SPL downgrade

On the e/os pages it was recommended to install Oxigen 12 before installing e/os, but so I kept getting “error 21”
I finally left version 10 and flashed version “e-1.17-s-20231109350748-stable-avicii” and everything was fine!
Guys, I went crazy because I encountered so many errors, each time I took a small step forward and then I stopped at the next error, but in the end I won!
Now I can’t say I’m an expert but I’ve learned a lot
Thanks for your help

Well I bricked 2 phones. Both ac2003. With easy installer on Mac.
Looking for a developer in the France - Germany - Benelux area that I can send both devices to?
Will pay to flash /e/ on both & shipping. @Alexv ?

No, I don’t know anyone in those countries
I solved the brick of my AC2003 with the MSM Dawonload software.
It’s not very difficult, just follow the instructions.
There are discussions on the topic on these pages too

or find a tutorial on xda\

A piece of advice, don’t use Easy installer on your AC2003 anymore, it is declared compatible but it is not completely so

I encountered a similar issue. When attempting to flash the recovery in OS12, the recovery failed to boot (version 1.8). I downgraded to OOS11, successfully flashed the recovery, but now 5G isn’t functioning. Can you share which ROM version you flashed, OOS11 or OOS12, and if 5G is working for you?

After finding my device bricked I used MSMDownload to flash the cel to Oxigen10 with the avicii_14_E_04_200716 version
After this I only updated via OTA to version 11 and then to 12.
Starting from Oxygen12, however, I couldn’t install my /e/os 1.17-s and so I started from stock 10 (always avicii_14_E_04_200716 via MSM Download), and everything went well
As for 5G operation, I haven’t been able to test it.