Installation problems on OnePlus Nord

Hi guys, this is my first time trying to install /e/os.
I’m using openSUSE Leap 15.3, I have a OnePlus Nord and I cannot finish the installation.
In the chapter “Installing /e/ from recovery” at point 3 it says “in TWRP”, but if I first flash the recovery image that I downloaded earlier now I don’t have TWRP.
I put it on because after it is needed but the guide does not say it (I have the unofficial OnePlus Nord version: twrp-3.4.0-13-avicii-mauronofrio.img).
But the real problem comes at the end, at point 6 when I have to Wipe it says to select Cache and System. These two aren’t here on TWRP. There are: Dalvik ART / Cache, Data, Internal Storage, USB Storage. I tried to select the first two. Then at point 7 when I sideload the /e/ .zip package that I downloaded earlier it tells me in the terminal:

adb: sideload connection failed: no devices/emulators found
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: no devices/emulators found

I tried running as root too but nothing changes.
Sorry I have no in-depth knowledge. Can someone help me? Can’t wait to try this OS!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

take a good working data cable

1 Like

Thank you piero for the help.
I used the stock cable, now I’m not at home, I’ll try with another one.
But my TWRP Is different, I’ve not the picture you attached. If I go on Main menu–>Wipe–>Advanced Wipe there are only the 4 options that I wrote in the first message. And if I go on Main menu–>Advanced–>ADB Sideload I can’t select anything if I’m not wrong. Later when I go home I’ll try again and I’ll take some pictures.

Other idea,
Try to flash the e-recovery instead of TWRP.

1 Like

Ok, and then try to sideload the with the e-recovery adb sideload?

Sounds like you are closely following e install instructions , which is good, but sadly their accuracy varies!

You’ve already noticed the confusing twrp reference when I guess you downloaded the e-recovery and flashed it earlier.

I hope you didn’t update to android 11 before starting?

If you were on 10 then fine.

In e-recovery you have to format data, factory reset before side loading the zip.


I did the update to android 11. Let me guess, will getting back to android 10 be complicated now? It certainly has to be… :joy:
Is there an instruction that can I follow?

Might be. Depends.What is the device state at the moment? Can you boot it to stock? I guess not if you’ve been wiping and formatting.

I’m making enquiries to see if there is any more helpful info.

Thank you chris, I really need help.
Yes, I was able to start the stock rom, I downgraded to Android 10 by following a guide.
Then I flashed the e-recovery and copied the contents of slot A to slot B as it says in the guide.
Now I have to try to flash with the e-recovery instead of TWRP.
What do you mean by formatting data in e-recovery?
Can you tell me the steps more precisely?

Well done with the downgrading!

I can help you continue, no problem, but a quick word or two about what’s in store for this device would be good if you have the time.

I know that there is a build in testing at the moment for R, so in the near future this device may be moving on to R. In addition to that there are a number of other one plus devices moving on to R this week.

Yourself and many other oneplus users are going to have to install stock android 11 before flashing e OS R.

I don’t know how easy it is to return to stock after flashing a custom rom but I’ll have to find out in order to help a friend of mine who has a oneplus 6 running e!

I’ll post again in a few minutes with some instructions for flashing with e-recovery.

Ok but the planning is up to the end of the year and there is no Oneplus Nord. So will it be in 2022?
If I can flash the e-rom with e-recovery, can’t I do the same thing with the stock rom and then upgrade to Android 11?

Thats right. Flash the e-recovery onto device in the same way you did earlier. Can I ask what command you use for that? Did the given example in the install instructions work, or did you use another? It would be helpful to know. :wink:

It’s just factory reset really, but it formats data as well. Slightly different steps to twrp but achieving the same results more or less.

  1. When e-recovery home screen is up and running, select Factory reset. Next select Format Data/factory reset.

Screen will go white and output at bottom left (very small letters) when done.

  1. Return to e-recovery home screen (if not already there, can’t remember ) and select Apply update. Next select Apply from ADB.

If device wasn’t plugged to pc, plug it in now and issue the command to sideload the OS zip.

Terminal output should now show " serving"something or other as the zip is transferred across, with a percentage amount.

It will stop at 47% (all being well) and everything is being done on device. Watch the on screen output for Step 1 and then step 2. Its quite slow and you may think nothing is happening, but wait until the recovery screen changes and you then press the back arrow at top left. Output should show install status.

Press reboot system.

I don’t know. I’m trying to find out.

It’s different steps to return to stock, you can’t do it from custom recovery. Not sure of the procedure at the moment but I’ll be researching over the weekend.

But I don’t think it’s impossible, we will surely find how to do it.
What are the differences between Q and R?
Can you link me where they explain it?
I do not find it sorry.

One cannot flash stock OOS from custom recovery, I believe.

There is no definitive post to explain diffeneces between Q and R, but I would say not much. In fact Q may be preferred at the moment; for its stability, amongst other things. Main difference is Q will become unsupported first. :joy:

But this is a bit off topic

When it’s time to switch to R I’ll think about it.
I did as you said with e-recovery. It works!
Over the weekend I will try a bit this OS and write a message here with all the steps I took to install it, so if anyone needs they have a summary. Thanks chris!


Hey, congratulations Sheriff!! That’s great. Enjoy e.

Sorry, but what command works to install recovery?

The command was “sudo fastboot flash recovery recoveryfilename.img” as in the guide but runned as root with the sudo command (otherwise it doesn’t work).

1 Like

Could you please post a link to the guide in Nord documentation thread, it may help others :wink:

Sure, it’s a guide that just came out on November 10 on
Really easy
Can you link me the Nord documentation thread? I’m sorry I can’t find it

1 Like