Installation success ? But fastboot stuck

You all prove to be a valuable source of info and help. I appreciate that a lot, thank you again.

Also @chrisrg I’m not into buying new hardware, I enjoy giving new life to used materials. We have some nice websites for this purpose in my country.

I’m restarting from some WW 13 and I’m downloading a WW 14 to update with the stock recovery.
From there, I dunno if I should either try /e/O or some WW 15 beforehand.

Oh I see, It’s always better to have the last update available before doing an /e/OS invasion, alright. I will download this.

…it’s all starting to make sense to me.

So, I’m gonna install WW14 (nougat) but /e/OS builds are for android Pie. Is that okay somehow ?

If you think WW versions are for your device and if WW14 was the last update from Asus, that would be ok. But if there was indeed another WW15, and that was the last upgrade; then that would have to be the target. Looks like you can get back to the base stock os ok if things go pear shaped!

I can go back to the beginning without to much of a hassle, but it is still annoying.

Well, it seems to me that there is a WW 15, indeed.

One android version at a time might be best approach but I really don’t know…

I get the error 7 when trying to apply WW14 over WW13. Maybe I need the last from WW13 packages before continuing, same for ww14 to WW15 ? This is so confusing (frustrating, might I add).

I just saw the recovery told me I need to apply a specific package, and it confirms what I thought just this instant.

Did you wipe the data partition during your install – is that in your instructions? Ah seen your update !

I always wipe system and cache right before flashing anything.

Do I need to activate USB debugging in between each installation or can I just reboot into recovery and keep flashing new OS ?

At any restart of an Android system, USB debugging, and your permission to use your PC will be lost. So yes, you need to re-ensble USB debugging at that point.

Wipe of data is also associated with Error 7, so I would definitely do it on change of Android version. And/ or a patch might be intended to include some prep of data partition, which is why I added a spoiler ! (Hope I am clear !)

HOW-TO: Going back to Stock ROM/Recovery on Zenfone 3 ZE552KL/ZE520KL | XDA Forums

It worth a try, as we don’t know how ASUS manage their firmware :wink:

Well, once you have the device reset from base stock firmware, you just flash versions after versions and if it’s not the correct version the device will tell you the proper version to install. Then you go to the Asus website, do a quicksearch (ctrl + F) with the number version paying attention that it starts with a WWsomethingsomething (not JP-) in my case.
With all the packages being around 2Gb, it’s a really long process and I hope that after all this, /e/OS will work.

It did not work.

First, I followed the instructions again and when I went for sideload; I got error 7. Then I chose to go with “install with SD card” and it installed successfully.

Time to reboot and…nope. Boot loop. I’m back to when/where I started this thread.

Is there is an older version of /e/OS I could use to make the step from android 8 to 9 ? If yes, where to find it ?
Is it the right way to go ? Which version of android this system had when the first /e/OS build appeared ? Maybe /e/OS nougat was the starter ? Should I try with updating android to nougat and then /e/OS ?

So what is the latest Asus android stock version have you managed to boot this time before trying the eOS install?

When in bootloop have you tried these steps?: Power off device> Manually boot into recovery> factory reset> reboot.

So what is the latest Asus android stock version have you managed to boot this time before trying the eOS install?

I managed to install up to android 8.

I just did that from twrp and it doesn’t change anything.

And then it bootlooped after eos install?

Yes, it bootlooped after I installed /e/OS through SD card because I couldn’t through sideload as I got error 7.
But the first time I did the manip’ I did through sideload and I had the same result.

That’s progress.

I guess the twrp version you are using is from the webpage linked from eOS instructions, so it’s from 2019.

If the phone still has Stock android 8 (WW15) on it , even if it won’t boot now, I would try to install something else on it to get started.

I found this page with a link to an unofficial lineage os rom - Lineage 16.1 (equivalent to pie,9). They also do 15.1 but the date is older than the twrp recovery so I wouldn’t try that. The downloads page has the rom and an md5 checksum file which is a good sign in my opinion.

Might be worth a try, don’t know,

Seeing your proposition gave me an idea; I went to look for a newer version of TWRP from their official website.

I dunno what I will start with.

Maybe I’ll try installing lineageOS to overwrite it with /e/OS, see if it changes anything.

This newer version of TWRP is a good idea or did /e/ devs especially pointed at this older package for a reason ?

EDIT : NEVERMIND, I WENT LOOKING FOR NEXUS 5X INSTEAD… so no, zenfone 3 has no twrp build on their website.

This build of lineageOS works without any hassle. I didn’t install microG because I don’t care about these for the test I ran.
Once installed, I went back to TWRP in order to install /e/OS through external SD card and it did the same fastboot loop as before.
So, my conclusion is that the dev build isn’t in a working state at the moment. I hope it’s not a forgotten project. If it is, I’ll just sell back this phone and find another one that supports /e/OS.

Thank’s @chrisrg for the new ideas and paths. I’m kinda losing hope right now.

My sense it that you need to attend to Recovery.

You mention using TWRP, but also not being able to find it ! Perhaps time for a break.

You made good progress !

There’s no TWRP build for the zenfone 3 on their website. There’s only the ones proposed by /e/ team. I was hoping for a newer version.

What do you mean ?

Yes, I need a break.