Installation success ? But fastboot stuck

Hello,

I tried to install /e/OS on my Zenfone 3 ZE552KL following the installation guide but once installation is successful and I reboot into system, it always hangs up on the Asus logo a few seconds before rebooting into fastboot.
I tried :
e-0.23
e-0.22
e-0.21
(currently downloading up to e-0.19 to try out)
Through either sideload or manually placing zip files on an external SD card, pushing files being unavailable.
Now I have unauthorised when I enter adb devices or fastboot devices and no more system I can boot to in order to re-enable USB debugging.
Also, I downloaded the firmware from Asus support website to go back to their OS but the setup through TWRP is instantly crashing with error 7.

Is there’s anything I can do ?

Kind regards,
Yrdael.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello,

Is an Asus stock ROM available ?
If it is, I’d try to go back to there. Usually it’s done from fastboot or a vendor custom tool.

Yes, that is this part :

You can find it here : ZenFone 3 (ZE552KL) - Support

You say I can do it from fastboot ?

Maybe this will help? [recovery] zenfone 3 (ze552kl) stock recovery files and how to flash | XDA Forums

Thank you, I will try this when I’m back home.

I have a hard time being able to command my phone through my terminal, the phone is unlocked and locked in matter of seconds, this is so annoying.

Okay, I managed to restore the default recovery. Currently downloading the oldest official ROM from Asus. I tried the last one from Asus and e-0.19 without any success.

This screen is getting on my nerves.

1 Like

Earlier you mentioned Error 7. In my experience this often happens if you try to jump Android versions.

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

I have not checked the versions you are using, but can we rule that out?

That is nice of you to point out. I will tinker a bit more.

I have no idea which android version it is. (after install it says android 6.0.1)

Thank’s to you @smu44 I got my recovery back and thank’s to you @aibd I managed to get an official Asus build running.

Restarting /e/OS invasion.

1 Like

Good luck with this. Tell us which abdroid version of stock you got running though! Please

Never mind. Just noticed you said 6.0 in the other post.

If 6 is definitely latest, there are no worries on that point.

Looks like Asus may have pushed android 7 as the last update.Although it’s difficult to verify random information like this.

I’ve usually found GSM arena info on what android versions a phone can have to be reliable and they say it was upgradable to 7

1 Like

It is always fun to experiment @Yrdael but you could leave it overnight to see if you are offered an update (to avoid other hassles, down the line ! )

The device build’s target of the e-bla-bla-bla.ZIP is displayed by TWRP install, and should appear in the Meta-Data of the file

Sorry, what did you just said ? How do I check its metadata ?

It’s not the latest I believe and I thought it would be okay. Now I have to repeat the reset process.

Do I have to upgrade version to version following an chronologic update order or can I just skip to last update before installing /e/OS ?

Excluding Android version, the manufacture’s intermediates can usually be skipped to the most recent.

But have you now seen an Android 7 and / or an Android 8 ?

I would expect no problem to jump to the latest Android 7.

As I do not know the device I cannot really say if an Android upgrade from 6 to 8 is safe.

Also to avoid trouble I would always test that the newly installed stock ROM worked satisfactorily before starting with a custom ROM.

Edit. I suppose it is important to read the small print on the download. Some manufactures (I do not know Asus phones) may issue a relatively small upgrade, intended only as an incremental upgrade. A clue would be the size of the ROMs you are seeing. If some are significantly smaller beware of those. In the link by @chrisrg we see the ROM recommended by the author as an Android version upgrade.

Another edit, @Yrdael I found the Asus site rather hard to navigate ( maybe I needed to log in idk) but I found this

Version JP-15.0410.1807.75
2018/10/05 1.89 GBytes

ASUS ZenFone 3 ZE552KL (ASUS_Z012D, ASUS_Z012DA, ASUS_Z012DB, ASUS_Z012DC, ASUS_Z012S) software Image: JP_15.0410.1807.75 (Android O) for JP SKU only*

Which looks like Oreo and more recent than your screenshot. Do you find this?

1 Like

Lots of work lately, haven’t found the strenght to put my mind to it yesterday and probably today as well.

I have seen this and I agree it’s a bit hard to navigate the Asus website, although I found my way to all the ROMs and softs for the zenfone 3.
I have no clue on how you manage to understand which version of android ot is, using their website (which is a flaw in my point of view).

From what you guys said I understand I can skip updates but no skipping an entire version.

I am just going by (Android O) for my Oreo clue!

As the device still has Asus support, their support would be able to answer specific questions like “can I upgrade from Android 6 to 8” – or better quote your running version to the most recent download available. (I may be over cautious – I just cannot say that it is ok !)

On reflection @Yrdael I am being more than over cautious as I really do not know the device. I would expect an Officially distributed, respected manufacturer’s ROM to be self sufficient and stable unless there was a warning in the small print !

It’s interesting to see the attempt to restore this older phone and get eOS on it. I’ve been searching around as well and I don’t have anything specific to report but I’m beginning to notice a few things.

Asus software version numbers, such as WW 13.16.5.36 and JP_15.0410.1807.75 (Android O) for JP SKU only*

Looks like the Prefix letters are for phone variants, don’t know what. WorldWide? JapaN?
And the first number refers to android version, so 13 for Android 6 as @Yrdael posted above and 15 for android 8 (Oreo) as you noticed @aibd

Another thing is a lot of users in xda threads talk about the the way for upgrading stock where ota’s don’t happen is to have the new os on sdcard and upgrade with the stock recovery.

So I’m guessing the next step might be to download a WW 14.something build to the phone and try upgrading from stock recovery.

This old 2017 xda thread shows latest firmware at that time for ZE552KL is WW-14.2020.1708.56