Installing /e/ on galaxy tab S2 Wifi

Hi @twiny welcome to the /e/ forum.

Until you learn different, I would say it is unwise! This search will help: Search results for 'gts210wifi' - /e/ community

In a quick search I do find an Unofficial LineageOS for SM-T810 [ROM][UNOFFICIAL][11] LineageOS 18.1 [T710][T715][T715Y][T810][T815][T815Y] | XDA Forums but I do not see his device tree so far. Your mentioned /e/ ROM states it is SM-T813 specific. If you find references to the two devices sharing a device tree it might be possible to make a better judgement. Good luck.

PS Info about gts210wifi | LineageOS Wiki | Install LineageOS on gts210wifi | LineageOS Wiki

1 Like

thank you for answering and edited so quickly :+1:

effectively, my About tablet / model number is : SM-T810.
and of course, I will not try to install the gts210vewifi on my device.

it’s a shame because i wanted to test /e/ and as far as I know lineageOS is not /e/.
but i’ll give it a try regardless.

I just found on this link that there is a difference of processor between Tab S2 2015 and 2016:
SM-T810 aka gts210wifi has a Samsung Exynos
SM-T813 aka gts210vewifi has a Qualcomm Snapdragon
though, I will throw an eye on lineageOs for my device

Did you follow my first suggestion/link? I saw some Unofficial /e/ I thought? Refine the search for #unofficial-builds.

1 Like

thank you again for your support.

First, I tried to install unofficial /e/ build found in this post, but it has failed (error 7).
So, I decide to give a try with lineageOS 18.1 and Yes it succeed to install even if adb sideload show an error at 47%. lineageos worked well.
Then I decide to retry with /e/ and the sideload then began, and this time without error but counter to lineageos, /e/ unofficial is looping on “logo + my data is MY data”.

Just a very quick reply. Sometimes (pre Oreo) you can jump Android versions “against the rules” - that is #anti-rollback, other times you need to flash Stock ROM - What is a stock ROM and how do I get one?. Check out the “install page” in your OP for the “official warning”!

Sorry but I don’t understand well what you want to mean. what OP stand for ?

Meanwhile, as I backup through twrp in internal storage but forget to transfer on laptop, this link is very usefull for me, thank you again. :+1:

1 Like

Sorry :blush: OP= opening post. Remember I do not know what Android version you started from, so I just provided some key words for you. Now that you tried Android 11, you may have fewer options!

oh … i read. :unamused:
is this because of the ARB thing that the unofficial /e/os was looping ?

does it mean that i cannot go back to samsung stock rom based on 7 nougat ? :thinking:

staying at lineageos 18 can be the deal in condition i can install app because the embedded browser sucks :stuck_out_tongue_closed_eyes:

is this because of the ARB thing that the unofficial /e/os was looping ?

Seems the most likely explanation.

But, @twiny, an edit; did you wipe Data (that is wipe system,data,cache,dalvik) as you attempted to move from Lineage 18 to 7 Nougat. If not that would be good to try. With a “built for Nougat” device you may be less impacted by anti rollback protection. With my older Samsung I have bumped Android versions, various things went wrong but I previously dug myself out!

The important thing is to read before you jump too much. And it can be significant if you installed Gapps in Lineage, that should be avoided when you attempt to downgrade.

1 Like

THANK YOU SO SO MUCH :smiling_face_with_three_hearts:

I appreciate a lot time you spent answering me :hugs:

You were right, I didn’t think to wipe before trying to downgrade from lineage v11 to nougat v7 …
I just did it, and it has worked instantly like a charm. (despite the red message at boot: kernel is not seandroid enforcing)

I can now go discovering the benefits of this beautiful ungoogled os :clap:

PS: However, I had read everything 3 times before starting :upside_down_face:.


For T-810 there is even a LineageOS 20 version now available:

I tried building myself for gts28wifi and gts210wifi with repo sync way for LOS 20 and could successfully build. Now I tried with repo eOS sources for T using kernel, devices, vendor data and respective build manifest but receive the following error message:

build/make/core/ warning: device/samsung/gts210wifi/ includes non-existent modules in PRODUCT_PACKAGES
Offending entries:
build/make/core/ error: Build failed.
19:05:35 ckati failed with: exit status 1

How can I add this packages to the build?

Thanks Piero. For the docker way I found instructions but not yet for the repo way… can you guide me?

Not directly because i have no experience building /e/, (only postmarketOS that is less complex),
i fantasm to build /e/ for 3 years but hasn’t hardware nor bandwidth, i recently aquired a PC 4x3,3Ghz 8Gb, and just ordered a modem, so maybe in some weeks/months ?..

Look like others encountred the same issue :

Have you tried vendor e ?

A Ubuntu (/Debian) environment which built standard LineageOS would need to be sure to have the full package list starting on line 156 in the dockerfile

apt-get install -y bc bison bsdmainutils build-essential ccache cgpt clang cron \
curl flex g++-multilib gcc-multilib git git-lfs gnupg gperf imagemagick kmod jq \
lib32ncurses5-dev libncurses5 lib32readline-dev lib32z1-dev libtinfo5 liblz4-tool \
libncurses5-dev libsdl1.2-dev libssl-dev libxml2 \
libxml2-utils lsof lzop maven pngcrush \
procps python python3 rsync schedtool squashfs-tools software-properties-common wget xdelta3 xsltproc yasm \
zip zlib1g-dev

My guess is that (for unknown reasons, loosely speaking) repo init has not yet pulled in the full /e/ repositories.

That list looks like one which I expect to find in /vendor/lineage/config/

I runned repo sync again and do not have this error anymore… but other build errors I’m following up :slight_smile:

1 Like

Up to now I could fix a lot of build errors, but now I’m stucked with the errors with the eOS Apps…any ideas?

[ 62% 60072/96027] Verifying uses-libraries: prebuilts/prebuiltapks/AccountManager/davx5-ose-4.2.6-ose-release-unsigned.apk
FAILED: out/target/common/obj/APPS/AccountManager_intermediates/enforce_uses_libraries.status
/bin/bash -c “(rm -f out/target/common/obj/APPS/AccountManager_intermediates/enforce_uses_libraries.status ) && (build/soong/scripts/ --enforce-uses-libraries --enforce-uses-libraries-
status out/target/common/obj/APPS/AccountManager_intermediates/enforce_uses_libraries.status --aapt out/host/linux-x86/bin/aapt --optional-uses-library androidx.window.extensions --optional-use
s-library androidx.window.sidecar --dexpreopt-config out/target/product/gts210wifi/obj/JAVA_LIBRARIES/androidx.window.extensions_intermediates/dexpreopt.config --dexpreopt-config out/target/product/gts21
0wifi/obj/JAVA_LIBRARIES/androidx.window.sidecar_intermediates/dexpreopt.config prebuilts/prebuiltapks/AccountManager/davx5-ose-4.2.6-ose-release-unsigned.apk )”
zipro W 08-09 19:58:41 386936 386936] Error opening archive prebuilts/prebuiltapks/AccountManager/davx5-ose-4.2.6-ose-release-unsigned.apk: Invalid file
ERROR: dump failed because no AndroidManifest.xml found
error: Command ‘[‘out/host/linux-x86/bin/aapt’, ‘dump’, ‘badging’, ‘prebuilts/prebuiltapks/AccountManager/davx5-ose-4.2.6-ose-release-unsigned.apk’]’ returned non-zero exit status 1
[ 62% 60075/96027] Verifying uses-libraries: prebuilts/prebuiltapks/AdvancedPrivacy/Advanced_Privacy-1.14.0-e-release.apk
FAILED: out/target/common/obj/APPS/AdvancedPrivacy_intermediates/enforce_uses_libraries.status
/bin/bash -c “(rm -f out/target/common/obj/APPS/AdvancedPrivacy_intermediates/enforce_uses_libraries.status ) && (build/soong/scripts/ --enforce-uses-libraries --enforce-uses-li
braries-status out/target/common/obj/APPS/AdvancedPrivacy_intermediates/enforce_uses_libraries.status --aapt out/host/linux-x86/bin/aapt --optional-uses-library androidx.window.extensions --opti
onal-uses-library androidx.window.sidecar --dexpreopt-config out/target/product/gts210wifi/obj/JAVA_LIBRARIES/androidx.window.extensions_intermediates/dexpreopt.config --dexpreopt-config out/target/produ
ct/gts210wifi/obj/JAVA_LIBRARIES/androidx.window.sidecar_intermediates/dexpreopt.config prebuilts/prebuiltapks/AdvancedPrivacy/Advanced_Privacy-1.14.0-e-release.apk )”
zipro W 08-09 19:58:41 386938 386938] Error opening archive prebuilts/prebuiltapks/AdvancedPrivacy/Advanced_Privacy-1.14.0-e-release.apk: Invalid file
ERROR: dump failed because no AndroidManifest.xml found
error: Command ‘[‘out/host/linux-x86/bin/aapt’, ‘dump’, ‘badging’, ‘prebuilts/prebuiltapks/AdvancedPrivacy/Advanced_Privacy-1.14.0-e-release.apk’]’ returned non-zero exit status 1
[ 62% 60076/96027] Verifying uses-libraries: prebuilts/prebuiltapks/Apps/AppLounge-2.5.8-release.apk
FAILED: out/target/common/obj/APPS/Apps_intermediates/enforce_uses_libraries.status
/bin/bash -c “(rm -f out/target/common/obj/APPS/Apps_intermediates/enforce_uses_libraries.status ) && (build/soong/scripts/ --enforce-uses-libraries --enforce-uses-libraries-status o
ut/target/common/obj/APPS/Apps_intermediates/enforce_uses_libraries.status --aapt out/host/linux-x86/bin/aapt --optional-uses-library androidx.window.extensions --optional-uses-library androi
dx.window.sidecar --dexpreopt-config out/target/product/gts210wifi/obj/JAVA_LIBRARIES/androidx.window.extensions_intermediates/dexpreopt.config --dexpreopt-config out/target/product/gts210wifi/obj/JAVA_L
IBRARIES/androidx.window.sidecar_intermediates/dexpreopt.config prebuilts/prebuiltapks/Apps/AppLounge-2.5.8-release.apk )”
zipro W 08-09 19:58:41 386939 386939] Error opening archive prebuilts/prebuiltapks/Apps/AppLounge-2.5.8-release.apk: Invalid file
ERROR: dump failed because no AndroidManifest.xml found
error: Command ‘[‘out/host/linux-x86/bin/aapt’, ‘dump’, ‘badging’, ‘prebuilts/prebuiltapks/Apps/AppLounge-2.5.8-release.apk’]’ returned non-zero exit status 1
[ 62% 60077/96027] Verifying uses-libraries: prebuilts/prebuiltapks/BlissIconPack/app-release-unsigned.apk
FAILED: out/target/common/obj/APPS/BlissIconPack_intermediates/enforce_uses_libraries.status
/bin/bash -c “(rm -f out/target/common/obj/APPS/BlissIconPack_intermediates/enforce_uses_libraries.status ) && (build/soong/scripts/ --enforce-uses-libraries --enforce-uses-libraries-
status out/target/common/obj/APPS/BlissIconPack_intermediates/enforce_uses_libraries.status --aapt out/host/linux-x86/bin/aapt prebuilts/prebuiltapks/BlissIconPack/app-
release-unsigned.apk )”
zipro W 08-09 19:58:41 386942 386942] Error opening archive prebuilts/prebuiltapks/BlissIconPack/app-release-unsigned.apk: Invalid file
ERROR: dump failed because no AndroidManifest.xml found
error: Command ‘[‘out/host/linux-x86/bin/aapt’, ‘dump’, ‘badging’, ‘prebuilts/prebuiltapks/BlissIconPack/app-release-unsigned.apk’]’ returned non-zero exit status 1
[ 62% 60078/96027] Verifying uses-libraries: prebuilts/prebuiltapks/BlissLauncher/BlissLauncher-1.14.0-apiS-release.apk
FAILED: out/target/common/obj/APPS/BlissLauncher_intermediates/enforce_uses_libraries.status
/bin/bash -c “(rm -f out/target/common/obj/APPS/BlissLauncher_intermediates/enforce_uses_libraries.status ) && (build/soong/scripts/ --enforce-uses-libraries --enforce-uses-libraries-
status out/target/common/obj/APPS/BlissLauncher_intermediates/enforce_uses_libraries.status --aapt out/host/linux-x86/bin/aapt prebuilts/prebuiltapks/BlissLauncher/Blis
sLauncher-1.14.0-apiS-release.apk )”
zipro W 08-09 19:58:41 386943 386943] Error opening archive prebuilts/prebuiltapks/BlissLauncher/BlissLauncher-1.14.0-apiS-release.apk: Invalid file
ERROR: dump failed because no AndroidManifest.xml found
error: Command ‘[‘out/host/linux-x86/bin/aapt’, ‘dump’, ‘badging’, ‘prebuilts/prebuiltapks/BlissLauncher/BlissLauncher-1.14.0-apiS-release.apk’]’ returned non-zero exit status 1
19:59:12 ninja failed with: exit status 1

I am not sure … a bunch of lines like this makes me think of
repo forall -c ‘git lfs pull’ --are you doing this after every repo sync ?

Mentioned Week 14, 2023: Development and Testing Updates

See the “hidden” paragraph

ROM Builders - Unofficial and Custom