Installing /e/OS on a Samsung Galaxy S10+ with latest Android 12 revision

Hi everybody, I thought I’d try and ask for some advice on this project of mine I started without realizing ALL the pitfalls right from the start. :sweat_smile:

I purchased a refurbished Samsung Galaxy S10+, planning to install /e/OS “R” on it. Knowing that I’d have to flash the Samsung stock ROM before doing so, I checked the version on my phone, and had the unfortunate luck of having purchased a phone that had been brought to the very latest update, which caused the bootloader revision to be “UF”. :tired_face:

So now I have a Galaxy S10+ which, by all conventional online wisdom cannot be flashed back to Android 11, because there is no firmware with a compatible bootloader revision.

Coming here, I hope to find some advice or ideas on how to still get this phone running on /e/OS without waiting for version “S” to be made available for my device.

Since this seems to be a bootloader problem mainly, I was wondering if I could just replace it with TWRP , and then basically sideload-install a Samsung stock ROM of Android 11 via this? And then flash /e/OS on top of that?

Or maybe it is possible to go through Lineage OS? Install their 19.1 first, then downgrade to 18.1 for Android 11, and then install /e/OS on top of that?

I’d be happy and grateful for any helpful advice, as well as any additional ideas that might work towards my goal. I am not in a hurry, since my main phone is still running fine, even if it is on “O” still. So I’m willing to try and experiment patiently. :smile:

Thanks for any replies and ideas! :smiley:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

If your english understanding is quite good, you can read informations about using “combination-firmware” on the internet

I tried to get some information about that option, sadly I only found how to flash a combination firmware ROM, but not where to find an up-to-date one with the proper bootloader revision, nor what to do with it in order to downgrade to Android 11 once it is running.

Also, one video talked about Samsung adding a permission-based layer of protection before that option? :thinking:

Do you maybe have a good source of guidance for this?

So, after some experimentation, I found the solution myself. Since all of the steps are covered elsewhere already, I’ll just go over them quickly:

  • First, I installed the correct version of TWRP compatible with Android 12. For a step-by-step, go here.

  • After that was done, I downloaded the latest images for LineageOS 19, LineageOS 18, and of course eOS, for my phone, and put them on an SD card that went into the phone.

  • From TWRP and the SD card, it went like this: install LineageOS 19 with the instructions here.

  • Reinstall TWRP

  • Install LineageOS 18 with the above instructions.

  • Reinstall TWRP

  • Finally, install eOS with the same instructions.

  • Reboot, and watch the e bounce happily up and down on my screen. :smiley:

It was a bit of a trial run at first, getting TWRP on the phone the first time, but after I had that down, everything else went smoothly.

So hopefully this can help others with similar trouble. You don’t have to downgrade a Samsung phone to the Android version fit for your eOS via official firmware, you can simply install LineageOS over the official firmware on your phone, downgrade that very easily, and then switch to eOS.


Thank you so much @Geron! I followed your instructions and it worked! Not exactly like you, but at the end I have /e/ running on my S10+ (and I come from the latest Samsung stock version)

I would like to add few things:

Boot the smartphone normally, follow the LineageOS welcome screens (you can check the "Update Recovery Lineage OS, it didn’t matter much), then go to settings and search “Recovery”, then go to “Advanced Restart” and enable Advanced Restart (the exact path is: Settings > System > Advanced > Gestures > Power menu > Advanced restart). Now, when you hold the power button and go to Restart it show you have an option to boot on Recovery. And it work! (it’s not TWRP tho, it’s LineageOS Recovery)

  • If you can’t wipe or install anything with TWRP anymore, because you have errors like “error opening: … permission denied” try to mount the internal storage (home screen of TWRP, then “Mount”), then go to Wipe settings, and go to “Format data”. I think that solved the problem for me.

  • If you can’t have TWRP recovery after flashing LineageOS (even after trying to reflashing it), it doesn’t matter. Just flash LineageOS 18.1 from LineageOS Recovery, and if you are already on LineageOS 18.1, then you can flash /e/ OS from the LineageOS Recovery, it work too. (it say that signatures are not corresponding, or something like that, but you can continue)

  • Your on /e/? Congratulations! But you think than icons and texts are too small by default? Me too! You can change that by going to the settings > screen settings > advanced settings > screen size > large.

1 Like

Glad my experiences where of some help, congrats on managing the switch! :tada::+1::iphone:

1 Like

Yes your experience was super useful!

Another thing I would like to add: if you want to improve the camera of the s10+, you can follow this: How to have a BETTER camera on your S10+

This is exactly what I did for a Galaxy Tab S6 Lite, as detailed at this post. It has worked, and it’s chugging along with /e/, now matching my phone, allowing me to finally leave the Apple ecosystem. :+1:

The trick was to forget about the OEM Unlock option in Developer options, since this was not reliable – sometimes it was there, sometimes not. Instead, I booted into Download mode and selected Unlock mode to unlock the bootloader. It did its warnings, but unlock went off easily.