Installing /e/OS on my OnePlus One -- general documentation / complaining / crying thread

Like the title says.

I have an old OnePlus One sitting here, gathering dust. It works perfectly, except for one significant issue, in that it keeps fouling up SIM cards, not instantly, but pretty quickly (within a few hours/days after insertion) … maybe the phone, maybe the SIM providers, don’t know. I’m content to use the phone as a homelab wifi-only practice device (although if anyone has any suggestions on the SIM issue, I’m all ears … err … eyes).

It’s worth noting that the OnePlus already has a custom ROM on it, along with an old version of TWRP, etc. I flashed a decent custom ROM onto it right after I got it, 5 (6?) years ago. Stock Android is not for me.

I also have a nice Galaxy S7 Edge, with /e/OS preinstalled on it, purchased thru /e/ … this is my daily driver. Works great, mostly, most of the time. Just noting this, as it may come up along the way to installing it on my OnePlus.

So, since I have a new phone, I want to start playing/experimenting/learning how to hack/program on phones, using this old OnePlus, and it seems like /e/ is a good place to start, since the documentation is so nicely done, the whole installation process clearly spelled out, etc.

ISSUE #1: And, not my issue (yet) … but I see two very recent OnePlus One threads here, one person could not apply the latest OTA update, another person could not install /e/. Both threads are still active, and it sounds like both are at least partly resolved already, but I’ll keep an eye on both, and report if I bump into my own version of either issue.

That’s it for now. Progress reports to follow …

I have installed eOS on my OPO more than one without absolute no issue. Everything works fine. It was a nougat version.

I’ve installed eOS on my OPO many times and it has always gone smoothly. OTAs worked fine too.

However, I have abandoned eOS on my OPO because of issues with phone calls on bluetooth devices. On the official nougat release, the phone seizes and reboots when using bluetooth on phone calls. I did an unoffical build of the pie version of eOS. It worked better, except the sound quality was horrible for the person at the other end of a call using bluetooth. (All 3 different BT devices.) So put an AOSP build of Android 10 on the phone and everything works perfectly, except now I don’t have the benefits of eOS.

Is anyone else using eOS on a OnePlus One doing bluetooth phone calls?

It is frustrating that the project is putting resources into expanding beyond smartphones and other projects, while most of the devices are still stuck on nougat. /e/ will not become a mainstream product by staying 3 version behind smartphones. Not to mention nougat and pie have security concerns that are addressed in 10.

I have contributed to the project twice and continue to be enthusiastic about it. But losing confidence while so many devices remain stuck at nougat and pie.

1 Like

I understand your frustration. I have had also eOS pie on my OPO. But I haven’t made any BT phone call. I only have streamed music to my BT headset and the quality was very good.

Have you had OPO firmware (stock rom) on your device before swapping to eOS ? It could be that the original firmware will solve your issue.

I’m not sure what you mean by “stock rom”. The phone had the factory OxygenOS on it before I started installing eOS. Is that what you mean?

OK, when you have had OxygenOS lates version on your OPO you should have the right firmware available.

So I’m sorry, I don’t know how to solve your issue.

Thank you for offering a suggestion. It is appreciated.

Since you already have it installed, would it be possible for you to test Bluetooth and confirm Brado’s issue is with firmware? That would help other users decide installing instead of finding out issues the hard way.

Thanks and Cheers.

I’m sorry, it seems all OPO user I l know with eOS installed doesn’t use BT callls :frowning:

Hi Harvey, that’s not the answer to the question. Also, how will the issue be verified and fixed if you have the ROM installed and won’t test?

Sorry, I’m confused. What question are you meaning ??


I can’t test, because I don’t use BT. Sorry. And I have ask in testing group and the bacon user there does also have no BT headset.