Installing Magic Arena work with Aurora Store, not with App lounge (same version)


I tried to install anonymously the game MTG arena, version 2022.14.0.1269 (15 march 2022 and last one), from both aurora store and app lounge.

I previously have to say that with Aurora Store, when MTG Arena App is out of date and installed on my device, I always have to uninstall the program from my device and reinstall completly , because I get an error message telling I have an issue and must Install the App from Google Play.
(if i get this message, if i uninstall then reinstall with Aurora Store, there is no problem and the game works fine).

But with App Lounge even if i have no MTG Arena App installed, i get the error message telling me to use Google Play during the installation (which stop).

so I can install the same version from Aurora but not with App Lounge.

May be i should post a ticket, but before, are there MTGA Players here having the same problem ?

Hi Loki,

I haven’t used /e/ in a while but I did use it to install MTG Arena via Aurora store on one /e/ phone to then copy the APK and OBB files to my daily driver phone that’s not officially compatible with Arena.

The message about an error and having to install from Google Play sounds familiar. I always got it when I only copied the APK (e.g. /data/app/~~iM4BYe-SKsihASjEc4uRqA==/com.wizards.mtga-ZiT31b7Hd12AJ52BiJu-HQ==/base.apk) but not the OBB (/sdcard/Android/obb/com.wizards.mtga/ or if the OBB version didn’t match the APK version.
But I’m rather sure I was able to update an existing installation via Aurora without having to uninstall it first.

As all this has been quite a while ago I don’t fully remember the details. That error about installing from Google Play is displayed when you start the Arena app, right? Before or after you attempted to update it via Aurora?

1 Like

I don’t have this message when i install from Aurora store (only if a previous install is present on my phone).
but i always have this message and can’t install MTGA when using AppLounge.

it was quite i while i hadn’t installed MTGA.

I’ve just tried to launch MTGA, that is out of date, and i get a message telling me to update.
i can click on “ok” button that launch which repository app i want to choose between AppLounge/ Aurora/ Frdroid/ browser (google play).
but unfortunately when i chose Aurora i get an infinite waiting icon (circular loop), it doesn’t match the app. I only have 'open" at the bottom, wich open MTGA app, not updated.

PS it was downloading the update but it not installed it.

PS 2 : I finally managed to install the update using Aurora, without reinstalling all the game.
I had to go in aurora click on the update notification of MTGA which downloaded and install.
(when i launched Aurora anonymously, i was told a new session was launched, maybe this was the problem)
finally I didn’t get the message telling me to use google play when using aurora update.

when i select AppLounge I get a blank page, and MTGA is not updated.

I will continue to try to install from AppLounge for 1 month at least before making a ticket.