Integrating /e/-mail with old android-device (android 4.0.4) -> ssl-error

I’ve been using /e/ quite a time now, exactly since april’19, with my “newer” device, a galaxy s4 mini (serranoltexx). Now I’d like to have my trusty old sony ericsson xperia pro (iyokan) as a nostalgic backup-possibility. I’m not interested in usual mainstream-apps, but would like to see my /e/-email-account working. When trying to apply the manual setup, it gave me an error, saying, “ssl is broken” or somewhat… Unfortuńately, my technical understanding ends at the point of questionning, if a replacement of the ssl-library / old certificates is possible. I still hope, somethinmg like this could at least give mail-exchange-possibilities for this old system… I tried the most actual ROM for tghis device, based on KitKat 4.4.4, but there, same problem of outdated ssl…
Maybe someone can help me or point me to other helpout-possibilities. The existing forum at xda for “iyokan” seems to be in a “standby/archived-state”…
Thanx in advance,


Here is the configuration :

Make sure to select “STARTTLS” in the SMTP configuration instead of “SSL/TLS”.

Thanx for answering with “no delay” :-))
BUT the problem seems to be the certificate-exchange between my device (=outdated certificates) and the /e/-server… Therefore I asked about replacing-/updating-possibillities for an old device with an old android-version…

I see… It’s beyond my capabilities, wait for another reply :slight_smile:

SSL certificates and all around is also not my case, but it could be that you will find a solution here

I’ll try out… and post the results of my efforts !

Access to /e/-email with Android 4.4.2 and older (“lower”) versions is probably not possible because the implemented current security certificate is simply not known to the old Android systems and is rejected accordingly. This will probably be the reason why an access to log-in is no longer possible.

If it is not working as Archie has written, you can use this PWA.

Open it in your web browser on your phone, login in and safe the site shortcut to your home screen.

But you won’t get any push message or notification :frowning:

Have you ever tried this Android 5 rom ?
But don’t know if it will solve the SSL issue

or you can look here
there should be a Android 6 (CM13) available

Hey Guys,
again, thanxalot for your advices ! I think, it’s as archie has commented, the impossibility of implementing newer signing- or security-techniques for older OS-versions… (like putting a Porsche-Motor in an old beetle, … which leads per incident [joke firstly not intended !! :-)) ]
to beach-buggy…). The Idea of using the web-only-approach seems the last way to go, as you named it, harvey186 ! I did so in the past with an experiment of an even older Gingerbread-based custom-ROM… BUT this is far from usability or even convenience !
Also thanx for the link to the Lollipop-ROM (all the links at LegacyXperia are dead), but I guess this surpasses the technical possibilities of the phone (512MB RAM, 1GHz single-core), the best and newest I tried out was AOSB-ROM, KitKat 4.4.4 … The reason for staying with stock-based ROMS for me is simply the fact, that all the hardware is recognized und functional, especially hdmi-out and usb-otg ! And, of course, I*m an elder, uncorrectable adherent of the physical hardware-keyboard, still unsurpassed ! :-))
So, in the end it remains a piece of nostalgica…and surely a good no more smart telephone…

I hit that snag some time ago also. On my LG G3 I multiboot and one of the ROMs on it is a fave AOSP KitKat, Mahdi, with microG. Tried to use my /e/ account on it last year but the SSL cert thing kept that from happening. Did a little searching back then but didn’t find a solution. Bummer.

Yes, it seems that all our beloved well-working old devices are forced to loose
more and more functionality… :frowning: