Internal storage not shown in files app

Hello, so I just installed /e/ OS on my Samsung Galaxy S8. There seem to be two problems

  • /e/ drive keeps crashing (I have already wrote it to GitLab)
  • if I open files app it doesn’t show internal storage and says something like “content cannot be loaded now”. I can only view the SD card contents.
    Why is this happening and what can I do about this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Which version of /e/? (look in Settings | System Updates, which tells you the /e/ version and build date/number)

but why do you ask? Was this issue fixed in specific build?

Not that I know of. I asked because sometimes people report problems here which have been fixed in more recent builds than the one they are running. That’s why it can be helpful to mention your /e/ version when reporting problems.

1 Like

Have you ever tried another file app?


You can try to wipe cache and rebbot system. Go to:

Settings > Apps > File > Storage then wipe cache…

/e/ drive’s bug also can be a cause to that bug… Wiping its cache too is easy to try.

… and on a Samsung, another one too easy not to try is a Force stop or Soft reset.
Volume down +Home/Bixby + Power

Man, I wrote that I JUST INSTALLED /e/ project, so clearly I haven’t tried any other app. BTW this is frikin default, so why would I even try anything else? That really didn’t cross my mind yet.
And as you can see in the other thread I CANNOT install anything else due to Apps crashing
BTW clearing cache of Files and reboot didn’t help


Did you strictly follow /e/'s doc installation steps? With format data? And ending with wipe cache/dalvik before booting on system?

1 Like

Man, you have a lot of problems.
I think it’s best to start again from the beginning.

I have used the EasyInstaller and followed it’s instructions. I believe I didn’t do wipe cache/Dalvik as it wasn’t said by the EasyInstaller instructions.

I had few problems however during partition change (not sure what is it changing to)
repair or Change file system reported some red failed messages, so I looked at and did the part with exfat and ext4.

If red error messages show up, your phone is probably encypted but TWRP can’t decrypt the /data partition (it’s a common issue on Samsung phones).

Yes my phone was encrypted. Did I do that part wrong? Maybe, because it is not very clear what exactly should I do with exfat and ext4.

I can try it all again if you think it’s worth it…

This posting and the problems you are having sounds to me like your phone is still encrypted.
I would first find out if this is the case and if so, how to fix it. Then again from the beginning

hm I wonder how it can even boot if it’s encrypted! It doesn’t ask me for the decryption PIN as it did before installing /e/

Perhaps a good idea to investigate how or why Easy Installer got stuck. This page will help you find a log.

Was change of Android version involved?

The Easy installer didn’t get stuck, why do you think it did?
I was looking for the log but didn’t find it. Now I have it. You can check it here

It is rather long because as I describe there was this red error message during Change file system, so I spent some time reading the guide what to do and meanwhile many waiting messages got logged.

Regarding Android change version - given that Samsung Galaxy is up to date with Google’s Android and I had official ROM on it so it was Android 11. I can see /e/ is based on Android 9, so yes I think that means change of Android version, right? But why does it matter if data was formatted?

Hi @McVitas I will study your log and read more carefully the position you are in as regards to the workflow of your install.

But just to answer your question, why it is significant there is a change of OS version is that Samsung and Android build in anti roll back protection to disallow what you have done. So Easy Installer has some heavy duty magic to do, in this case to install 9 over 11.

Then in addition

why does it matter if data was formatted?

It is a feature loosely, of Android verified boot that a little bit of SYSTEM is written into DATA. The verification has to ensure it sees an exact copy of system (part of which is now hidden in data.) :slight_smile:

Edit, that very loose description applied to 8/9/10, we are promised more challenging anti roll back in Android 11.

Ok so that is a success log if you only read just reading the last dozen lines.

Correct, Easy installer should do this.

I had few problems however during partition change (not sure what is it changing to) repair or Change file system reported some red failed messages, so I looked at and did the part with exfat and ext4.

So this is the bit - was I missreading? did you make an intervention, or were you were cautiously reading along with the progress, then agreed to the path suggested by Easy Installer?

Man I am sorry, do you read what I write? :slight_smile:
This is not going anywhere obviously. I said I did all as EasyInstaller said. If you don’t believe me, then I can’t help you.
I will try the whole process again and will see…

Half a year later and I fixed it :slight_smile: I wiped it in TWRP and installed via the three adb commands from this guide and now it seems to be fine. Not sure what went wrong before…