Is it possible to enable fingerprint unlock on Poco F1?


I’m testing /e/OS on my Poco F1 but I couldn’t find where to enable fingerprint unlock. Is it possible on Poco F1?

Thanks in advance.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Does anybody knows? This is really the only thing preventing me to migrate my main phone to /e/.

My understanding is that if the stock RO for your device supports fingerprint unlock, then it will also be supported under /e/OS.

On a device which I know supports fingerprint unlock under /e/OS (Sony XZ Compact), when I go to Settting | Security, I see 'Fingerprint` as the second option after ‘Screen lock’. If the ‘Fingerprint’ option is not there on your device, then I guess it is not possible on your device.

It also worked on Sony Z5 Compact when I was running /e/OS on that device

The stock ROM of my device supports fingerprint unlock but the option isn’t present on /e/OS… I know /e/ is based on LineageOS and I think it does support fingerprint unlock on Poco F1. I’m going to flash it to confirm. If it works I’m going to treat it as a bug.

Thanks Pete for the information about where to look for this option. This helped me to confirm it isn’t there :slight_smile:

1 Like

Hi @rodsilva

I have a Poco F3 and the fingerprint feature was working properly until some weeks ago. Suddenly (after the May update I guess) it stopped and disappeared from the Security Settings.

I’m waiting the update for a newest version hoping that will fix this issue, but I’m not confident anymore: my device is on version 1.11, didn’t received the 1.12.3 yet and the 1.13 is already rolling out to anothers…

Maybe for your device this new update can fix this.

Hi @anderson. No, I use it on a secondary phone for long time and the fingerprint unlock never worked.

After the response from @petefoth , I installed LineageOS and it isn’t working either… When I have time, I’ll try to restore the stock ROM to see if the problem is with the hardware. I don’t think it is because I’m pretty sure it was working before I installed /e/OS.

Hey @rodsilva , ok.
Good luck with stock ROM. But seems to me if it is not working with LineageOS either, could be the hardware. I am afraid that is the my problem also…
I was thinking to change to Lineage, but I don’t see the privacy features that eOS have on another ROM.

I too have this issue an a Samsung S10 with a fresh install of /e/ OS (1.18-s-20231208360970-dev-beyond1lte). The fingerprint sensor works within apps, but does not appear as an option under Settings/Security and therefore does not show on the lock screen. I know it was functioning in the fully updated stock OS prior to flasing with / e/ OS.
It would be great to get this working.