Is my Galaxy S9+ now a paperweight?

Well, for those of you who remember my last posts, “I need a recommendation for a new phone to buy” and “a description of some problems my phone is having”(I need a recommendation for what phone to buy), I’m back with a new development, and asking for even more advice.

First, a few people suggested a Fairphone 4 for my new phone which sounded good to me… but it’s only sold in Europe, and I’m not there (I’m in Canada :canada:). So any other suggestions are still appreciated.

And next, a fun technical challenge! I don’t even remember how I got to this stage, but my phone now looks like this:

It can sit like that until the battery dies out, and it never changes. By simultaneously holding down the Bixby, Volume down, and Power buttons, I can force the phone to turn off, but when I start it again I get the same screen. Aside from turning it off, nothing else I’ve tried has provoked any sort of response. Does anyone know how to fix this? Or is it time for me to call for last rites and bury the thing?

I believe as long as it starts there is hope, especially with Samsungs… :slight_smile:

The important questions are of course which steps you took that led it to where it is now…

Since it is stuck in download mode, could you throw in something through for instance Odin? Something, anything, a version of TWRP or /e/ recovery? Just something to chew on so it perhaps shakes it off…

That MIGHT work, but there’s a problem… I don’t know what Odin is.:grimacing: You’re talking to a complete techno-idiot here. (Unless you were suggesting I pray to Odin the Norse god; hey, I’ll give it a shot, but…)

Search for the name “Vireo” on this Fairphone FAQ page:

It’s an authorized reseller that allegedly ships worldwide. You can contact Vireo on their own site to inquire.

Note also Fairphone’s blurb about lack of Fairphone warranty for those.

Of course, just because you can order and receive a Fairphone doesn’t mean that:

  • its bands will match a carrier in your locale
  • it will be approved for activation by the carrier
  • it’s certified for VoLTE calling with the carrier, even if it matches every LTE band, if VoLTE is now, or is soon to be, a requirement by the carrier.

These are things you should confirm before ordering. I would check with Vireo, and peruse discussion fora (here, reddit, XDA Developers, etc.) of Canada users, if any, making sure the information is recent.

In my experience the Odin mode screen you show us usually has some text in the top left, I am uncertain if this is a clue to some trauma or something else.

Is this a phone which once had /e/OS running on it ?

Or is it a USA type Samsung that was never designed for a custom ROM ?

Ok, let’s go back to the beginning.

Press and hold on/off button ONLY. Sooner or later the phone should shut down. Then restart, WITHOUT pressing anything else than on/off button, and it should start as usual.

If you HAVE done that, then what’s probably happened is that you have managed to somehow corrupt the OS, including bootloader. Which is not really a problem if you know the basics of flashing on a Samsung.

So you need two things now:

  1. A stock rom for your phone. Go to and choose the right latest ROM for your model. Download it and store it on your computer.

  2. If you are running Windows PC, you need Odin software ( Download Odin 3.14.4 - Samsung Odin download with ROM Flashing Tool ( )
    If you are running something else on your computer, you need Heimdal, but i have never worked with that.

You need that software to flash the ROM into the phone. There are tutorials about that, it’s too much for me to write about here.

And, by the way I am still curious about what you were trying to do with the phone and how you were planning on doing that… :slight_smile:

Oh, THAT’s what Odin is? Interesting. Last night I did… well, SOMETHING… to it, and for a time the screen was much brighter and it did have writing starting in the top left corner. Couldn’t tell you what it said though. Then I kept playing with it and it went back to the way you see it in the picture. In an earlier post I said that it had spontaneously locked itself out of my home network; and today I suddenly realized that not connecting to a network could explain it not proceeding past this “downloading” page. And of course, I can’t take it to a different network, because I can’t get off this screen to type in a password.

I bought the phone (supposedly) new but a few years out of date, and put /e/ on it right away. I’ve had nothing but trouble with it, but I never used it with the stock android rom, so I don’t know if /e/ installed properly on a lousy phone, or if /e/ installed screwy on a properly working phone. And it wasn’t a US phone; it’s an international version and I’m in Canada.

Don’t know what else to tell ya.

Cool :slight_smile: the blank Odin mode screen is not a blocker, I have seen it myself when Odin is “forced” by a bootloop.

I think this is a likely guess.

You should have a very good chance of proceeding as described by @prkfsz.

Please take your time to do some reading:

and here is an Odin tutorial.

I am very confident that you can recover the phone. (On the negative side I am not sure if you will have the difficulties found by USA users due to their carriers using exclusively VoLTE – a little more fully described in my first link.)

In choosing a stock ROM first you will want a Canada ROM, a little research will be necessary !! :slight_smile:

You will want Android 10, that is Q. You will want the latest “Software revision” (SW REV) available, but not the very latest Security patch level (SPL) – an October or November 2022 release date would be fine. (I will omit further detail, please ask again when you did some research yourself.)

Good luck.