Issue installing \e\ on my Pixel XL 2

Hello everybody,

I’ve just been trying to install \e\ on my pixel XL 2. And an issue came very quickly.
After managing to install TWRP (which was quit hard), I push the \e\ .zip on my device, I lunch the install from TWRP and then when I reboot, it goes directly to the bootloader.
And when I try to go in recovery, I find that TWRP has been replace by the Lineage OS recovery.
I’ve tried what is explained here Help needed installing ROM on Pixel 2 XL but maybe i’m unlucky, or iI don’t do it properly, but it don’t work…

Any help is welcome :slight_smile:

Are you installing a GSI or the Pixel 2 XL-specific ROM? From the thread you linked, it seems like there is something wrong with the Pixel 2 XL-specific ROM.

Try the a/b GSI file that you can find in this forum post.

I’ve tried the pixel specific ROM, and I tired to push this one “e-pie-20190827-UNOFFICIAL-treble_arm64_beN.img” but my system reboots on TWRP

Having the same issue. Used and installed the 3.3.0 and sideloaded the latest version from TWRP installed successfully. After following suggested instructions by starting from stock Oreo from, The OS does not boot, but I can sideload e.

Have you tried the GSI file I linked above? It works for me on my Pixel 2 (non-XL) after I had my own issues trying to build for my Pixel 2.

Do you mean this file?

That file did not work as the phone is looking for tiamen instead of walleye.

No, look at my comment from Sept 17 for the forum link.

A/b GSI also fails; the footer is wrong, signature verification fails and can’t find update-binary

@wilson or anyone else, is there any other suggestions? I’d like to start using e.

I have the same problem, that I can’t do
bash treble_build_lineage/
as I don’t have it.
I went to GitHub to download the treble build los folder, but no .sh was inside. Any help?