Issue installing e/os/ on Google Pixel 5a

I’m trying to flash a Google Pixel 5a, the directions are a bit confusing , under temporarily booting a custom recovery using fastboot it says to download custom recovery and downlad the file name vendor_boot.img then in step 5 it says to Flash a recovery image so I flashed the recovery-e-1.7-s-20230110250406-dev-barbet.img and it transferred the file over phone but the phone stays in fastboot mode, restarting it or restart in recovery just brings it back to fastboot. Device state: unlocked. Boot slot:a Enter reason: error boot prepare

So I reflashed Android 11 and tried to flash the vendor_boot.img file. It shows the google logo on white background briefly then goes back to fastboot mode. What do I try next?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

In Fastboot use the volume buttons to find Recovery and hit the power button to enter Recovery Mode. This should get you to where you need to be.

When I enter recovery, the phone just reboots back to the fastboot screen.

1 Like

Installation instructions are confusing and mixed up at the moment with roms for android 11 and 12 requiring different steps to flash a recovery.

If you want to install eOS-s please install google’s stock android 12 first. Also read this post about similar problems on another pixel device. It’s best practice to put stock on both slots before flashing eOS.

Then to flash recovery on android 12 pixel choose the oldest vendor_boot.img from the list. It may or may not work, I don’t know for sure. There have been problems with this recently.

If that doesn’t work you may try to extract the vendor_boot.img from the payload.bin of the eos rom you are trying to flash. Again, I don’t know this would work but think it may. Payload dumper helps to do this.

1 Like

I am having same problem with a Pixel 4a5g: error boot prepare. If I reinstall factory ROM 11 I can recover to stock, then use easy installer to get to e/OS-r. Once I move to e/OS-s I get trouble.

I will post a more details once I get home from work. I have two of these phones I managed to get to e/OS-s on mine last week, but the second one I cannot. Like I said i will post later in a new thread.

Thanks for the replies. I flashed to Android 12 and then used the older vendor_boot.img from lineage and was able to flash 1.7 e/os.


Have a look at this thread might also apply to the Pixel 5a:

You wouldn’t happen to be able to share the old lineage boot img would you? My attempts to find it only find the latest version.

I got another pixel 5a and am attempting to flash /e/os and having a terrible time. It was on Android 13 with the latest security patch and I flashed Android 12 on it and have been attempting to get the vendor_boot.img from here but when it restarts it shows device state: unlocked
boot slot: a
Enter reason: no valid slot to boot

and then it doesn’t boot into recovery. I’ve tried all different versions of vendor_boot but haven’t gotten them to boot. I’ve flashed back to stock quite a few times. What’s the next step to troubleshoot?

I think you have to flash to both slot a and b

Google has antirollback features see below

Warning: The Android 13 update for Pixel 6, Pixel 6 Pro, and the Pixel 6a contains a bootloader update that increments the anti-roll back version for the bootloader. This prevents the device from rolling back to previous vulnerable versions of the bootloader. After flashing an Android 13 build on these devices you will not be able to flash and boot older Android 12 builds. For developers who need to develop and test against an Android 12 environment, a special Developer Support Build that contains the bootloader update should be used.

After taking an Android 13 update and successfully booting the device post update, an Android 12 build resides in the inactive slot (seamless updates for more information on slots) of the device. The inactive slot contains an older bootloader whose anti-rollback version has not been incremented. If the active slot is then flashed with a build that fails to boot, the fallback mechanism of seamless updates kicks in and the device tries to boot from the inactive slot. Since the inactive slot contains the older bootloader, the device enters an unbootable state.

1 Like

Thanks @Tech-e1 ! I flashed both slots and was able to install e/os on it.

1 Like