Issue with /e/ on Nexus 5 (Sprint) Phone

I installed /e/ manually on the Nexus 5, and everything has worked perfectly during the test run. But now that I have tried to actually activate this device with my cell provider (Sprint), I am running into big issues. The device would not recognize the SIM card in the device to connect to the cellular network, I was sent a new SIM card under the assumption the previous one was faulty, but the device will not recognize this SIM card either. Has anyone run into similar issues trying to activate an /e/ device with their cellular service provider?

Please give us more information:

  1. Which e version
  2. From which stock rom are you coming ?

The most recent (Feb 15) 0.7 release of /e/, and the stock ROM I came from was just the most up to date patch of the ROM it shipped with.

sorry, we need to know the Android version.
Which version is eOS ?? nougat / oreo / pie
which version was your stock rom ?? nougat / oreo / pie

That might be nougat on the Nexus 5, 7.1.2. Meanwhile there is a newer e version from the 29th February.

And what stock rom was installed before ? Android 7, 8 or 9

It was running Android 6.

From stockROM Android e/ for hammerhead dev (nougat) usually works perfectly.

A problem could possibly be the modem firmware. Did you do a factory reset after inserting the SIM card?

Sometimes this action helps if the SIM card is inserted after the first boot of the /e/ OS.

As @archje has written, an upgrade from stock android 6 to eOS 7 should be no problem.
If his suggestion isn’t working I would go back to stock rom and when on stock everything is up to date and working I would reflash eOS again.

It’s quite amazing: Although the Google Nexus 5 - “hammerhead” released in 2013 has only 2 GByte RAM, LineageOS 17.1 runs smoothly on the device.

It’s kind of shocking to realize that Google stopped updates for this perfectly fine hardware back in November 2015! Basically saying to non-tech people: Throw away your phone and buy a new one.
It will be interesting to see if e manages to have a rom based on that 17.1 one day. There are many tech interested folks with this device.

I’ve been kind of busy lately, I will try @archje’s suggestion as soon as I can and report back whether or not it worked.

So update, tried factory resetting, at first it seemed to work. But the attempt at updating network settings hung, and upon restarting the device it has gone back to not recognizing the SIM/letting me access any cellular network settings.

I’m going to try and reflash back to stock, get it up to date, and reinstall /e/ from scratch again. Will post an update when I have the chance to get this done.

Yes, please let us know if you were able to solve the problem. Maybe read before … Google Nexus 5 Sprint Threads … and try to flash a branding free Factory Image for “hammerhead”