Issue with MMS and wifi access point (shared connection)

Hello !

I recently installed /e/os on a Sony Xperia Z5 compact, and I can’t get both MMS and Wifi access point to work at the same time. At first, I actually had trouble getting both normal internet access and MMS to work. I’ve seen many posts on this, so I gathered that some APN configuration was necessary.
The default configuration had both internet access and Wifi access point working well (but no MMS). Here is what I had by default:

APN: sl2sfr
MCC: 208
MNC: 10
APN type: default,supl,dun,fota

I found on the provider’s webpage that I should use the following configuration:

APN: sl2sfr
MMSC: http://mms1
MMS Proxy:
MMS Port: 8080
MCC: 208
MNC: 10
APN Type: default,hipri,mms

and another configuration for “APN option modem” (probably meaning Wifi access point)

APN: websfr
APN Type: dun

With the default,hipri,mms configuration, both MMS and internet access work fine, but the Wifi access point doesn’t. The second configuration was already in the available configurations. With it, internet access and Wifi access point work fine, but no MMS.
Of course, I tried simply adding dun to the first configuration, but I get an error

L’opérateur n’autorise pas l’ajout d’APN de type dun.

(The provider does not allow the creation of an APN of type dun).
I also try and add the MMS configuration to the default, but everything is greyed out and I can’t edit it.

Finally, because I saw this being asked in other forum posts: before installing /e/os I had an old Lineage OS 14.1 on the same phone, with the same provider and the same sim card, and it all worked fine.

So, I guess my question is: is there a way to add dun to a configuration without the phone/provider complaning? Alternatively, is there a way to edit the greyed out configuration to add the MMS settings there?

Thanks a lot for your help!