K9 mail app out of sync

Hi guys,
I started getting this issue a few days ago, so I am assuming it must be connected to one of the /e/ updates.
The mail app occasionally goes out of sync, but in very specific ways.
Emails are still received perfectly without issues (at least in my test cases).
When I mark an email as “read” and then sync again, it gets changed back to “unread” this is the case for both marking something as unread and opening the email.
There is some discrepancy between the web mail and the mail app, some email that were in the trash on the app, were still in the inbox in the web mail service.

Is there a way of resetting the app back to default settings to double check I didnt mess anything up?
Is anyone else experiencing similar issues?


1 Like

I’ve got the same on my A5Y17.
I’ve fixed it by deleting the account in k9 mail and adding it again…
Doing it at each update.

I tried to solve this issue, but it seems I cannot delete my last account?

Thanks guys, its nice to know that this is not a niche thing.
I did as suggested and deleted - readded the account, for now that did the job. It is a bit annoying though, i hope i dont have to do this every update. Will see if i can find something for the one account problem that @davidbe is facing

Thank you @carlos.
I cannot remove the first account I created in Mails (K9-mail-version in /e/). When I long-press on that account > Delete account, the screen jumps to the “Accounts” list (the same as general Settings > Accounts). Other accounts give no problem.

Why not try create another account and then delete the one that cause problem ?

I already tried that but it is not a solution.
When I’ve some time, I’m going to remove all my accounts (not for K9 mail). The account I cannot remove is also used for calendar syncing. Maybe there’s interference?

I have the same problem as davidbe. I’m unable to get the K9 app to work with my current email account but when I long click on the K9 icon it won’t delete. Since there’s been no response since July 17 should I assume there is no way to delete K9 once it’s been installed?

For me on Samsung a5y17 no pb to delete an account from the /e/ k9mail fork installed on /e/ by default.

I could remove all email-accounts, but not the first one I had configured.
I eventually did a re-install.

I had the same issue, resolved by removing all accounts from the settings accounts menu, then flash the last 20191010 e firmware then adding accounts gmail and e.email … Hope this issue will not come back !

1 Like

I gave up on K9 and deleted it. It took me 7 months but it looks like I finally got the default email app working in conjunction with my e.email account.