Keepass2android can't open file in murena-cloud with 2FA

In principle Keepass2android can open a file in nextcloud (here It worked at least several months.
When I recently updated to v1.15 I also activated 2FA for the cloud. Since then I struggle opening the file. I get authentication errors (code=401), even with app password. I try this setting (file is in root folder):
URL to file:
username: my_username
password: my_password / app_password

Can you help me?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Solved - after many trials.
Here is how I did it:
The dialogue of keepass2android to open a remote file is this:

Murena-cloud is Nextcloud, so I tried it many times via this button. And I failed in all tested configurations.

Now I used “HTTPS (WebDav)” and it works immediately (with an app password)
I enter:
URL to file:
username: my_username
password: app_password

And when I change the pwd-file in my mobile app it perfectly stores the change in the file located in the Murena-cloud.
Hopefully this will be of help to someone else.


This topic was automatically closed after 90 days. New replies are no longer allowed.