Keyboard Issues (Android-Keyboard (AOSP), AnySoftKeyboard)

Device: Gigaset GS290
/e/OS: 0.23-2020121590522, Android 10
In use since two weeks

This is my first posting within this forum, so please let me know, if anything is wrong or missing or you need more information. :slight_smile:

I have some serious issues with my keyboard Apps:

Android-Keyboard (AOSP) (Default)
==> Works fine except for one App: Signal. The word suggestions bar stays empty whilst typing, though Auto Correction works. For every other App it’s not an issue.
Please Note: Originally I had installed Signal via the /e/ Appstore “Apps”, but updated it via because that App Store is not trustworthy at the moment, sorry…and can’t be reached at present anyway due to server timeout?!
==> Just to make sure: Is the AOSP Keyboard really private and secure, means it is not “chatty”? I suppose so, since it is pre-installed, and read about it somewhere, but have no real confirmation.

==> Installed via F-Droid, which was actually kind of weird, along with an additional language pack. It shows no suggestions bar at all, although this option is activated. Well, first it did not, then I de- and reinstalled it, then it worked fine and all of a sudden, the bar is gone again. But when it worked, it worked with every app, including Signal.

I hope this is sufficient for someone to help me out. :slight_smile:

I use AnySoftKeyboard. Try cleaning all data and choosing the wanted language packs and interface.

Some apps do not allow using word suggestion, aiming to avoid getting that data. Maybe Signal is that way.

I’d say I did all that by deinstalling both ASK and the language pack and reinstalling both, but maybe you could specify “cleaning all data”

In terms of AOSP Keyboard, I solved this issue now by deinstalling Signal and reinstalling the apk from their website. Now word suggestion works fine for Signal as well. I suppose there was kind of a mess up by installing it via “Apps” first and then updating it with the apk from their website.

By reinstalling ASK you don’t clean its data. You should:

  1. Go to Android Settings>Applications>“Package”>Memory/Data
  2. “Clean data” and “Clean cache”

Good! You solved the problem :slight_smile:

Thx mate, but it did not help for this issue. Idk, maybe I will give it another try with de- and reinstalling ASK within the next couple of days. I will post the result accordingly.

But all in good time, since I have some other issues and nuisances to take care of. :slight_smile:

Try Openboard. It works fine with Signal for me on a Oneplus 6. Excellent language support as well.

1 Like

AnySoftKeyBoard still doesn’t work properly with any app, even after the /e/-OS Update 0.15. The app works in the beginning, but after a while the word suggestions vanish and swiping doesn’t work either. For now, I will stick to AOSP.

@Grendel: Thanks for the recommendation, will check it out sometime.