Known Issues With Install on Zenfone 8?

I was looking to finally install /e/. I noticed that there are two known issues listed on the GitLab for the Zenfone 8, both relating to the installation.

They seemed like they were resolved, and there are reports of a successful install in the forum recently. I don’t really know much of the jargon used there, so can someone confirm that it should be safe?

I understand it as you cannot install operational recovery mode you will not be able to install os itself as recovery is a mid step. However someone wrote lately about successfull installation on sake lately :thinking:

Looking at the Install /e/OS on a ASUS ZenFone 8 - “sake” guide and this is not your primary phone yet or you have a backup one, I guess you should be good to go:

The only issue I can think you might come across, is with the Vendor Image, that is probably dependent on actions of the Lineage OS community.

I added a few bullet points at the bottom of this thread, how I got the /e flashing working for my phone:

If this is still a an issue, I got the side loading working, when I was using an old version of vendor image that eboelens provided and keeps luckily alive: Dropbox - vendor_boot.img - Simplify your life

Give a try!

1 Like

Whelp. I got stuck at the same part as everyone else. (i.e.: Can’t boot into recovery.) Even when using that older vendor boot file you provided. Guess I’ll be going back to stock.

Maybe I’ll update to Android 13 and try Lineage OS. After two attempts about 6 months apart getting stuck at the same point, I’m about ready to give up on /e/OS.

There’s a build of LineageOS for microG available at

Installation instructions in the LineageOS Wiki

LineageOS showed up on level of Android 13, this is nice. But does it work properly with recovery mode and all the rest? I wonder if the issues described above are only regarding /e/ os or are they also regarding LineageOS :thinking:

That flaw with Vendor partition that some of us had, is probably not related to recovery issue you are mentioning. It would appear when installing the /e firmware after the recovery boot.

So you are stuck somewhere at fastboot flash boot recoveryfilename.img and booting into recovery?

Lineage OS must have moved with Sake to ASOP 13 recently. You would have to try, if you have more luck with the recovery mode there.

I did not reinstal my sake yet. I am so far observing if it works properly, as this my main phone and I need it to be working after maximum few hours of reinstalling :wink: Plus I am still thinking if open bootloader is a safe solution for the phone. I know that degoogled OS levels up privacy, but I am worried about security regarding the bootloader :thinking:

I am assuming you are are installing ?

Would you like to try a vendor_boot.img which I have extracted from the above ROM.

I renamed the file to e-1.11-s--sake_vendor_boot.img

Zum Stichtag September 2021 gab es meines Wissens keine allgemein gemeldeten Probleme bei der Installation von Software auf dem Zenfone 8. Es ist jedoch wichtig zu beachten, dass sich Technologie und Software im Laufe der Zeit ändern können und neue Probleme auftreten können.

Wenn Sie Schwierigkeiten bei der Installation von Software auf Ihrem Zenfone 8 haben, empfehle ich die folgenden Schritte:

Kompatibilität sicherstellen: Stellen Sie sicher, dass die Software, die Sie installieren möchten, mit dem Zenfone 8 und seiner Betriebssystemversion kompatibel ist.

1 Like

I was going to give it a try but the download appears to be broken.

Sorry for the slow responses. I didn’t expect so much help from everyone and had stopped checking the forum.

1 Like

Yes. My terminal says that sending recovery finishes successfully in 2.566s, then when I try to boot into recovery I just get fastboot again, regardless of whether I use the terminal or the physical buttons on my phone.

Could it be that I loaded the Android 12 beta to get my phone back in working order after the first time I tried?

I tried to get back to stock ROM by downloading from the ASUS website, but I haven’t found any documentation on how to install it. The beta version just has you run a .bat or .sh file, but it doesn’t seem to exist here. If that’s likely the issue, does anyone know how to install the stock ROM?

Looks like coming from the Android 12 beta was the issue. I’ve now successfully loaded into /e/OS! Thank you to everyone that helped, especially @demux.

Here’s the steps I took:

  1. Download the Android 13 beta and the rollback to Android 12. Found here.
  2. Following the steps on that page to install the Android 13 beta. (I finished all the device setup too, though I’m not sure it’s necessary.)
  3. Roll back to Android 12 using the same process as in the last step. (I set this up fully as well.)
  4. Follow the /e/ install instructions, using the vendor boot file shared by demux.

Figured this might help someone in the future.


Great to hear that you have /e/ running.

I was able reproduce that the download of e-1.11-s--sake_vendor_boot.img offered in Post #10 was not found early morning UTC today.

I was however able to download it at the third attempt.

1 Like

Hi guys,
I am looking to switch to /e/OS on Zenphone 8. I have managed to switch back to version 12 of Android but I am blocked in the installation because I can’t access EOM deactivation. However, the search function finds the option but I can’t access it… Do you have any tips? Have I missed something (which is possible, it’s the first time I’ve got my hands in this type of software layer on a smartphone)?


Asus most likely did pull the unlock tool temporary, as it is currently not working.

May have a look here as well:

Does anyone know when Zenfone 8 (sake) will receive update to Android T (13)?

Prediction on the Internet suggest that there will be no support of Android 14 most probably to this phone so it is good time to change system now :smile: However I would not like to mingle with os downgrade and upgrade again after some time.

It seems like LineageOS already has LOS 20 (Android 13) but it has no microG. And the version with microG is not updated that often as clear LOS itself.

LineageOS makes weekly builds for Android T / LOS 20.0 devices. LineageOS for Microg make releases monthly (because they don’t have the time or resources to do so more often), which is more frequently than /e/OS :wink: The latest build is only a week old - see

Just got an asus zenfone 8 and learned that the bootloader cannot be unlocked. Has anyone seen a way around this?
If not, It should be taken off the list of supported devices.

1 Like