Le2 x526 - version and vowifi & volte?


Just flashed an Le2 x526 ‘s2’ with /e/ to try it out.

Can anyone tell me if /e/ supports VoWifi and VoLTE with this device?

Also, it currently appears to be based on Android 7 - any plans to update the root OS for this device to Android9 or later…?

I also have a PocoPhone f1 ‘beryllium’ - currently running LineageOS 16 (Android 9) - this supports VoWifi and VoLTE - will it under /e/?

Any idea which version of /e/ runs on beryllium?

Thank you for any input or advice!

Looking forward to trying /e/ fully.


Hi @nrsp, you can check the list of supported devices here. Beryllium is already on the supported list but under Oreo. For OS upgrades and new devices you can add a topic under Request a device. Moving this post there.

OK, thank you!

And VoWifi and VoLTE availability on Le2 x526 ‘s2’ and PocoPhone f1 ‘beryllium’ running /e/?


Similar question here:

Iam using Leeco S2 (x526) with newest /e/ 1.8 (Android 10/Q)
There is no option in telephone or system - settings to activate volte or vowifi.

When dialed * # * # 4636 # * # * (USSD-Code), the volte and vowifi was checked out and there is no possibility to move checkbox to active.

also IMS Status (same menu) shows that everything is disabled

I tried editing the build.prop according to xda developers thread:

So I started TWRP and edited build.prop via TWRP file manager/editor

Debug Options

persist.dbg.ims_volte_enable=1 (already exists)
persist.dbg.volte_avail_ovr=1 (already exists)
persist.dbg.vt_avail_ovr=1 (already exists)
persist.dbg.wfc_avail_ovr=1 (does NOT exist → added manually)

Radio Options

persist.radio.rat_on=combine (already exists)
persist.vendor.radio.data_ltd_sys_ind=1 (already exists, but with “vendor”. In XDA, it is without “vendor”)
persist.vendor.radio.data_con_rprt=1 (does NOT exist → added manually including “vendor”)
persist.vendor.radio.calls.on.ims=1 (does NOT exist → added manually including “vendor”)

I do not know what the “vendor” is good for. As the other entrys are named “vendor”, I added to the missing entrys “vendor” too

Afterwards I rebooted and when opening Android settings menu, I got immediately asked if I want to enable wifi-calling.

when dialing * # * # 4636 # * # *, the checkboxes are enabled now. But when checking IMS-Status, it is shown as “not registered, not available”

I also added “ims” to “APN-type” in APN settings.

My carrier (o2-Germany) officially supports vowifi/volte and the sim card is quite new.

still no vowifi/volte
any ideas?

Just a short update:
I noticed that my s2 now in fact keeps 4G when doing calls. That means VOLTE works now. I also have the impression that the calls using VOLTE are louder and clearer.
Anyway, VOWIFI does not work. When trying to make a call with airplane mode activated and WiFi connected, the message appears “deactivate airplane mode or establish a WiFi connection”