LG G7 ThinQ LMG710EM - Judyln | Device Request


I wonder, if it would be possible to create an /e/ version for the LG G7 ThinQ. At release it came with Android 8. It’s currently running Android 10.
I don’t know, if it’s supported by any other Android Custom ROM.

It’s not officially supported by LineageOS, but there is an unofficial - and apparently stable - LOS 17.1 ROM so an unofficial /e/ build should be possible. Looks like the needed files are all on github

https://github.com/TheNotOnly/android_kernel_lge_sdm845 (Kernel by @NotTheOnly) 

Make a local manifest from that lot, and it should build with no problems :slight_smile:

Thank you for your help and the fast reply!

But I honestly don’t know, how to build an /e/ ROM :smiley:
Since I am no expert, I think it would be best to wait for an official build.

It’s Sunday, the golf courses in England are still closed, so I have nothing better to do, and an unofficial build is in progress :slight_smile: If it works, it should be available in the morning - watch this space.

Realistically, there won’t be an official build, as the device is not officially supported by LOS.

I haven’t forgotten about this: the build started at 20:50 last night, and is currently at 92%. It should definitely be available sometime this month :slight_smile:

… and the build failed at 98% :frowning: with an error message I’ve never seen before and have no idea how to go about fixing.

All I can recommend for know is that you head over to XDA forums and try out the [STABLE][UNOFFICIAL]LineageOS 17.1 for the LG G7 ThinQ ROM. It seems to pretty stable, with most things working.

Sorry I can’t get /e/ working for you. If anyone else fancies a try, this is the content of the local manifest I used

<?xml version="1.0" encoding="UTF-8"?>
    <!-- LG G7 ThinQ LMG710EM - judyln-->
    <!-- Get the kernel files from github/TheNotOnly -->
    <project name="TheNotOnly/android_kernel_lge_sdm845" path="kernel/lge/sdm845" remote="github" revision="new-markus" />

    <!-- Get the device tree and vendor files from github/LameMonster82 -->
    <project name="LameMonster82/android_device_lge_judyln" path="device/lge/judyln" remote="github"  revision="lineage-17.1" />
    <project name="LameMonster82/android_device_lge_sdm845-common" path="device/lge/sdm845-common" remote="github"  revision="lineage-17.1" />
    <project name="LameMonster82/proprietary_vendor_lge" path="vendor/lge" remote="github"  revision="lineage-17.1" />

And this is the error I get when building

[ 98% 120944/122831] Verifying vendor VINTF manifest.
FAILED: out/target/product/judyln/verified_assembled_vendor_manifest.xml
/bin/bash -c "PRODUCT_ENFORCE_VINTF_MANIFEST=true 	 	out/host/linux-x86/bin/assemble_vintf 	     	    -c out/target/product/judyln/obj/ETC/verified_assembled_system_matrix.xml_intermediates/verified_assembled_system_matrix.xml 	    -i out/target/product/judyln/obj/ETC/device_manifest.xml_intermediates/manifest.xml 	    \$([ -d out/target/product/judyln/vendor/etc/vintf/manifest ] && 	        find out/target/product/judyln/vendor/etc/vintf/manifest -type f -name \"*.xml\" | 	        sed \"s/^/-i /\" | tr '\\n' ' ') -o out/target/product/judyln/verified_assembled_vendor_manifest.xml"
File "out/target/product/judyln/vendor/etc/vintf/manifest/vendor.lineage.livedisplay@2.0-service.lge_sdm845.xml" cannot be added: HAL "vendor.lineage.livedisplay" has a conflict.

Good luck

Hi Pete,
I tried the same version and got the same error as you got and I can’t resolve it too.
There exist also a R version where I got a lot of kernel errors so I gave up.
More promising is a T version which is still actively developed.

Unfortunately I got the following error which I could also not address - I did not find the entries in the usual device or vendor files where this is defined:

build/make/core/main.mk:1312: warning: device/lge/judyln/lineage_judyln.mk includes non-existent modules in PRODUCT_PACKAGES
Offending entries:
build/make/core/main.mk:1312: error: Build failed.
17:01:15 ckati failed with: exit status 1

PicoTts will be a Text to speech app or library, that whoever makes the ROM you’re basing your build on has included in his ROM. Easiest ‘fix’ is just to delete the mention of the offending module in that device/lge/judyln/lineage_judyln.mk file

Thats what I also thought, but in none of the mk files in both device folders I could locate the offending PicoTts and android.hardware.media.omx@1.0-service entries

I find (and, edited, have running a build with the line hashed out) added under the /e/ OS packages

# PicoTTS
$(call inherit-product, external/svox/svox_tts.mk)



Yes I know. This line is in Q but not in T. Really strange I would expect the offending entries in the device.mk, but they are not.

Found now the PicoTTS entry. In T is under vendor/eos/config/common.mk

android.hardware.media.omx@1.0-service still to be found…

In R I find


Yes, but where to comment it out?
I did now just use export allow missing dependencies=true
which is usually not a good idea.
And needed to download clang proton
It builds now… lets see how far I get…

That was no fun… but I could build. Thank @aibd again for you help!