Line Messenger can not access network

I have one apps which “Can not access the network”, even when wifi / 4G is working fine with others apps.

The troubles maker is :

  • Line Messenger

Any idea where to look at to allow it to access ?

Hi @Pistou pl can you share the /e/ ROM build version and device you are using. Is the default QKSMS working.

Essential PH1 0.5-201902173314
QKSMS working without any problem.

Have you set Line as your default SMS app …Settings>>App & Notifications>>Advanced >>Default Apps >>Sms App

1 Like


No, sms app per defaut is qksms.
only it and Signal are available in the selection option

Have you tried using Line messenger on Lineage OS before. Wanted to check if this is specific to /e/. Tried installing on /e/ ROM and do not see it in the SMS apps list as you said. System may not identifying it as a SMS app.


No, never used Lineage before.

For the records, I use line as messenger app, not for SMS.

Line Messenger works for me. I have a new install of e-0.5-201902153276 on a Samsung S6-edge. I installed f-droid and then yalp and then used yalp to install Line. The only testing I did was to add a friend and send a test message. works for me to that level.

1 Like

Line is always working for me too since first /e/ 0.1 (Xiaomi Mido, actually e-0.5-n-201902173314)

Is this device specific? On FP2 there are two categories in Settings: “apps” and “notifications”. Should ave worked though:Screenshot%20at%202019-02-14%2010-23-33

Case closed, i reinstall the apps and seems ok now.
No idea what changed.

Thanks to all for support.

I’ve the same problem with the “Township” app, which “can not access network”, even though wifi is on (and other apps work fine).
I tried to desinstall et reinstall it 3 times, nothing changed.
I’ve a Samsung S7edge with /e/ 0.7-2019082020896
Any idea ?

Have you checked settings / microG / google services / google cloud messaging ?
If this is ON, you should see your app in the list of the approved apps.

Thanks a lot for your answer Pistou !
Yes, google cloud messaging is ON and Township is in the list of apps using it.
The other settings of microG are well activated, except google account (I don’t manage to sign in - can this be the reason ?) ; in the auto-check, all the boxes are ticked (except geolocalisation).

On my phone, i have “Google device registration” = Enable

Hope you find your way.

Thank you for helping me :blush:

Enable, too.
It’s the line just above (“Google account”) which doesn’t work for me ; I don’t know if a Google account is needed for playing such a game. But in fact, I don’t see why a Google account would be needed for that…

Would it be possible that this app is not fitted to work with /e/ ?