[LIST] Apps that work or do not work with microG

My results may be mixed. Both /e/ devices are preoccupied (one is updating).

Tested on crDroid with microG 0.2.27. Installed via Aurora Store. AM Installer is used with Aurora to block all trackers (20) on installation.
Surprisingly the app ran and behaved normally. It registered with microG.

I ran the Alert tests. Nothing happened. Went into AM and unblocked all trackers. Cleared cache for good measure. After some minutes a bunch of alerts showed up.

Back into AM I blocked all but push related trackers. No alerts. Unblocked all. Still haven’t seen new Alerts from the tests.

My /e/ device just finished updating to 1.8.1-q. I’ll test there shortly.

EDIT: A reboot is all that seemed required. On reboot I was greeted with test alerts. Cleared them, opened the app and tested. Immediate results. Cleared and tested again. Instant response.

Good to know that after some fuckery it will eventually work. Unfortunately I lost my entire E OS install trying to get back the TWRP recovery that E OS overwrites with it’s own during flashing the ROM so it will be a bit until I get to the point of fixing this reletively minor in comparison issue.

I was so tired yesterday I did not notice that you were the TWRP thing.
Fingers crossed you get that squared away without losing data or having to start over.

My crDroid device was low on battery so I put it in airplane mode. This morning I turned on networking and was bombarded by sports scores and news.
Cool deal. Not a sports person so I’ll be removing the app shortly. :grin:

I cannot edit the table in the first post, so I write it here

LibreLink (at least Italian version) app not working. It asks to be installed from Google Play

I’ve tried on a OnePlus 3, /e/OS 1.8.1-…

Could you provide a full name or developer. I see two apps.
FreeStyle LibreLink

EDIT: Tried both anyway. Teracube 2e emerald, 1.7-r. Installed via App Lounge.

FreeStyle LibreLink - US (com.freestylelibre.app.us) will not even start. No screen, no errors. Nothing. Captured a log but can’t make heads or tails. Could not find anything related to Google either.

LibreLinkUp (org.nativescript.LibreLinkUp) runs but it requires signing in. Can’t test past that.

Also tried on crDroid ROM with microG. Same with FreeStyle. On both devices there’s some kind of DEBUG dump. Before that there is an error about not being able to start a debugger since it cannot load the jdwp agent.
Searching the error brings up quite a number of hits.
It looks as though it fails before even getting a chance to query anything Google.

I suspect maybe the device being unlocked. Went to the FreeStyle site and checked their FAQ. The app is not supported on rooted Android or jailbroken iPhones.

A maybe also. App requires NFC be enabled. Never use it so it was disabled. Had already uninstalled before seeing that.


EDIT 2: What a dope I am. I should’ve just searched for “librelink microg”.
Your issue has been covered already. Disregard previous ya-ya maybe.

[com.freestylelibre.app.gb] LibreLink using BIND_GET_INSTALL_REFERRER_SERVICE to detect abscence of Google Play · Issue #1589 · microg/GmsCore · GitHub

Spoofing my Diabetes app so it runs without Play Services - r/CalyxOS

Even from our own forum. My bad.
Install app that is GSF dependent, consequences? - Using /e/OS / Applications - /e/OS community

1 Like

@marcdw What a research, sorry for the time spent for me. Really really appreciate! :pray:

LibreLink is the app used for activating (once) and scanning the sensor on daily basis to retrieve data. LibreLinkUp is made for parents/caregiver to only see the data of an user (eg. to look after their child’s data, for example if he/she scans the sensor on schools, trips, …).

The apps differ based on where you live. I found the Italian version (I live in Italy), and even downloading it via Aurora store after signing in with my G account don’t make it works (same error: download it via Play Store message).

Even if I activate the NFC prior to launch the app, nothing change. Same old error.

So, in the end, seems no one could make it works.
The solution they propose are:

  • using another device, which is the one I’m doing right now (using an iPhone);
  • using another app, such as Diabox (which I can’t make it works with the NFC, but I’m going to dig into the issue), but unfortunately for me I need to use the original one to push the data to the server so my doctor could see them.

So I just tried this again. Still can’t get any push notifications on thescore app. Not sure what you’re referring to by “unblocked by AM”? Microg is version 0.2.26 on the 1.7 R build that I’m running and there doesn’t appear to be any sane way go update microg. I attempted to add the repository on f-droid but it keeps coming up as “unverified” and shows no updates. Thescore app shows as having “registered” status in microg so I have no idea what you did differently to get push notifications working…

Oh, I am sorry, AM meant App Manager. I use App Manager (AM Installer) as an installation method in Aurora Store. It can block in-app trackers during installs.

Successful test was on crDroid with microG 0.2.27.
The Teracube is still on 1.7-r and microG 0.2.26. I will test TheScore ASAP and see what happens.
May also try on 1.8.1-q with 0.2.27.

And as mentioned before, there is no way to update /e/'s microG with upstream via normal means. Different signatures. Adding the microG repo won’t help.

Test Number 1.

Teracube 2e emerald, /e/OS 1.7-r, microG 0.2.26.

Failing but there’s a but.
Grabbing logs I see that all attempts to reach analytics-tracker.thescore.com fail as it is being redirected to localhost / That tells me it is being blocked.
I do have InviZible Pro with DNSCrypt so I disabled that and rebooted.

URL is still failing. On my other /e/ device, after updating to 1.8.1 I found I could no longer get mail in the Outliook app. After some fiddling around I found that Advanced Privacy was blocking outlookmobile.com among others. Once unblocked all was good.

Figured AP might be the cause for theScore.
Now I have my own problem. Advanced Privacy crashes. It will not run so I cannot check if it is blocking theScore.

Will now test on the other /e/ device.

Test Number 2.

Essential PH-1, /e/OS 1.8.1-q, microG 0.2.27.

Initial tests failed. Made sure network was clean, couple of reboots but still nothing.
Logs didn’t show the same localhost messages but it did show that the hostnames could not be resolved.

Now I go into Advanced Privacy and see that it is blocking the hosts.

Unblocked just the hosts and tried again. Nothing immediately (I think I did a reboot).
So I just turned off blocking of the app. On reboot I was greeted with an Alert. In the app I ran the tests again, instant response.
Back in AP I see more items added that probably would have been blocked also.
Haven’t tested reenabling block and selecting only ad stuff.

As it stands, with me, I cannot say microG 0.2.26 is the problem since I am unable to run AP to clear the blocked trackers on that device.
Here’s hoping the T2e gets updated soon. If impatient I might consider switching over to the dev channel (plus it has rooted debugging :grin: ). Depends on how lazy I am.

While composing this a couple more alerts showed up.


Advanced privacy was the problem. I temporarily turned the “block trackers” switch off, sent a test alert and it instantly was received. Advanced privacy also seemed to be fucking with the Adaway apps ability to block ads within TheScore app. It started automatically working once “block trackers” was disabled. I then re-enabled “block trackers” in advanced privacy and rebooted and everything is now working as it should. Looks like an oversight from E OS…

Thanks for your help. Hope you get your issue with advanced privacy sorted out as well.


Audible | Audiobook and podcast service | SP | no
I can install the app, login into the account, download the audiobooks, but when trying to listen to them an error shows up: “There is an error. Try again later”

Phone: Samsung SM-G950F // /e/ 0.23
Last update, 12nd April 2022

DUO Mobile seems to not be working and was wondering if anyone has had success in restoring an account within the app.

Application installs fine, but the only way to get my existing account moved over to it, is to click on “I have existing accounts”. After pressing this, Duo Mobile wants to connect to Google Drive since thats how it backs up accounts. When pressing on this, it just crashes, going back to the main page of DUO mobile.

Tried adding an Google microg account as well as adding a normal Google account, all were successfully but no change.

Loving /e/ OS and the idea of it but this is the one piece that is preventing using it as a daily driver.

Please let me know of any additional information or anything to test out. I love the whole “custom ROM” world. This phone can be wiped, reinstalled,etc since there is nothing on it (yet).

Phone : Oneplus 6t
OS Version : Updated to 1.10 last night

The new DAK app is now working.

Either since the app update to 3.11 or the OS update to 1.11 it doesn’t work anymore.

There are a few apps with DAK in the name. Which one exactly by which author/developer. See if I can test it.

The package name is de.dak.dak_app

Ah, OK.
Tried on /e/ 1.10-r and crDroid with microG (A11).
Message on both, in German, says the app will not run on rooted device or custom ROM. Along with a qr-code to send them for additional help if that is not the case.

Tried three others. Oreo, Pie, and another A11. All with the same error.

Also checked out a log. Mentions protected app.
I am inclined to think it checks bootloader (un)lock status.

Thanks, but I relocked the bootloader after installing /e/os. Anyway, that means the check was introduced with the latest update of the app. I guess, I’ll switch insurance to one that let’s you use their online services without an app or with one that works with /e/os. Sadly, it’s hard to find up-to-date information about that and you can never be sure they just change it in the future.

1 Like