[LIST] Apps that work or do not work with microG

Not Working (on my Samsung Galaxy S7)

The list is editable you can move them to the not working part

PayPal | Banking; installs with SAI but crashes constantly
Spotify | Reported as working above. Apparently not working on Galaxy S9+ bought from /e/ store

These work on my Galaxy S9+ (SM-G965N) /e/OS 0.16-20210424112062

1 Like

Can someone with the necessary “trust” level in the community please add the following to the working list:
App Name = “Tangerine”
Description = “Banking”
Country = “ca”
gg = “no”

This is on a FP3, so I do not know if it will work on a device without a re-locked bootloader.

1 Like

Added Strava to the ‘Doesn’t work’ list. The app installs and runs, but hangs when trying to log in

I can confirm

Spotify | Reported as working above. Apparently not working on Galaxy S9+ bought from /e/ store.

This now works on the Galaxy S9+ (SM-965F) /e/OS 0.16-20210422111918

Pulled via Aurora Store. Spotify Version:

No, because we don’t know what apps have been tried and not tried. “Known to work” would be a valuable thing to know.

Added ‘Doccle’ (Belgian administration app)

Works perfect without Google. :+1:

I got a regression with the latest OTA update /e/OS 0.17. A norwegian banking app named ‘Vipps’ I was able to get working before by rooting then using magisk hide. After the update to 0.17 the app seems to always detect root. The only reason I rooted my phone was to use magisk hide to hide root from apps, ironically, as that has been working for me.

Has the issue where apps detecting root where the device is not rooted been fixed in 0.17? If so I would try to remove magisk.

1 Like

Thanks lot. If vipps works or not decides whether the e is go or no-project for me.
I have no idea of how to use magisk.

I wanted to create this topic as a list for users who are experiencing apps crashing or not working on FP3+ devices without trackers enabled. Please send me messages if you own FP3+ and your app is not working properly for whatever reason. If it worked before, mention a build you used when it worked properly.

FP3+ Broken Apps:

  • HabitShare - last worked under /e/OS 0.16
  • Spotify - doesn’t work with all trackers blocked (under TC)
  • Infinity for Reddit - doesn’t work with all trackers blocked (under TC)

I just rooted my Galaxy S9+ and some apps stopped working for me as well, Wells Fargo banking app, Amazon Shopping app. Magisk hide did not work in my case either. But makes me wonder if it’s Magisk/Magisk Manager or the ROM?

WeConnect from Volkswagen is listed as working but I’m not able to access the Google map within the app for destinations, which is the main reason people use it… I’m wondering if this aspect was checked when it was listed as working.

EDIT: listed is We Connect ID which is not the same as the We Connect app…my bad.
Still I would like to get We Connect working. I’ll edit the table.

Had an app that constantly crashed after performing a certain action. Logcat revlealed it was related to microg libraries. Upgraded to latest /e/ 0.17 and that solved the problem.

If you are having issues with apps not working with microg it might help to upgrade to the latest /e/ if you are not already on it :slightly_smiling_face:

1 Like

Indeed, I have listed we connect iD as functional ;-). Unfortunately I did not test we connect app…

If you can test it that would be great. If it’s not working I can raise it with microG.

I believe that the list of not working apps is too big and not right. Like the app asn bank and coronamelder is working though


I have installed middle of September this build : e-0.18-q-20210813129945-dev-a3xelte.zip (since : /e/ image ROM download)

Work fine (just one error message per moment on screen, no impact on OS for me)

And at start, Itsme don’t work…

And since yesterday : It’s work, yeeeaaah

Magisk version 23.0 + hidden on app
Itsme version 3.4.1 - build 1629733016

Device is correct found on APP info and OS version is Android 10

:belgium: people can reused this app :slight_smile:

Found currently following issues here with e/OS 0.18 20210828 containing MicroG 0.2.21 (btw. 0.2.22 is current stable)

  • “eBay shopping” ( : can’t logon anymore, triggers MicroG crash somehow
  • “Corona Warn-App” (2.12.1): display warning about “phone is rooted” (but it isn’t)
  • “MySkoda” (4.4.0): display warning about “phone is rooted” (but it isn’t)

Can one confirm the same?
If one is interested in logs, drop me a note.

Instead of “Corona Warn App” from Playstore, I would suggest to use “Corona Contact Tracing App” or CovPass" App from f-droid.
Both FOSS forks of original Apps, but working without Google Services. :wink: