[LIST] Banking Apps on /e/OS

I only installed them yesterday (using Aurora) but so far both Nationwide and Starling Bank apps both seem to be working fine.


Should PayPal be mentioned here? Works perfectly fine for me.

Phone: FP2 (Rooted with Magisk)
OS: e-0.18-q-20210827132307-dev-FP2
Bank: Sparda-Bank West eG
Country: Germany
App: https://play.google.com/store/apps/details?id=de.sdvrz.ihb.mobile.app

Works fine.

For those having problems getting their Banks app to work, I had a problem with mine. I looked at TrackerControl and turned off its blocking of the bank app, but still it didnt work, but when I turned off Monitoring of the bank app, the app worked. Seems the bank apps are smart and dont work when being monitored. Which is good.

CIC seems to no longer work. Its current version, 9.40.0, displays a warning about the device being rooted, even if it is not.

Mobile Banking (Bank of Maldives PLC) work fine with no issues.

Mobile Banking

Update: the QR reader for the KBC app doesn’t work on the Moto G7 either.

For France Credit Mutuel app work fine (all features tested). I don’t know if it’s relevant but Paylib (mobile payment) doesn’t work (but it’s another app (Lyf Pay))


1 Like

Vivawallet Greek ebank with servise around Europe not working. Show message “This app will not work correctly on rooted devices”.

Eurobank Greek Bank and the app working normal

National Bank of Greece work fine with no issues

1 Like

The NatWest Mobile Banking and Lloyds Bank Mobile Banking apps (UK) both work perfectly for me

hi, I’m from Italy and I’ve tried the Mediolanum Bank app and it works.
I’m also using PostePay, which is an app that manages pre-paid debit cards offered by our postal system, and it works fine too.
I installed both of them from Aurora Store. Currently running on a Google Pixel 3

1 Like

Thought it might be interesting to note on this thread that not even my own bank stands over it’s own banking app :sweat_smile: I wonder how many other banks have similar text buried in their TOS. Maybe people can post their bank’s TOS for the fun… like if you have absolutely nothing better to be doing :stuck_out_tongue_winking_eye:


Credit Agricole “Ma banquet” does not work on Murena 0.20 stable (avicii). It was not working on 0.19 as well. App starts but then the securipass activation complains the device is rooted, while it’s nor.
It did work rooting with Magisk but I think we should list only those app working OOB or we may end up in an unmanageable number of special cases that would be impossible to reproduce. In my case, for example, if I root the device, the UBS app stops to work.

I can’t seem to edit the table (I think I might not be active enough) to add two apps that work in Portugal in /e/OS 0.20 (didn’t work in 0.19):

Is there a place in this forum where we can report the banking apps which DO NOT work ? It could be as useful as those that works.

There is yes, and also for apps that DO work. It’s a bit disorganised isn’t it? Just like Android Settings!! lol

1 Like

The Crelan bank app (Belgium) is working well for me. All functions that I have tried work.

Only issue I have found is that the Payconiq Bancontact app does not work. Payconiq app is embedded within the homepage of the Crelan bank app. It is basically just a one off link though and does not impede functionality.

1 Like


A few days ago, I installed /e/OS on my Fairphone 3. Everything works like a charm, but the problem with the banking apps is really a downer.
bks and
elba doesn’t work at all.

Maybe there is someone who can tell me if there is a workaround or even if there will be a native support of the banking apps in the future.

Sadly, this is the only reason why all my friends don’t want to change to /e/OS.

Thanks, Reini

1 Like

Hi Reini, and welcome to the forum.

Yes, also my friends do not want to move ftom stock android for a myriad of reasons.

But they all use the web interface an do not trust banking apps. Many of them are working in the IT sector.


French bank’s app “Crédit mutuel Bretagne -CMB” is working fine
Installed from aurora store, I was able to registered my phone as a “trusted device”

1 Like