[LIST] Devices working with the Easy Installer

Thank you so much for your answer and help proposal but having no technical knowledge, I’m not planning to go to such lengths to install /e/ and it is the same for the vast majority of people allegedly targeted by /e/. I want to be able to recommend /e/ for other people who have a S9 or who would be interested in having one with /e/ but it is impossible since /e/ unfortunately still doesn’t offer an easy way to flash them.

I will wait /e/ team’s fix for this major flaw in order to flash my S9 and the ones of the people I know. I guess they have to fix that really quickly since such a contradiction for the allegedly easy installer makes no sense at all.

What does “except nougat” mean on the S7s? Does it mean the install will not work on phones that have been upgraded to nougat?

I haven’t bought the phone yet, so it would be good to know. As I understand it, an S7 can have anything from Marshmallow to Pie.

You are correct in thinking that a device already on Pie should not be downgraded to Nougat. Nougat is what to expect from Easy Installer today. The dev build however is Pie.

1 Like

Most of the used phones I’ve come across are still on marshmallow, so I probably won’t have a problem. I’m just kind of poor and can’t afford to make too many bricks.

@Manoj could you not ignore my questions?

Thanks in advance

No it has not been fixed . The Easy installer is a community based development initiative. Users with development experience are free to pitch in and help with its enhancement.

In this particular case, what would have to be done in the easy-installer source code? My understanding so far was that the installer always installs what is called “stable” currently.
So wouldn’t be the easy “fix” to declare Android 10 stable for starlte? :wink:

Or are you talking about letting the user choose between stable and dev channel?

2 Likes

I went through the process of attempting an upgrade of my S9 but it only reloaded v. 0.16. I probably misunderstood what was going to happen. I run Ubuntu 20.04 and loaded the Easy Installer and then downloaded e-0.16-o-20210422111918-stable-starlte.zip. I followed the installation/upgrade instructions at the devices/starlte/upgrade site. All went well but I came up with Android 8.1.
I guess I will wait for the OTA version and hope for the best.

Gigaset GS290: worked for me :smiley:

Brand new GS290, without google account, Android 10 was pre installed, only needed Wifi connection to run system update and do OEM unlock.

Easy Installer 0.12.3-beta installed via snap on Linux (Manjaro).

All steps as described in the installer were done. Installation went without problems.
/e/ 0.16-20210422111920 is now running.

Thanks!

5 Likes

A report that Samsung G960N is not yet supported.

Review of Easy Installer help request on Telegram

Our contact asked for help where mysteriously Easy Installer failed to complete.

  1. We see that we have sound contact with the device.
    OS name = Windows 10
    List of devices attached

21xxxxxxxxxxxxec device product:starltexx model:SM_G960F device:starlte transport_id:28

  1. Downloading reported ok.

validChecksum(C:\Users\DXX.xxxxx\AppData\Local\easy-installer\sources\e-latest-starlte.zip.sha256sum)
2021-05-27 13:09:41,614 DEBUG [Thread-5] e.e.i.t.DownloadTask [null:-1] ChecksumLine = ddad9d6e11f681dd4801b9fd55b911f1ea9374f9691e1055a44eaa143c5824d7 e-latest-starlte.zip
2021-05-27 13:09:41,615 DEBUG [Thread-5] e.e.i.t.DownloadTask [null:-1] createFileChecksum()
2021-05-27 13:09:44,463 DEBUG [Thread-5] e.e.i.t.DownloadTask [null:-1] compare checksum: ddad9d6e11f681dd4801b9fd55b911f1ea9374f9691e1055a44eaa143c5824d7 vs ddad9d6e11f681dd4801b9fd55b911f1ea9374f9691e1055a44eaa143c5824d7
2021-05-27 13:09:44,464 DEBUG [JavaFX Application Thread] e.e.i.c.s.DownloadSrcController [null:-1] DownloadService.succeeded()
2021-05-27 13:09:44,464 INFO [JavaFX Application Thread] e.e.i.c.s.DownloadSrcController [null:-1] startNextDownload()

  1. Fails:

(debug)C:\Program Files\easy-installer>“C:\Program Files\easy-installer\bin\heimdall” detect 1>nul
2021-05-27 13:10:10,133 DEBUG [Thread-17] e.e.i.m.Command [null:-1]
(debug)ERROR: Failed to detect compatible download-mode device.

and,
2021-05-27 13:11:14,637 DEBUG [Thread-17] e.e.i.m.Command [null:-1]
(debug)ERROR: Failed to access device. libusb error: -12
ERROR: Failed to access device. libusb error: -12

and at the end,
(debug)C:\Program Files\easy-installer>“C:\Program Files\easy-installer\bin\adb\adb” -s ““21xxxxxxxxxxxxec”” wait-for-recovery

  1. libusb error: -12 error is reported against Heimdall #243

Benjamin-Dobell commented (re the general thread there) “Hmm. it couldn’t open /dev/bus/usb/001/050, due to a general IO error, which unfortunately isn’t very specific, and is quite odd. It’s not a permission issue, because there’s a separate error code for that.
I did some quick digging through libusb and for this error message to occur POSIX open() is setting errno to EIO, which is unfortunately a general error. However, under normal circumstances, realistically it shouldn’t occur, you should get a more specific error. This makes me think that there is a driver bug, or some kind of hardware failure on your system - but it’s hard to tell with such a generic error.”

  1. [Solved] Try a different cable! The caller told us he had been using the Samsung cable that came with the device, a replacement allowed Easy Installer to complete.

What does this tell us?

Perhaps everyone planning to flash a phone should blow all their USB ports out with compressed air.

Throw away any USB cables with slack connection.

Throw away any twisted usb cables. The only good reason to wind a wire is to create an Electromagnetic force.

Buy a new data cable for good luck.

I don’t understand what the problem is since the installer is supposed to install the stable release and that your website clearly states that the S9 stable release is android Q.

So does the easy installer finally flash eos android 10 now?

If not, then what is the exact problem preventing it from doing so and when will it be finally fixed so that eos users can be able to flash galaxy S9 as pretended in eos documentation?

It is a known error in documentation.
STABLE Q FOR S9 / S9+ DON’T YET EXIST :

I have asked the developer to display the detail of the OS version to be flashed while the installation is in process. Also will check if we can show the details of the stable builds OS versions in the documentation.
Reg the S9 the stable builds are not available as we are working on upgrading the OS OTA. The s9 is a device we sell through our eShop and any change in the OS impacts all the stable build users.
For now only manual install of S9 Q is available as mentioned in the documentation.

We have another report of a GS290 which will not start following Easy Installer reporting success. (Reported by @tyru1 in another post as “tout neuf”, brand new.)

I see no documentation for recovering the phone in this situation.

In Gitlab #3429 GS290 bricked @Anonyme linked https://community.e.foundation/t/echec-installation-gigaset-gs290/30792/7 but this now returns “Oops! That page doesn’t exist or is private.”

This page Installing /e/OS after removing UbuntuTouch on the GS290 was reported in this post in the thread Stuck on fastboot flashing unlock(Now Black screen) as successful, we do not know if @tyru1 is in exact same situation.

If only I had found your post sooner. I just bought a samsung S9 (starlte) because I saw that Easy Installer worked for this F960 model. Only it doesn’t work anymore because nowadays these phones are al upgraded to Android 10. Only if you firs downgrade to 8 it will work. This is to much for me, so I am stuck with this phone on Google and will wait until the Q version for Easy Installer will come out. So same as post Privacyman, Apr 30
I would like to try the manual installation of Q rev. Having read the instructions it made my feel a bit afraid, this also because of experiencing already difficulties with the Easy Installer i have posted earlier.
Still searching the posts for something the gives me the courage.

Any news when/if FP4 will be available to install /e/OS with the Easy Installer?
Thanks

Hi @Manoj, when I check the Official version of this list I no longer see Teracube 2e on that list, did I miss a report of the device being withdrawn or is it just missing from the page? With thanks.

That is correct. For now Teracube 2e has been removed from the list of devices supported on EasyInstaller. There is a warning as well on their forums that the /e/OS ROM is only compatible with Android 10 stock of 2e. Once we have resolved the issues with EasyInstaller support, we will add it back to the list.

2 Likes

It worked for me - model SM-G930FD, 0.19-20211023142428
@oobleck

1 Like