Location doesn't work

This is a follow up to this thread.

I unbricked my fairphone 4, reflashed e-os, was very careful to not forget anything, and do everything correctly and configured e-os in a way that advanced privacy was never activated.

After all that I can confirm that the GPS doesn’t work. I also tested if it worked before installing e-os on the factory android and it did very well, so it’s not a hardware issue.
I also did all the updates on the stock android before installing e-os this time.

Does anyone know how to fix this or do I have to switch roms ?

EDIT: this time I’m on e-os 1.2 stable

GPS works well on my FP4 (stable build).

Try to go back to stock Android Fairphone OS. Instructions here:

Then apply all updates (system updates + Play Store updates). This will also upgrade your firmware.

Then flash again /e/OS, everything should work correctly.

I already did all that before flashing e-os, what is in that image that’s not in the default factory os ?, also as seen in the previous thread location works on calyx

So that’s weird, it should work.

Did you try to put location “off”, then “on” again. Try to clear cache and data from all apps that use GPS.

Then open Magic earth from outside a building, allow the app to use the location, and leave it on during 5-6 minutes?

@yz3en, @stanwood, if you have the same phone, perhaps you could double check if you have the same GPS.conf file?
Or can it be due to the network/phone provider? @stanwood, does GPS work fine without 4G data?
@yz3en, an idea, do you authorize localisation with Mozilla API in microg settings:

Well I have the same config, except the bluetooth location which is off.


Sadly I haven’t been able to get a consistent GPS fix on my /e/OS phone as well :confused:
I installed it on my OnePlus 3T. It’s running 1.2-20220728206630.

Really not sure what the problem is. I have the same settings as you

This thread lacks clarity! :slight_smile:

Please can you define the app or other area where you are experiencing the perceived “Location failure”. Generalised location issues that are frequently asked seem to break into 3 categories

  1. Map app is slow to start. Over simplifying Magic Earth | Maps is slow to “pick up all the clues” to the device location. Many suggestions found in this this is a linked Search #Maps + Location involve using Maps for a real job outside and moving rather than sit and look at it indoors!

  2. Gps is reported to “just not work”. GPSTest, GitHub - barbeau/gpstest: The #1 open-source Android GNSS/GPS test program found in App Lounge or GPSTest | F-Droid - Free and Open Source Android App Repository is a good tool to try to confirm this. In many locations (static) one’s “fix” is classed as Amber; maybe Amber is sometimes discounted without supporting data.

  3. /e/ ROMs > 1.0 include Advanced privacy Support topics #Advanced privacy this can be switched on or off, but please read the manual before switching it on if one is not familiar with it. Advanced privacy includes Fake my location.

Side effects
After enabling Fake my location, users may face some unexpected behavior …
/quote from: Advanced privacy Fake my location.

1 Like

Wifi scanning and bluetooth scanning are on, and so are mozilla location service and nominatim.
I don’t know how to test for GPS without 4G but it didn’t work after disabling mobile data.


  1. I tried on magic earth and organic maps, outside and inside.
  2. Tried GPSTest just now, I let it run for 5 minutes and it can’t locate me.
  3. Advanced privacy is totally turned off and never was turned on at any point since I flashed the phone.
    However I remember from last time that faking the location did give me GPS coordinates although fake ones lol.

I solved the problem, I tried switching SIM cards (with different carriers) and that was the problem.
French carrier Bouygues Telecom doesn’t work but Orange does.
As for why, I have no idea because the location did work on stock android.

Interesting. I’m on Bouygues Telecom as well and also had the problem at first. Then, it started to work, maybe because I did this, but I can’t be sure.
Is it still not working when you try with the Bouygues SIM again now?

Just tried that and nothing changed, still no location with bouygues.

I think that the root cause is Bouygues Telecom. It has only been working for me while travelling abroad: I was doing roaming with my Bouygues SIM card so I was not actually using the Bouygues network, I think.
Shall I report the issue in Gitlab or do you do it?

I’m using /e/ on Samsung A5 with Bouygues as provider ans i dont have any issue with GPS. Works quite fine after some seconds when I open any map apps…
Could it be due to some settings in Settings > Network & Internet > Mobile Network???

1 Like

Do you have “supl” in your APN types ?


Thanks @smu44.
If that van help, on my A5 I have that settings for APN with Bouygues:

This topic was automatically closed after 15 days. New replies are no longer allowed.