Location Service is in a VERY BAD State

Hello,

I have a Xiaomi Redmi Note 5 Pro Whyred. /e/ OS v1.0

The location is not at all accurate. It shows my location some 30 K.M. away from my actual location. I suspect Advanced Privacy to be the issue. I have it set to use my real location. The moment I turn it OFF, my location is closer but not accurate. The range is of 1 to 2 KM away.
The location does not even update on time.

So it basically makes Navigation and location based apps like OSMAND+, Uber and Zomato useless.

After reading a lot of posts regarding the same issue, I downloaded multiple location modules.

  • Apple Wi-Fi
  • Deja Vu Location Service
  • GSM Location Service
  • Mozilla Location Service

I have used them together as well as individually, but to no avail.

The only time I get accurate location is when I am on my home wifi and mobile data with location service on.
Is there a solution being worked on for this massive issue?

Just to be clear, this was not an issue when using Android 10 just a few weeks ago before migrating to /e/ OS/

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I think Advanced privacy certainly brings added problems to this issue.

On one hand /e/ probably needs to get Advanced privacy under full user control.

Until this occurs, the tricks we all learned in the past are not seeming to work very well.

There is hope … Magic Earth is working again for me this weekend!

Divide an rule is the best I can offer today. :frowning_face:

I encountered the same issue. Wasn’t really happy to be located in the Philippines when I had to do my car technical control. Fortunately I could find the center on time the old way, but…

Advanced Privacy does need some option for location, application wise. I’m perfectly fine with most applications not knowing where I am, but weirdly I do would expect my GPS to know, so an option to allow that application specifically to know my real location instead of a probable randomized one is much needed.

1 Like

@Kinxil I believe it will be more controllable and / or stable in v1.1.

With a fresh ROM install 1.1-rc.3-q-20220624199212-dev-a3xelte with the correct default Advanced privacy off, Random plausible location on, carefully setting Maps permissions, I got a working Map application correctly.

Still working correctly 3 days later, and tested switchable; full disclosure, Companion Device Manager disabled.

Well I believe I have the latest possible version of the OS on my FP4 since I updated yesterday.

Tried to tweaks options here and there with no luck either on Waze or Magic Earth. Both show the random location if the option is on. So I’m kinda forced to use real location on Advanced privacy. But it’s kinda fine to me since you can fine tune permissions so I can block location permission anyway on the apps asking for location while I’d not like them to.

Here, apps accessing location is not the issue, but the apps that have been allowed location access pick up entirely wrong location.
What is the use of OSMAND having access to location if it show me that I am in an whole different district than my actual location?

Not Using Advanced Privacy is the only solution.

I have advanced privacy set use real location and have magic earth set to know my location. Magic earth thinks I am about 10 miles from my current location rebooting the phone and trying to open magic earth again does not help

With google maps there is a button that will cause maps to move to your current location if it is not correct. I don’t see any option like that in Magic Earth

For reference I have a teracube 2e with android 11 1.6

The thing in the bottom left which shows the direction and distance to your current location is a button which you can tap to take you there.
Looks like this if it’s there …

Screenshot_20220811-161910_Magic_Earth_1

This post Weather widget position not accurate - #6 by mebitek introduced me to the app SatStat | F-Droid - Free and Open Source Android App Repository. If you decide to install the app does it throw any light in the mismatch you see ?

try to install “local NLP backend” from f-droid, enable it on microG settings and disable mozilla location service on microG settings

1 Like

I downloaded satstat from f-droid. It initially showed the same wrong location. Briefly it showed 2 map pins the 2nd one was the correct location. Then magic earth showed the right location. Then a few minutes later satstat started showing only the old incorrect location. After this change in location magic earth once again showed the same incorrect location. I am in Dana Point CA. The screen shot from satstat show a location in Aliso Viejo CA

[mebitek] I installed local nlp backend and turned it on in micro g. I disabled mozilla under micro g and rebooted. Magic Earth still shows a map location in Aliso Viejo CA. The screen shot above shows Mission Viejo. The actual map pin is in the next city over. When I search for a known address in Magic Earth it says no gps position

I found part of the problem the local nlp backend will not stay activated, the slider keeps going to the off position.

I think this experiment has illustrated that the phone derives location from the gps sensor and “internet sources”, but in your case at the moment, “internet sources” is favoured over gps.

In my case I have “internet sources” putting me in different places from day to day, one reason for this may be that my ISP offers to spoof my location as part of their standard service.

I think many of us who experience “issues” with Maps may experience gps actually gets treated as a “low certainty” fix.

I certainly had trouble with Maps to start with. Now I can perform a clean install and have Maps working correctly in 24 hours.

You are likely to find many of my tips scattered around the #gps threads on the forum.

I believe that the essence is not to sit indoors watching gps not working !

You first have to go to the permission manager and allow Local NLP Backend to access the location all the time, then you can enable it.

I changed permission for the NLP back end, it will now stay enabled. I get an incorrect map reading unless I run an app called satstat once that app finds my location then magic earth will find my location.

1 Like